mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-06 11:26:55 -05:00
gnu: gdk-pixbuf: Add missing arguments.
* gnu/packages/patches/gdk-pixbuf-CVE-2020-29385.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Unregister it. * gnu/packages/gtk.scm (gdk-pixbuf) [arguments]<#:glib-or-gtk?>: New argument. [replacement]: Remove. (gdk-pixbuf/fixed): Remove. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
This commit is contained in:
parent
abc0ea3200
commit
298352a302
3 changed files with 41 additions and 104 deletions
|
@ -1060,7 +1060,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gdb-hurd.patch \
|
||||
%D%/packages/patches/gd-fix-tests-on-i686.patch \
|
||||
%D%/packages/patches/gd-brect-bounds.patch \
|
||||
%D%/packages/patches/gdk-pixbuf-CVE-2020-29385.patch \
|
||||
%D%/packages/patches/gdm-default-session.patch \
|
||||
%D%/packages/patches/geary-CVE-2020-24661.patch \
|
||||
%D%/packages/patches/genimage-signedness.patch \
|
||||
|
|
|
@ -581,7 +581,6 @@ (define-public gdk-pixbuf
|
|||
(package
|
||||
(name "gdk-pixbuf")
|
||||
(version "2.42.2")
|
||||
(replacement gdk-pixbuf/fixed)
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
|
@ -593,6 +592,7 @@ (define-public gdk-pixbuf
|
|||
(build-system meson-build-system)
|
||||
(arguments
|
||||
`(#:meson ,meson-0.55
|
||||
#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
|
||||
#:configure-flags '("-Dinstalled_tests=false")
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
|
@ -625,15 +625,6 @@ (define-public gdk-pixbuf
|
|||
(license license:lgpl2.0+)
|
||||
(home-page "https://developer.gnome.org/gdk-pixbuf/")))
|
||||
|
||||
(define gdk-pixbuf/fixed
|
||||
(package
|
||||
(inherit gdk-pixbuf)
|
||||
(source (origin
|
||||
(inherit (package-source gdk-pixbuf))
|
||||
(patches
|
||||
(append (search-patches "gdk-pixbuf-CVE-2020-29385.patch")
|
||||
(origin-patches (package-source gdk-pixbuf))))))))
|
||||
|
||||
;; To build gdk-pixbuf with SVG support, we need librsvg, and librsvg depends
|
||||
;; on gdk-pixbuf, so this new varibale. Also, librsvg adds 90MiB to the
|
||||
;; closure size.
|
||||
|
|
|
@ -1,53 +0,0 @@
|
|||
Fix CVE-2020-29385. Note that we omit the binary test file
|
||||
tests/test-images/fail/hang_114.gif from the following commit, to avoid
|
||||
requiring 'git' to apply the patch.
|
||||
|
||||
|
||||
From bdd3acbd48a575d418ba6bf1b32d7bda2fae1c81 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Ancell <robert.ancell@canonical.com>
|
||||
Date: Mon, 30 Nov 2020 12:26:12 +1300
|
||||
Subject: [PATCH] gif: Fix LZW decoder accepting invalid LZW code.
|
||||
|
||||
The code value after a reset wasn't being validated, which means we would
|
||||
accept invalid codes. This could cause an infinite loop in the decoder.
|
||||
|
||||
Fixes CVE-2020-29385
|
||||
|
||||
Fixes https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/issues/164
|
||||
---
|
||||
gdk-pixbuf/lzw.c | 13 +++++++------
|
||||
tests/test-images/fail/hang_114.gif | Bin 0 -> 5561 bytes
|
||||
2 files changed, 7 insertions(+), 6 deletions(-)
|
||||
create mode 100644 tests/test-images/fail/hang_114.gif
|
||||
|
||||
diff --git a/gdk-pixbuf/lzw.c b/gdk-pixbuf/lzw.c
|
||||
index 9e052a6f7..105daf2b1 100644
|
||||
--- a/gdk-pixbuf/lzw.c
|
||||
+++ b/gdk-pixbuf/lzw.c
|
||||
@@ -195,19 +195,20 @@ lzw_decoder_feed (LZWDecoder *self,
|
||||
if (self->last_code != self->clear_code && self->code_table_size < MAX_CODES) {
|
||||
if (self->code < self->code_table_size)
|
||||
add_code (self, self->code);
|
||||
- else if (self->code == self->code_table_size)
|
||||
+ else
|
||||
add_code (self, self->last_code);
|
||||
- else {
|
||||
- /* Invalid code received - just stop here */
|
||||
- self->last_code = self->eoi_code;
|
||||
- return output_length;
|
||||
- }
|
||||
|
||||
/* When table is full increase code size */
|
||||
if (self->code_table_size == (1 << self->code_size) && self->code_size < LZW_CODE_MAX)
|
||||
self->code_size++;
|
||||
}
|
||||
|
||||
+ /* Invalid code received - just stop here */
|
||||
+ if (self->code >= self->code_table_size) {
|
||||
+ self->last_code = self->eoi_code;
|
||||
+ return output_length;
|
||||
+ }
|
||||
+
|
||||
/* Convert codeword into indexes */
|
||||
n_written += write_indexes (self, output + n_written, output_length - n_written);
|
||||
}
|
Loading…
Reference in a new issue