mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: Perl: Update cross-compilation code.
* gnu/packages/perl.scm (perl)[native-inputs]: Update "perl-cross" to 1.3.6. [arguments]: Remove obsolete patch. * gnu/packages/patches/perl-cross.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
b4553b7cad
commit
2a592d43ef
3 changed files with 6 additions and 72 deletions
|
@ -1519,7 +1519,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/patchutils-test-perms.patch \
|
||||
%D%/packages/patches/patch-hurd-path-max.patch \
|
||||
%D%/packages/patches/perl-autosplit-default-time.patch \
|
||||
%D%/packages/patches/perl-cross.patch \
|
||||
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
|
||||
%D%/packages/patches/perl-image-exiftool-CVE-2021-22204.patch \
|
||||
%D%/packages/patches/perl-net-amazon-s3-moose-warning.patch \
|
||||
|
|
|
@ -1,60 +0,0 @@
|
|||
Submitted upstream.
|
||||
|
||||
From 4c3eb19a11dfe5c88c902481a8294c4f675fcd03 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
|
||||
Date: Sun, 19 Apr 2020 23:33:28 +0200
|
||||
Subject: [PATCH] Support cross-compiling to the Hurd.
|
||||
|
||||
* cnf/hints/gnu: New file.
|
||||
* cnf/configure_tool.sh: Guess it.
|
||||
---
|
||||
cnf/configure_tool.sh | 4 ++++
|
||||
cnf/hints/gnu | 21 +++++++++++++++++++++
|
||||
2 files changed, 25 insertions(+)
|
||||
create mode 100644 cnf/hints/gnu
|
||||
|
||||
diff --git a/cnf/configure_tool.sh b/cnf/configure_tool.sh
|
||||
index 32201c0..7b0baa4 100644
|
||||
--- a/cnf/configure_tool.sh
|
||||
+++ b/cnf/configure_tool.sh
|
||||
@@ -266,6 +266,10 @@ if not hinted 'osname'; then
|
||||
define osname "bsd"
|
||||
result "BSD"
|
||||
;;
|
||||
+ *-gnu*)
|
||||
+ define osname "gnu"
|
||||
+ result "GNU"
|
||||
+ ;;
|
||||
*)
|
||||
result "no"
|
||||
;;
|
||||
diff --git a/cnf/hints/gnu b/cnf/hints/gnu
|
||||
new file mode 100644
|
||||
index 0000000..a0583a2
|
||||
--- /dev/null
|
||||
+++ b/cnf/hints/gnu
|
||||
@@ -0,0 +1,21 @@
|
||||
+# Hurd syscalls
|
||||
+d_voidsig='define'
|
||||
+d_nanosleep='undef'
|
||||
+d_clock_gettime='define'
|
||||
+d_clock_getres='define'
|
||||
+d_clock_nanosleep='define'
|
||||
+d_clock='define'
|
||||
+
|
||||
+# From the original linux.sh
|
||||
+usemallocwrap='define'
|
||||
+
|
||||
+# libraries to test
|
||||
+libswanted='m crypt pthread nm ndbm gdbm dbm db dl gdbm_compat'
|
||||
+
|
||||
+d_procselfexe='undef'
|
||||
+procselfexe='"undef"'
|
||||
+
|
||||
+st_ino_sign=1
|
||||
+st_ino_size=8
|
||||
+
|
||||
+d_fcntl_can_lock='define'
|
||||
--
|
||||
2.26.0
|
||||
|
|
@ -13,7 +13,7 @@
|
|||
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
|
||||
;;; Copyright © 2016, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
|
||||
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
|
||||
;;; Copyright © 2017, 2018, 2020 Marius Bakke <marius@gnu.org>
|
||||
;;; Copyright © 2017, 2018, 2020, 2021 Marius Bakke <marius@gnu.org>
|
||||
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
|
||||
;;; Copyright © 2017, 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
|
||||
|
@ -141,14 +141,10 @@ (define-public perl
|
|||
`((add-after 'unpack 'unpack-cross
|
||||
(lambda* (#:key native-inputs inputs #:allow-other-keys)
|
||||
(let ((cross-checkout
|
||||
(assoc-ref native-inputs "perl-cross"))
|
||||
(cross-patch
|
||||
(assoc-ref native-inputs "perl-cross-patch")))
|
||||
(assoc-ref native-inputs "perl-cross")))
|
||||
(rename-file "Artistic" "Artistic.perl")
|
||||
(rename-file "Copying" "Copying.perl")
|
||||
(copy-recursively cross-checkout ".")
|
||||
(format #t "Applying ~a\n" cross-patch)
|
||||
(invoke "patch" "-p1" "-i" cross-patch))
|
||||
(copy-recursively cross-checkout "."))
|
||||
(let ((bash (assoc-ref inputs "bash")))
|
||||
(substitute* '("Makefile.config.SH"
|
||||
"cnf/config.guess"
|
||||
|
@ -251,11 +247,10 @@ (define-public perl
|
|||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/arsv/perl-cross")
|
||||
(commit "1.3.3")))
|
||||
(file-name (git-file-name "perl-cross" "1.3.3"))
|
||||
(commit "1.3.6")))
|
||||
(file-name (git-file-name "perl-cross" "1.3.6"))
|
||||
(sha256
|
||||
(base32 "065qbl1x44maykaj8p8za0b6qxj74bz7fi2zsrlydir1mqb1js3d"))))
|
||||
("perl-cross-patch" ,@(search-patches "perl-cross.patch")))
|
||||
(base32 "0k5vyj40czbkfl7r3dcwxpc7dvdlp2xliaav358bviq3dq9vq9bb")))))
|
||||
'()))
|
||||
(native-search-paths (list (search-path-specification
|
||||
(variable "PERL5LIB")
|
||||
|
|
Loading…
Reference in a new issue