mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: fontconfig: Update to 2.12.6.
Gperf is now a hard dependency. * gnu/packages/patches/fontconfig-remove-debug-printf.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/fontutils.scm (fontconfig): Update to 2.12.6. [source]: Add 'fontconfig-remove-debug-printf.patch'. [arguments]: Remove 'regenerate-fcobjshash' phase.
This commit is contained in:
parent
5bb20a2507
commit
2b174b4ebd
3 changed files with 23 additions and 10 deletions
|
@ -636,6 +636,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/fltk-xfont-on-demand.patch \
|
%D%/packages/patches/fltk-xfont-on-demand.patch \
|
||||||
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
|
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
|
||||||
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
|
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
|
||||||
|
%D%/packages/patches/fontconfig-remove-debug-printf.patch \
|
||||||
%D%/packages/patches/freeimage-CVE-2015-0852.patch \
|
%D%/packages/patches/freeimage-CVE-2015-0852.patch \
|
||||||
%D%/packages/patches/freeimage-CVE-2016-5684.patch \
|
%D%/packages/patches/freeimage-CVE-2016-5684.patch \
|
||||||
%D%/packages/patches/freeimage-fix-build-with-gcc-5.patch \
|
%D%/packages/patches/freeimage-fix-build-with-gcc-5.patch \
|
||||||
|
|
|
@ -230,20 +230,21 @@ (define-public woff2
|
||||||
(define-public fontconfig
|
(define-public fontconfig
|
||||||
(package
|
(package
|
||||||
(name "fontconfig")
|
(name "fontconfig")
|
||||||
(version "2.12.3")
|
(version "2.12.6")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
"https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
|
"https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
|
||||||
version ".tar.bz2"))
|
version ".tar.bz2"))
|
||||||
|
(patches (search-patches "fontconfig-remove-debug-printf.patch"))
|
||||||
(sha256 (base32
|
(sha256 (base32
|
||||||
"1ggq6jmz3mlzk4xjs615aqw9h3hq33chjn82bhli26kk09kby95x"))))
|
"05zh65zni11kgnhg726gjbrd55swspdvhqbcnj5a5xh8gn03036g"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(propagated-inputs `(("expat" ,expat)
|
(propagated-inputs `(("expat" ,expat)
|
||||||
("freetype" ,freetype)))
|
("freetype" ,freetype)))
|
||||||
(inputs `(("gs-fonts" ,gs-fonts)))
|
(inputs `(("gs-fonts" ,gs-fonts)))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("gperf" ,gperf) ; Try dropping this for > 2.12.3.
|
`(("gperf" ,gperf)
|
||||||
("pkg-config" ,pkg-config)))
|
("pkg-config" ,pkg-config)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
|
@ -262,13 +263,6 @@ (define-public fontconfig
|
||||||
"PYTHON=false")
|
"PYTHON=false")
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
(add-before 'configure 'regenerate-fcobjshash
|
|
||||||
;; XXX The pre-generated gperf files are broken.
|
|
||||||
;; See <https://bugs.freedesktop.org/show_bug.cgi?id=101280>.
|
|
||||||
(lambda _
|
|
||||||
(delete-file "src/fcobjshash.h")
|
|
||||||
(delete-file "src/fcobjshash.gperf")
|
|
||||||
#t))
|
|
||||||
(replace 'install
|
(replace 'install
|
||||||
(lambda _
|
(lambda _
|
||||||
;; Don't try to create /var/cache/fontconfig.
|
;; Don't try to create /var/cache/fontconfig.
|
||||||
|
|
18
gnu/packages/patches/fontconfig-remove-debug-printf.patch
Normal file
18
gnu/packages/patches/fontconfig-remove-debug-printf.patch
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
Fontconfig 2.12.5 and 2.12.6 was released with a stray debugging statement.
|
||||||
|
See <https://lists.freedesktop.org/archives/fontconfig/2017-October/006079.html>.
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
https://cgit.freedesktop.org/fontconfig/commit/?id=b56207a069be2574df455ede0a6ab61f44d5ca2b
|
||||||
|
|
||||||
|
diff --git a/fc-query/fc-query.c b/fc-query/fc-query.c
|
||||||
|
index 842a8b6..6cd5abd 100644
|
||||||
|
--- a/fc-query/fc-query.c
|
||||||
|
+++ b/fc-query/fc-query.c
|
||||||
|
@@ -170,7 +170,6 @@ main (int argc, char **argv)
|
||||||
|
FcPattern *pat;
|
||||||
|
|
||||||
|
id = ((instance_num << 16) + face_num);
|
||||||
|
- printf("id %d\n", id);
|
||||||
|
if (FT_New_Face (ftLibrary, argv[i], id, &face))
|
||||||
|
break;
|
||||||
|
num_faces = face->num_faces;
|
Loading…
Reference in a new issue