mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: mesa: Update to 21.1.6.
* gnu/packages/gl.scm (mesa): Update to 21.1.6. * gnu/packages/patches/mesa-skip-tests.patch: Remove cache_test.c as it is no longer needed (test passes). Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
554e09254c
commit
2c0013916e
2 changed files with 6 additions and 25 deletions
|
@ -16,6 +16,7 @@
|
|||
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
|
||||
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
|
||||
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -238,7 +239,7 @@ (define libva-without-mesa
|
|||
(define-public mesa
|
||||
(package
|
||||
(name "mesa")
|
||||
(version "20.2.6")
|
||||
(version "21.1.6")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -250,7 +251,7 @@ (define-public mesa
|
|||
version "/mesa-" version ".tar.xz")))
|
||||
(sha256
|
||||
(base32
|
||||
"1nw5k2qrlcrp5bljy1lmyybgl525y0h44synkbbirw92qv3a6b7i"))
|
||||
"0dwyk7cxlwna24ap23i8i92a2qcc6xhp16i03zzakpqiz4i03jxi"))
|
||||
(patches
|
||||
(search-patches "mesa-skip-tests.patch"))))
|
||||
(build-system meson-build-system)
|
||||
|
@ -310,7 +311,7 @@ (define-public mesa
|
|||
"-Dglx=dri" ;Thread Local Storage, improves performance
|
||||
;; "-Dopencl=true"
|
||||
;; "-Domx=true"
|
||||
"-Dosmesa=gallium"
|
||||
"-Dosmesa=true"
|
||||
"-Dgallium-xa=enabled"
|
||||
|
||||
;; features required by wayland
|
||||
|
@ -418,8 +419,8 @@ (define-public mesa
|
|||
(let ((out (assoc-ref outputs "out"))
|
||||
(bin (assoc-ref outputs "bin")))
|
||||
;; Not all architectures have the Vulkan overlay control script.
|
||||
(mkdir-p (string-append bin "/bin"))
|
||||
(call-with-output-file (string-append bin "/bin/.empty")
|
||||
(mkdir-p (string-append out "/bin"))
|
||||
(call-with-output-file (string-append out "/bin/.empty")
|
||||
(const #t))
|
||||
(copy-recursively (string-append out "/bin")
|
||||
(string-append bin "/bin"))
|
||||
|
|
|
@ -1,23 +1,3 @@
|
|||
disk_cache_create() here looks up the users home directory from <pwd.h>
|
||||
which resolves to "/" in the build environment. I could not find an easy
|
||||
way to set the home directory to something else, so we disable this test
|
||||
for now.
|
||||
|
||||
--- a/src/compiler/glsl/tests/cache_test.c
|
||||
+++ b/src/compiler/glsl/tests/cache_test.c
|
||||
@@ -170,11 +170,6 @@
|
||||
unsetenv("MESA_GLSL_CACHE_DIR");
|
||||
unsetenv("XDG_CACHE_HOME");
|
||||
|
||||
- cache = disk_cache_create("test", "make_check", 0);
|
||||
- expect_non_null(cache, "disk_cache_create with no environment variables");
|
||||
-
|
||||
- disk_cache_destroy(cache);
|
||||
-
|
||||
/* Test with XDG_CACHE_HOME set */
|
||||
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
|
||||
cache = disk_cache_create("test", "make_check", 0);
|
||||
|
||||
This test fails on i686-linux. I couldn't come up with a regex that
|
||||
could be used to disable it just on i686-linux, so we disable it
|
||||
completely with this patch:
|
||||
|
|
Loading…
Reference in a new issue