mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: scilab: Update to 2024.1.0.
* gnu/packages/maths.scm (scilab): Update to 2024.1.0. * gnu/packages/patches/scilab-tbx_build_help.patch: Update patch. Change-Id: I79197822aefba698b2383e3aa30fbc511da6954c Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
9149aa79d9
commit
2e433799c5
2 changed files with 17 additions and 20 deletions
|
@ -9891,7 +9891,7 @@ (define-public optizelle
|
||||||
(define-public scilab
|
(define-public scilab
|
||||||
(package
|
(package
|
||||||
(name "scilab")
|
(name "scilab")
|
||||||
(version "2024.0.0")
|
(version "2024.1.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
|
@ -9901,7 +9901,7 @@ (define-public scilab
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"08nyfli3x7gd396ffd1a8zn9fj3gm6a8yw0ggm547c09sp2rgvl7"))
|
"1qk0pf1cwcvdqjza9xqkynd90ywq0yh421bz59w5zjzbs40ijnrx"))
|
||||||
(patches (search-patches "scilab-better-compiler-detection.patch"
|
(patches (search-patches "scilab-better-compiler-detection.patch"
|
||||||
"scilab-tbx_build_help.patch"))
|
"scilab-tbx_build_help.patch"))
|
||||||
(modules '((guix build utils)
|
(modules '((guix build utils)
|
||||||
|
|
|
@ -1,38 +1,35 @@
|
||||||
From c59d78c5a5c8c187450f157cf7f8480455e8e6a2 Mon Sep 17 00:00:00 2001
|
From 24a9bc240729b7630e20a7b83b75f086024ae03d Mon Sep 17 00:00:00 2001
|
||||||
From: Nicolas Graves <ngraves@ngraves.fr>
|
From: Nicolas Graves <ngraves@ngraves.fr>
|
||||||
Date: Wed, 3 Apr 2024 03:32:23 +0200
|
Date: Wed, 21 Aug 2024 15:42:35 +0200
|
||||||
Subject: [PATCH] scilab: tbx_build_help: Allow for some flexibility under
|
Subject: [PATCH] scilab: tbx_build_help: Allow for some flexibility under
|
||||||
-nwni.
|
-nwni.
|
||||||
|
|
||||||
upstream reference: https://gitlab.com/scilab/scilab/-/merge_requests/818
|
upstream reference: https://gitlab.com/scilab/scilab/-/merge_requests/818
|
||||||
|
|
||||||
---
|
---
|
||||||
.../modules_manager/macros/tbx_build_help.sci | 12 ++++++------
|
scilab/modules/modules_manager/macros/tbx_build_help.sci | 5 +++--
|
||||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/scilab/modules/modules_manager/macros/tbx_build_help.sci b/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
diff --git a/scilab/modules/modules_manager/macros/tbx_build_help.sci b/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
||||||
index 7862e33a868..5593ee3dc04 100644
|
index ab06b3fa8dc..cbb1b4cadf8 100644
|
||||||
--- a/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
--- a/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
||||||
+++ b/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
+++ b/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
||||||
@@ -58,12 +58,12 @@ function tbx_build_help(moduletitle, path)
|
@@ -57,8 +57,8 @@ function tbx_build_help(moduletitle, path)
|
||||||
|
|
||||||
// Check scilab mode
|
// Check scilab mode
|
||||||
if and(getscilabmode() <> ["STD" "NW"]) then
|
if and(getscilabmode() <> ["STD" "NW"]) then
|
||||||
- error(msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode()));
|
- error(msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode()));
|
||||||
|
- end
|
||||||
+ msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode());
|
+ msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode());
|
||||||
+ else
|
+ else
|
||||||
+ directory_language = basename(path);
|
|
||||||
+ default_language = "en_US"
|
|
||||||
+
|
|
||||||
+ xmltojar(path, moduletitle, directory_language, default_language);
|
|
||||||
end
|
|
||||||
|
|
||||||
- directory_language = basename(path);
|
directory_language = basename(path);
|
||||||
- default_language = "en_US"
|
default_language = "en_US"
|
||||||
-
|
@@ -89,4 +89,5 @@ function tbx_build_help(moduletitle, path)
|
||||||
- xmltojar(path, moduletitle, directory_language, default_language);
|
warning(_(".start file was not found, build of help pages using <scilab:image> tag may failed."));
|
||||||
-
|
xmltojar(path, moduletitle, directory_language, default_language);
|
||||||
|
end
|
||||||
|
+ end
|
||||||
endfunction
|
endfunction
|
||||||
--
|
--
|
||||||
2.41.0
|
2.45.2
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue