gnu: imagemagick: Update to 6.9.13-5.

This is a follow-up to ac658511ae ("gnu: imagemagick: Update to 6.9.12-91."),
which patch didn't apply cleanly.

* gnu/packages/imagemagick.scm (imagemagick/stable): Update to 6.9.13-5.
[source]: Remove patch.
[configure-flags]: Specify correct --with-gs-font-dir location.
[native-inputs]: Add zstd.
* gnu/packages/patches/imagemagick-fix-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
* gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.13-5.

Change-Id: Ic3ab5ea821de91fb18b80325414444e02e7eecb0
This commit is contained in:
Maxim Cournoyer 2024-01-23 11:19:47 -05:00 committed by Ludovic Courtès
parent f5d75acd0d
commit 2e4e3e883b
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 17 additions and 38 deletions

View file

@ -1536,7 +1536,6 @@ dist_patch_DATA = \
%D%/packages/patches/idris-test-ffi008.patch \
%D%/packages/patches/igraph-fix-varargs-integer-size.patch \
%D%/packages/patches/ilmbase-fix-tests.patch \
%D%/packages/patches/imagemagick-fix-tests.patch \
%D%/packages/patches/inkscape-poppler-compat.patch \
%D%/packages/patches/instead-use-games-path.patch \
%D%/packages/patches/intltool-perl-compatibility.patch \

View file

@ -65,23 +65,25 @@ (define-public imagemagick/stable
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
(version "6.9.12-91")
(version "6.9.13-5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
"0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
(patches
(search-patches "imagemagick-fix-tests.patch"))))
"1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))
(build-system gnu-build-system)
(arguments
(list
#:configure-flags #~(list "--with-frozenpaths" "--without-gcc-arch"
;; Do not embed the build date in binaries.
"--enable-reproducible-build")
#:configure-flags
#~(list "--with-frozenpaths"
"--without-gcc-arch"
(string-append "--with-gs-font-dir="
(search-input-directory %build-inputs
"share/fonts/type1"))
;; Do not embed the build date in binaries.
"--enable-reproducible-build")
#:phases
#~(modify-phases %standard-phases
(add-before 'build 'pre-build
@ -124,8 +126,11 @@ (define-public imagemagick/stable
libxml2
pango
xz
zlib))
(native-inputs (list pkg-config))
zlib
zstd))
(native-inputs
(list font-ghostscript
pkg-config))
(outputs '("out"
"doc")) ; 26 MiB of HTML documentation
(home-page "https://www.imagemagick.org/")
@ -146,16 +151,14 @@ (define-public imagemagick
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
(version "6.9.12-91")
(version "6.9.13-5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
"0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
(patches
(search-patches "imagemagick-fix-tests.patch"))))))
"1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))))
(define-public perl-image-magick
(package

View file

@ -1,23 +0,0 @@
From 696d8735e05688d0162b769f37b0d75205ab2a97 Mon Sep 17 00:00:00 2001
From: Saku Laesvuori <saku@laesvuori.fi>
Date: Thu, 20 Jul 2023 19:14:43 +0300
Subject: [PATCH] Fix tests
---
Magick++/demo/demo.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/Magick++/demo/demo.cpp b/Magick++/demo/demo.cpp
index 14721dbcd..12cc3b10c 100644
--- a/Magick++/demo/demo.cpp
+++ b/Magick++/demo/demo.cpp
@@ -477,7 +477,7 @@ int main( int /*argc*/, char ** argv)
montageOpts.compose( OverCompositeOp );
montageOpts.backgroundColor( "#ffffff" );
montageOpts.pointSize( 18 );
+ montageOpts.font(MAGICK_FONT);
montageOpts.fillColor( "#600" );
montageOpts.strokeColor( Color() );
montageOpts.compose(OverCompositeOp);
--
2.41.0