mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 22:26:40 -05:00
gnu: lksctp-tools: Fix build of include file.
* gnu/packages/patches/lksctp-tools-1.0.18-fix-header-file-name.patch: New file. * gnu/local.mk[patches]: Add it. * gnu/packages/networking.scm(/lksctp-tools)[source]: Use this patch.
This commit is contained in:
parent
fca8ef0d76
commit
3281ba6eae
3 changed files with 35 additions and 0 deletions
|
@ -1266,6 +1266,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libffi-float128-powerpc64le.patch \
|
%D%/packages/patches/libffi-float128-powerpc64le.patch \
|
||||||
%D%/packages/patches/libvirt-add-install-prefix.patch \
|
%D%/packages/patches/libvirt-add-install-prefix.patch \
|
||||||
%D%/packages/patches/libziparchive-add-includes.patch \
|
%D%/packages/patches/libziparchive-add-includes.patch \
|
||||||
|
%D%/packages/patches/lksctp-tools-1.0.18-fix-header-file-name.patch \
|
||||||
%D%/packages/patches/localed-xorg-keyboard.patch \
|
%D%/packages/patches/localed-xorg-keyboard.patch \
|
||||||
%D%/packages/patches/kdiagram-Fix-missing-link-libraries.patch \
|
%D%/packages/patches/kdiagram-Fix-missing-link-libraries.patch \
|
||||||
%D%/packages/patches/kiki-level-selection-crash.patch \
|
%D%/packages/patches/kiki-level-selection-crash.patch \
|
||||||
|
|
|
@ -448,6 +448,8 @@ (define-public lksctp-tools
|
||||||
(url "https://github.com/sctp/lksctp-tools")
|
(url "https://github.com/sctp/lksctp-tools")
|
||||||
(commit (string-append "v" version))))
|
(commit (string-append "v" version))))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
|
(patches
|
||||||
|
(search-patches "lksctp-tools-1.0.18-fix-header-file-name.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1x4fwzrlzvfa3vcpja97m8w5g9ir2zrh4zs7zksminrnmdrs0dsr"))))
|
(base32 "1x4fwzrlzvfa3vcpja97m8w5g9ir2zrh4zs7zksminrnmdrs0dsr"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
|
|
@ -0,0 +1,32 @@
|
||||||
|
From 378560050a8f93786c590cc99a55461666205b61 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Xin Long <lucien.xin@gmail.com>
|
||||||
|
Date: Fri, 24 Aug 2018 01:13:32 +0800
|
||||||
|
Subject: [PATCH] build: fix netinet/sctp.h not to be installed
|
||||||
|
|
||||||
|
After libcnetinet_HEADERS was set to sctp.h.in, netinet/sctp.h can
|
||||||
|
no longer be installed into ${includedir}.
|
||||||
|
|
||||||
|
Since "AC_CONFIG_HEADERS([src/include/netinet/sctp.h])" is already
|
||||||
|
added into configure.ac, there's no need to generate sctp.h by
|
||||||
|
automake.
|
||||||
|
|
||||||
|
So we simply set libcnetinet_HEADERS back to sctp.h.
|
||||||
|
|
||||||
|
Fixes: 9607dd85e70a ("netinet/sctp.h: dynamically build based on system setup")
|
||||||
|
Signed-off-by: Xin Long <lucien.xin@gmail.com>
|
||||||
|
Signed-off-by: Marcelo Ricardo Leitner <marcelo.leitner@gmail.com>
|
||||||
|
---
|
||||||
|
src/include/netinet/Makefile.am | 3 +--
|
||||||
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/include/netinet/Makefile.am b/src/include/netinet/Makefile.am
|
||||||
|
index ca0aac2..965db8c 100644
|
||||||
|
--- a/src/include/netinet/Makefile.am
|
||||||
|
+++ b/src/include/netinet/Makefile.am
|
||||||
|
@@ -11,5 +11,4 @@ libcnetinetdir = $(includedir)/netinet
|
||||||
|
# API.
|
||||||
|
include_HEADERS =
|
||||||
|
|
||||||
|
-libcnetinet_HEADERS = sctp.h.in
|
||||||
|
-BUILT_SOURCES = sctp.h
|
||||||
|
+libcnetinet_HEADERS = sctp.h
|
Loading…
Reference in a new issue