gnu: u-boot: Use DDR3 patch for Nano Pi R4S.

* gnu/packages/bootloaders.scm (%u-boot-nanopi-r4s-ddr3-patch): Add
variable.
(u-boot)[source]: Use patch.
* gnu/packages/patches/u-boot-nanopi-r4s-ddr3.patch: Add file.
* gnu/local.mk (dist_patch_DATA): Register patch.

Change-Id: Ibbf952f2806c9cac7fc29e1264d427bf6ee67d01
This commit is contained in:
Herman Rimm 2024-03-23 09:19:03 +01:00 committed by Ryan Schanzenbacher
parent 4164ff51a9
commit 33c1b42ea4
Signed by: ryan77627
GPG key ID: 81B0E222A3E2308E
3 changed files with 43 additions and 2 deletions

View file

@ -62,7 +62,7 @@
# Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
# Copyright © 2023 Bruno Victal <mirai@makinata.eu>
# Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
# Copyright © 2023 Herman Rimm <herman@rimm.ee>
# Copyright © 2023, 2024 Herman Rimm <herman@rimm.ee>
# Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
# Copyright © 2024 David Elsing <david.elsing@posteo.net>
# Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
@ -2230,6 +2230,7 @@ dist_patch_DATA = \
%D%/packages/patches/u-boot-build-without-libcrypto.patch \
%D%/packages/patches/u-boot-nintendo-nes-serial.patch \
%D%/packages/patches/u-boot-rockchip-inno-usb.patch \
%D%/packages/patches/u-boot-nanopi-r4s-ddr3.patch \
%D%/packages/patches/ucx-tcp-iface-ioctl.patch \
%D%/packages/patches/ultrastar-deluxe-no-freesans.patch \
%D%/packages/patches/ungoogled-chromium-extension-search-path.patch \

View file

@ -750,6 +750,10 @@ (define %u-boot-build-without-libcrypto-patch
;; Upstream commit to fix Amlogic builds in u-boot 2024.01.
(search-patch "u-boot-build-without-libcrypto.patch"))
(define %u-boot-nanopi-r4s-ddr3-patch
;; Use DDR3 instead of LPDDR4 for the Nano Pi R4S U-boot.
(search-patch "u-boot-nanopi-r4s-ddr3.patch"))
(define u-boot
(package
(name "u-boot")
@ -758,7 +762,8 @@ (define u-boot
(patches
(list %u-boot-rockchip-inno-usb-patch
%u-boot-build-without-libcrypto-patch
%u-boot-allow-disabling-openssl-patch))
%u-boot-allow-disabling-openssl-patch
%u-boot-nanopi-r4s-ddr3-patch))
(method url-fetch)
(uri (string-append
"https://ftp.denx.de/pub/u-boot/"

View file

@ -0,0 +1,35 @@
Someone created a thread on the U-Boot mailing list [1], referencing work
done to support variants of RK3399 SoCs with different types of DRAM [2].
This patch configures the Nano Pi R4S to use DDR3 instead of LPDDR4, but
will be removed once [2] is included in a future U-Boot release. This
patch was created around April 2023 by Herman Rimm <herman@rimm.ee> for
personal use and has only been submitted to GNU Guix.
[1]: https://patchwork.ozlabs.org/project/uboot/patch/WwCslkoi6ts6A8RCd6KlxuRAMpItkfneEG-3BbNbG61gWVz0A2A3-0hl_Jg7W9quLr19luuiiT7naEi7djncCaEruUOnVq3pnb9dQFU_GqY=@protonmail.com/#2973664
[2]: https://github.com/anaelorlinski/OpenWrt-NanoPi-R2S-R4S-Builds/commit/9d836044340ddef53f5d9f1946ac48c946a78284
diff --git a/arch/arm/dts/rk3399-nanopi-r4s-u-boot.dtsi b/arch/arm/dts/rk3399-nanopi-r4s-u-boot.dtsi
index 69800cc368..a3054849f8 100644
--- a/arch/arm/dts/rk3399-nanopi-r4s-u-boot.dtsi
+++ b/arch/arm/dts/rk3399-nanopi-r4s-u-boot.dtsi
@@ -13,7 +13,7 @@
*/
#include "rk3399-nanopi4-u-boot.dtsi"
-#include "rk3399-sdram-lpddr4-100.dtsi"
+#include "rk3399-sdram-ddr3-1866.dtsi"
/ {
smbios {
diff --git a/configs/nanopi-r4s-rk3399_defconfig b/configs/nanopi-r4s-rk3399_defconfig
index 4f4363cb0f..bfa7ee628d 100644
--- a/configs/nanopi-r4s-rk3399_defconfig
+++ b/configs/nanopi-r4s-rk3399_defconfig
@@ -54,7 +54,6 @@ CONFIG_PMIC_RK8XX=y
CONFIG_REGULATOR_PWM=y
CONFIG_REGULATOR_RK8XX=y
CONFIG_PWM_ROCKCHIP=y
-CONFIG_RAM_ROCKCHIP_LPDDR4=y
CONFIG_BAUDRATE=1500000
CONFIG_DEBUG_UART_SHIFT=2
CONFIG_SYS_NS16550_MEM32=y