gnu: openscad: Update to 2021.01 [maybe fixes TALOS-2020-1222, TALOS-2020-1223].

TALOS-2020-1222 has yet to be disclosed and has no known CVE number.
TALOS-2020-1223 has CVE-2020-28599 assigned.

* gnu/packages/engineering.scm (openscad): Update to 2021.01.
[patches]: Remove. Boost 1.72 is supported now upstream.
[arguments]: In replacement 'check phase, disable some tests requiring
experimental "lazy-union" feature. Also disable PDF-related tests requiring
ghostscript and failing either way.
* gnu/local.mk (dist_patch_DATA): Remove patch.
* gnu/packages/patches/openscad-parser-boost-1.72.patch: Ditto.
This commit is contained in:
Léo Le Bouter 2021-03-01 02:56:51 +01:00
parent 3d5c5cf611
commit 3505d86502
No known key found for this signature in database
GPG key ID: 45A8B1E86BCD10A6
3 changed files with 13 additions and 32 deletions

View file

@ -1429,7 +1429,6 @@ dist_patch_DATA = \
%D%/packages/patches/openssh-fix-ssh-copy-id.patch \
%D%/packages/patches/openssh-hurd.patch \
%D%/packages/patches/openresolv-restartcmd-guix.patch \
%D%/packages/patches/openscad-parser-boost-1.72.patch \
%D%/packages/patches/opensles-add-license-file.patch \
%D%/packages/patches/openssl-runpath.patch \
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \

View file

@ -2476,7 +2476,7 @@ (define-public lib3mf
(define-public openscad
(package
(name "openscad")
(version "2019.05")
(version "2021.01")
(source
(origin
(method url-fetch)
@ -2484,9 +2484,7 @@ (define-public openscad
".src.tar.gz"))
(sha256
(base32
"0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))
(patches (search-patches
"openscad-parser-boost-1.72.patch"))))
"0n83szr88h8snccjrslr96mgw3f65x3sq726n6x5vxp5wybw4f6r"))))
(build-system cmake-build-system)
(inputs
`(("boost" ,boost)
@ -2529,7 +2527,17 @@ (define-public openscad
(with-directory-excursion "tests"
(invoke "cmake" ".")
(invoke "make")
(invoke "ctest"))
(invoke "ctest" "--exclude-regex"
(string-join
(list
"astdumptest_allexpressions"
"echotest_function-literal-compare"
"echotest_function-literal-tests"
"echotest_allexpressions"
"lazyunion-*"
"pdfexporttest_centered"
"pdfexporttest_simple-pdf")
"|")))
;; strip python test files since lib dir ends up in out/share
(for-each delete-file
(find-files "libraries/MCAD" ".*\\.py"))

View file

@ -1,26 +0,0 @@
https://github.com/openscad/openscad/commit/b6c170cc5d.patch
From b6c170cc5dd1bc677176ee732cdb0ddae57e5cf0 Mon Sep 17 00:00:00 2001
From: Jan Beich <jbeich@FreeBSD.org>
Date: Fri, 25 Oct 2019 15:10:26 +0000
Subject: [PATCH] Add missing header bootlegged by Boost < 1.72
src/parser.y:76:6: error: no template named 'stack' in namespace 'std'
std::stack<LocalScope *> scope_stack;
~~~~~^
---
src/parser.y | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/parser.y b/src/parser.y
index 7f4fd56ca7..4c77c989ea 100644
--- a/src/parser.y
+++ b/src/parser.y
@@ -46,6 +46,7 @@
#include "printutils.h"
#include "memory.h"
#include <sstream>
+#include <stack>
#include <boost/filesystem.hpp>
#include "boost-utils.h"
#include "feature.h"