mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
Merge branch 'master' into core-updates
This commit is contained in:
commit
359aba76b6
7 changed files with 33 additions and 13 deletions
|
@ -515,6 +515,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
||||||
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
||||||
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
|
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
|
||||||
|
%D%/packages/patches/gd-fix-gd2-read-test.patch \
|
||||||
%D%/packages/patches/gd-fix-tests-on-i686.patch \
|
%D%/packages/patches/gd-fix-tests-on-i686.patch \
|
||||||
%D%/packages/patches/gegl-CVE-2012-4433.patch \
|
%D%/packages/patches/gegl-CVE-2012-4433.patch \
|
||||||
%D%/packages/patches/geoclue-config.patch \
|
%D%/packages/patches/geoclue-config.patch \
|
||||||
|
|
|
@ -772,15 +772,15 @@ (define-public perl-dbd-pg
|
||||||
(define-public perl-dbd-mysql
|
(define-public perl-dbd-mysql
|
||||||
(package
|
(package
|
||||||
(name "perl-dbd-mysql")
|
(name "perl-dbd-mysql")
|
||||||
(version "4.033")
|
(version "4.035")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://cpan/authors/id/C/CA/CAPTTOFU/"
|
(uri (string-append "mirror://cpan/authors/id/M/MI/MICHIELB/"
|
||||||
"DBD-mysql-" version ".tar.gz"))
|
"DBD-mysql-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0769xakykps0cx368g4vaips4w3bjk383rianiavq7sq6g6bp66c"))))
|
"0dqrnrk8yjl06xl8hld5wyalk77z0h9j5h1gdk4z9g0nx9js7v5p"))))
|
||||||
(build-system perl-build-system)
|
(build-system perl-build-system)
|
||||||
;; Tests require running MySQL server
|
;; Tests require running MySQL server
|
||||||
(arguments `(#:tests? #f))
|
(arguments `(#:tests? #f))
|
||||||
|
|
|
@ -50,7 +50,8 @@ (define-public gd
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
|
"0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
|
||||||
(patches (search-patches "gd-fix-tests-on-i686.patch"))))
|
(patches (search-patches "gd-fix-gd2-read-test.patch"
|
||||||
|
"gd-fix-tests-on-i686.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)))
|
`(("pkg-config" ,pkg-config)))
|
||||||
|
|
|
@ -331,7 +331,7 @@ (define-public iodine
|
||||||
(define-public wireshark
|
(define-public wireshark
|
||||||
(package
|
(package
|
||||||
(name "wireshark")
|
(name "wireshark")
|
||||||
(version "2.0.4")
|
(version "2.0.5")
|
||||||
(synopsis "Network traffic analyzer")
|
(synopsis "Network traffic analyzer")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
|
@ -340,7 +340,7 @@ (define-public wireshark
|
||||||
version ".tar.bz2"))
|
version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"19g11m8m8qd7dkcvcb27lyppklg608d9ap7wr3mr88clm4nwiacy"))))
|
"02xi3fz8blcz9cf75rs11g7bijk06wm45vpgnksp72c2609j9q0c"))))
|
||||||
(build-system glib-or-gtk-build-system)
|
(build-system glib-or-gtk-build-system)
|
||||||
(inputs `(("bison" ,bison)
|
(inputs `(("bison" ,bison)
|
||||||
("c-ares" ,c-ares)
|
("c-ares" ,c-ares)
|
||||||
|
|
14
gnu/packages/patches/gd-fix-gd2-read-test.patch
Normal file
14
gnu/packages/patches/gd-fix-gd2-read-test.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
Fix a 'maybe-uninitialized' warning (turned error)
|
||||||
|
which occurs on non-Intel platforms.
|
||||||
|
|
||||||
|
--- libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-21 01:21:16.000000000 -0400
|
||||||
|
+++ libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-29 15:52:03.806405312 -0400
|
||||||
|
@@ -5,7 +5,7 @@
|
||||||
|
|
||||||
|
int main(int argc, char *argv[])
|
||||||
|
{
|
||||||
|
- int error, i = 0;
|
||||||
|
+ int error = 0, i = 0;
|
||||||
|
gdImagePtr im, exp;
|
||||||
|
FILE *fp;
|
||||||
|
char *path[] = {
|
|
@ -32,14 +32,15 @@ (define-module (gnu packages protobuf)
|
||||||
(define-public protobuf
|
(define-public protobuf
|
||||||
(package
|
(package
|
||||||
(name "protobuf")
|
(name "protobuf")
|
||||||
(version "2.5.0")
|
(version "2.6.1")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://protobuf.googlecode.com/files/protobuf-"
|
(uri (string-append "https://github.com/google/protobuf/releases/"
|
||||||
|
"download/v" version "/protobuf-"
|
||||||
version ".tar.bz2"))
|
version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0xxn9gxhvsgzz2sgmihzf6pf75clr05mqj6218camwrwajpcbgqk"))))
|
"040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("zlib" ,zlib)))
|
(inputs `(("zlib" ,zlib)))
|
||||||
(home-page "http://code.google.com/p/protobuf/")
|
(home-page "http://code.google.com/p/protobuf/")
|
||||||
|
|
|
@ -29,6 +29,7 @@ (define-module (guix scripts size)
|
||||||
#:use-module (srfi srfi-1)
|
#:use-module (srfi srfi-1)
|
||||||
#:use-module (srfi srfi-9)
|
#:use-module (srfi srfi-9)
|
||||||
#:use-module (srfi srfi-11)
|
#:use-module (srfi srfi-11)
|
||||||
|
#:use-module (srfi srfi-26)
|
||||||
#:use-module (srfi srfi-34)
|
#:use-module (srfi srfi-34)
|
||||||
#:use-module (srfi srfi-37)
|
#:use-module (srfi srfi-37)
|
||||||
#:use-module (ice-9 match)
|
#:use-module (ice-9 match)
|
||||||
|
@ -119,10 +120,12 @@ (define (requisites* items)
|
||||||
information available in the local store or using information about
|
information available in the local store or using information about
|
||||||
substitutes."
|
substitutes."
|
||||||
(lambda (store)
|
(lambda (store)
|
||||||
(guard (c ((nix-protocol-error? c)
|
(let-values (((local missing)
|
||||||
(values (substitutable-requisites store items)
|
(partition (cut valid-path? store <>) items)))
|
||||||
store)))
|
(values (delete-duplicates
|
||||||
(values (requisites store items) store))))
|
(append (requisites store local)
|
||||||
|
(substitutable-requisites store missing)))
|
||||||
|
store))))
|
||||||
|
|
||||||
(define (store-profile items)
|
(define (store-profile items)
|
||||||
"Return as a monadic value a list of <profile> objects representing the
|
"Return as a monadic value a list of <profile> objects representing the
|
||||||
|
|
Loading…
Reference in a new issue