mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: xgboost: Update to 1.7.6.
* gnu/packages/machine-learning.scm (xgboost, python-xgboost): Update to 1.7.6. (python-xgboost)[arguments]: Remove #:test-flags and disable tests. * gnu/packages/patches/xgboost-use-system-dmlc-core.patch: Update patch. Change-Id: Ib0eb015f72150ef82ce386eda26749e25f816e95
This commit is contained in:
parent
33d8c6904a
commit
35afdc3b5c
2 changed files with 10 additions and 43 deletions
|
@ -3510,7 +3510,7 @@ (define-public dmlc-core
|
||||||
(define-public xgboost
|
(define-public xgboost
|
||||||
(package
|
(package
|
||||||
(name "xgboost")
|
(name "xgboost")
|
||||||
(version "1.5.2")
|
(version "1.7.6")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
|
@ -3520,7 +3520,7 @@ (define-public xgboost
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(patches (search-patches "xgboost-use-system-dmlc-core.patch"))
|
(patches (search-patches "xgboost-use-system-dmlc-core.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0qx04y7cz8z7qv6bk9q7d7ba9b7xzj53l83l2x9ykdwhzacc3dn0"))))
|
(base32 "16fbm5y3hn6ccflmbdlmn7krrdq7c0az3mxd8j1d23s9ky8niw05"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags (list "-DGOOGLE_TEST=ON")))
|
`(#:configure-flags (list "-DGOOGLE_TEST=ON")))
|
||||||
|
@ -3547,40 +3547,7 @@ (define-public python-xgboost
|
||||||
(build-system pyproject-build-system)
|
(build-system pyproject-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
(list
|
(list
|
||||||
#:test-flags
|
#:tests? #f ; all tests require network access
|
||||||
'(list "tests/python"
|
|
||||||
;; FIXME: CLI tests fail with PermissionError.
|
|
||||||
"--ignore" "tests/python/test_cli.py"
|
|
||||||
"-k"
|
|
||||||
(string-append
|
|
||||||
"not test_cli_regression_demo"
|
|
||||||
;; These tests use the Boston dataset that has been
|
|
||||||
;; removed from scipy.
|
|
||||||
" and not test_sklearn_demo"
|
|
||||||
" and not test_sklearn_parallel_demo"
|
|
||||||
" and not test_predict_shape"
|
|
||||||
" and not test_num_parallel_tree"
|
|
||||||
" and not test_boston_housing_regression"
|
|
||||||
" and not test_boston_housing_rf_regression"
|
|
||||||
" and not test_parameter_tuning"
|
|
||||||
" and not test_regression_with_custom_objective"
|
|
||||||
" and not test_RFECV"
|
|
||||||
;; Pandas incompatibility? Says:
|
|
||||||
;; '_CalibratedClassifier' object has no attribute
|
|
||||||
;; 'base_estimator'
|
|
||||||
" and not test_pandas_input"
|
|
||||||
;; Accuracy problems?
|
|
||||||
" and not test_exact"
|
|
||||||
" and not test_approx"
|
|
||||||
" and not test_hist"
|
|
||||||
;; The tests below open a network connection.
|
|
||||||
" and not test_model_compatibility"
|
|
||||||
" and not test_get_group"
|
|
||||||
" and not test_cv_no_shuffle"
|
|
||||||
" and not test_cv"
|
|
||||||
" and not test_training"
|
|
||||||
;; "'['./runexp.sh']' returned non-zero exit status 1"
|
|
||||||
" and not test_cli_binary_classification"))
|
|
||||||
#:phases
|
#:phases
|
||||||
#~(modify-phases %standard-phases
|
#~(modify-phases %standard-phases
|
||||||
(add-after 'unpack 'preparations
|
(add-after 'unpack 'preparations
|
||||||
|
|
|
@ -1,13 +1,13 @@
|
||||||
# This patch was imported from Debian: https://sources.debian.org/src/xgboost/1.5.1-1/debian/patches/cmake-dmlc-core.patch/
|
# This patch was imported from Debian: https://sources.debian.org/patches/xgboost/1.7.4-1/cmake-dmlc-core.patch/
|
||||||
|
|
||||||
Index: xgboost/CMakeLists.txt
|
Index: xgboost/CMakeLists.txt
|
||||||
===================================================================
|
===================================================================
|
||||||
--- xgboost.orig/CMakeLists.txt
|
--- xgboost.orig/CMakeLists.txt
|
||||||
+++ xgboost/CMakeLists.txt
|
+++ xgboost/CMakeLists.txt
|
||||||
@@ -164,7 +164,9 @@ endif (USE_NCCL)
|
@@ -205,7 +205,9 @@ msvc_use_static_runtime()
|
||||||
|
if (FORCE_SHARED_CRT)
|
||||||
# dmlc-core
|
set(DMLC_FORCE_SHARED_CRT ON)
|
||||||
msvc_use_static_runtime()
|
endif ()
|
||||||
-add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core)
|
-add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core)
|
||||||
+add_library(dmlc SHARED IMPORTED)
|
+add_library(dmlc SHARED IMPORTED)
|
||||||
+find_library(DMLC_LIBRARY dmlc)
|
+find_library(DMLC_LIBRARY dmlc)
|
||||||
|
@ -15,7 +15,7 @@ Index: xgboost/CMakeLists.txt
|
||||||
|
|
||||||
if (MSVC)
|
if (MSVC)
|
||||||
if (TARGET dmlc_unit_tests)
|
if (TARGET dmlc_unit_tests)
|
||||||
@@ -222,7 +224,7 @@ set_target_properties(runxgboost PROPERT
|
@@ -267,7 +269,7 @@ set_target_properties(runxgboost PROPERT
|
||||||
#-- End CLI for xgboost
|
#-- End CLI for xgboost
|
||||||
|
|
||||||
# Common setup for all targets
|
# Common setup for all targets
|
||||||
|
@ -24,7 +24,7 @@ Index: xgboost/CMakeLists.txt
|
||||||
xgboost_target_properties(${target})
|
xgboost_target_properties(${target})
|
||||||
xgboost_target_link_libraries(${target})
|
xgboost_target_link_libraries(${target})
|
||||||
xgboost_target_defs(${target})
|
xgboost_target_defs(${target})
|
||||||
@@ -273,7 +275,7 @@ install(DIRECTORY ${xgboost_SOURCE_DIR}/
|
@@ -318,7 +320,7 @@ install(DIRECTORY ${xgboost_SOURCE_DIR}/
|
||||||
#
|
#
|
||||||
# https://github.com/dmlc/xgboost/issues/6085
|
# https://github.com/dmlc/xgboost/issues/6085
|
||||||
if (BUILD_STATIC_LIB)
|
if (BUILD_STATIC_LIB)
|
||||||
|
|
Loading…
Reference in a new issue