gnu: netdde: Resurrect and update to 2.6.32.65-2-e67c284ac1.

* gnu/packages/patches/netdde-build-fix.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/hurd.scm (netdde)[source]: Update to
e67c284ac113d939b10b4578334f27dab29d5b08 and use it.
[inputs]: Add zlib:static.
[arguments]: Remove #true from build phases.  In 'build' phase, remove
obsolete CFLAGS, and also build static version.  In 'install' phase,
install them in <out>/hurd.  There is no check target, so set #:tests?
to #false.

Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
This commit is contained in:
Janneke Nieuwenhuizen 2023-05-25 07:25:26 +02:00 committed by Josselin Poiret
parent bbfb41ed9d
commit 37256c02a2
No known key found for this signature in database
GPG key ID: 505E40B916171A8A
3 changed files with 51 additions and 18 deletions

View file

@ -1618,6 +1618,7 @@ dist_patch_DATA = \
%D%/packages/patches/ncompress-fix-softlinks.patch \
%D%/packages/patches/ncftp-reproducible.patch \
%D%/packages/patches/netcdf-date-time.patch \
%D%/packages/patches/netdde-build-fix.patch \
%D%/packages/patches/netpbm-CVE-2017-2586.patch \
%D%/packages/patches/netpbm-CVE-2017-2587.patch \
%D%/packages/patches/netsurf-message-timestamp.patch \

View file

@ -553,8 +553,8 @@ (define-public hurd
(license gpl2+)))
(define-public netdde
(let ((commit "4a1016f130b6f2065d3f088325e5fb0b2997ae12")
(revision "1"))
(let ((commit "e67c284ac113d939b10b4578334f27dab29d5b08")
(revision "2"))
(package
(name "netdde")
;; The version prefix corresponds to the version of Linux from which the
@ -565,20 +565,19 @@ (define-public netdde
(uri (git-reference
(url "https://git.savannah.gnu.org/git/hurd/incubator.git")
(commit commit)))
(patches (list (search-patch "netdde-build-fix.patch")))
(sha256
(base32
"1njv9dszq4lj05yq4v9j5v247hfghpzvvz4hzy0khjjr35mw7hr8"))
"0vnkls7sr7srzib5mnw6gybzl5qa8c5a4zf3h08w6gdr7zqbndh0"))
(file-name (git-file-name name commit))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
`(#:tests? #f ;no "check" target
#:make-flags
(list (string-append "SHELL="
(search-input-file %build-inputs "/bin/bash"))
"PKGDIR=libdde_linux26"
,@(if (%current-target-system)
(list "CC=i586-pc-gnu-gcc"
"LINK_PROGRAM=i586-pc-gnu-gcc")
(list "CC=gcc")))
(string-append "CC=" ,(cc-for-target)))
#:configure-flags
,#~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
#:phases
@ -594,8 +593,7 @@ (define-public netdde
(string-append dde "/" dir ) dir))
'("libdde_linux26" "libddekit")))
(substitute* "libdde_linux26/mk/rel2abs.sh"
(("/bin/bash") (which "bash")))
#t))
(("/bin/bash") (which "bash")))))
(add-after 'patch-generated-file-shebangs 'build-libdde-linux26
(lambda* (#:key make-flags #:allow-other-keys)
(with-directory-excursion "libdde_linux26"
@ -606,17 +604,23 @@ (define-public netdde
(apply invoke "make" "convert" make-flags)))
(replace 'build
(lambda* (#:key make-flags #:allow-other-keys)
;; no-common can be dropped with GCC 10+ where this is the
;; default.
(apply invoke "make" "CFLAGS=-fno-common" make-flags)))
(apply invoke "make"
,(string-append "LINK_PROGRAM=" (cc-for-target))
make-flags)
;; This hack to build netdde.static was found in
;; https://salsa.debian.org/hurd-team/netdde/-/blob/b539b2ad7a171371f140c3da58cce33f1a91ac12/debian/rules
(delete-file "Makefile.inc")
(apply invoke "make"
,(string-append "LINK_PROGRAM=" (cc-for-target) " -static")
"TARGET=netdde.static"
make-flags)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(install-file "netdde"
(string-append (assoc-ref outputs "out")
"/bin"))
#t)))))
(let ((hurd (string-append (assoc-ref outputs "out") "/hurd")))
(install-file "netdde" hurd)
(install-file "netdde.static" hurd)))))))
(inputs
(list hurd libpciaccess-0.17 zlib))
(list hurd libpciaccess-0.17 zlib `(,zlib "static")))
(native-inputs
`(("coreutils" ,coreutils)
("gawk" ,gawk)

View file

@ -0,0 +1,28 @@
Upstream status: Presented upstream.
https://lists.gnu.org/archive/html/bug-hurd/2023-05//msg00449.html
From b0a7e4f2706bea8d1c80d5af7a095941f9635033 Mon Sep 17 00:00:00 2001
From: Janneke Nieuwenhuizen <janneke@gnu.org>
Date: Fri, 26 May 2023 17:39:17 +0200
Subject: [PATCH] Update for .../rumpdisk: Fix race condition in bootstrap
---
machdev.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/machdev.c b/machdev.c
index dda5eb8ba..1a6811072 100644
--- a/machdev.c
+++ b/machdev.c
@@ -18,5 +18,6 @@ void machdev_run1 (void *arg)
void machdev_run2(void)
{
- machdev_trivfs_server(bootstrap);
+ machdev_trivfs_server_startup(bootstrap);
+ machdev_trivfs_server_loop(NULL);
}
--
2.40.1