mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 13:28:12 -05:00
gnu: findutils: Update to 4.8.0.
* gnu/packages/base.scm (findutils): Update to 4.8.0. [source](patches): Remove "findutils-test-rwlock-threads.patch". * gnu/packages/patches/findutils-test-rwlock-threads.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/commencement.scm (findutils-boot0)[arguments]: Add 'skip-fnmatch-test' phase.
This commit is contained in:
parent
dcaa934c3d
commit
3a0c7e7d1e
4 changed files with 17 additions and 47 deletions
|
@ -1,5 +1,5 @@
|
|||
# GNU Guix --- Functional package management for GNU
|
||||
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
|
||||
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
|
||||
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Andreas Enge <andreas@enge.fr>
|
||||
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
|
||||
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
|
||||
|
@ -990,7 +990,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
||||
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
|
||||
%D%/packages/patches/findutils-localstatedir.patch \
|
||||
%D%/packages/patches/findutils-test-rwlock-threads.patch \
|
||||
%D%/packages/patches/flann-cmake-3.11.patch \
|
||||
%D%/packages/patches/foobillard++-pkg-config.patch \
|
||||
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014, 2019 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2014, 2015, 2016, 2018 Mark H Weaver <mhw@netris.org>
|
||||
|
@ -284,16 +284,15 @@ (define-public diffutils
|
|||
(define-public findutils
|
||||
(package
|
||||
(name "findutils")
|
||||
(version "4.7.0")
|
||||
(version "4.8.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/findutils/findutils-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"16kqz9yz98dasmj70jwf5py7jk558w96w0vgp3zf9xsqk3gzpzn5"))
|
||||
(patches (search-patches "findutils-localstatedir.patch"
|
||||
"findutils-test-rwlock-threads.patch"))))
|
||||
"0r3i72hnw0a30khlczi9k2c51aamaj6kfmp5mk3844nrjxz7n4jp"))
|
||||
(patches (search-patches "findutils-localstatedir.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags (list
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
|
||||
|
@ -2549,7 +2549,17 @@ (define findutils-boot0
|
|||
((or "arm-linux" "aarch64-linux")
|
||||
''("--disable-dependency-tracking"))
|
||||
(_ ''()))
|
||||
,flags)))))))
|
||||
,flags))
|
||||
((#:phases phases '%standard-phases)
|
||||
`(modify-phases ,phases
|
||||
(add-before 'check 'skip-fnmatch-test
|
||||
(lambda _
|
||||
;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
|
||||
;; to incorrect handling of the [:alpha:] regexp character
|
||||
;; class. Ignore it.
|
||||
(substitute* "gnulib-tests/Makefile"
|
||||
(("^XFAIL_TESTS =")
|
||||
"XFAIL_TESTS = test-fnmatch ")))))))))))
|
||||
|
||||
(define file
|
||||
(package
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
Skip "test-rwlock1" when multithreading is disabled, which is the case
|
||||
during bootstrapping on architectures not supported by GNU Mes.
|
||||
|
||||
Taken from upstream gnulib:
|
||||
https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=fdff8bd09a7f053381f8bdb107ab5280b7c95959
|
||||
|
||||
diff --git a/gnulib-tests/test-rwlock1.c b/gnulib-tests/test-rwlock1.c
|
||||
--- a/gnulib-tests/test-rwlock1.c
|
||||
+++ b/gnulib-tests/test-rwlock1.c
|
||||
@@ -21,6 +21,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#if USE_ISOC_THREADS || USE_POSIX_THREADS || USE_ISOC_AND_POSIX_THREADS || USE_WINDOWS_THREADS
|
||||
+
|
||||
#include "glthread/lock.h"
|
||||
|
||||
#include <errno.h>
|
||||
@@ -151,3 +153,18 @@ main ()
|
||||
sleep (1);
|
||||
}
|
||||
}
|
||||
+
|
||||
+#else
|
||||
+
|
||||
+/* No multithreading available. */
|
||||
+
|
||||
+#include <stdio.h>
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ fputs ("Skipping test: multithreading not enabled\n", stderr);
|
||||
+ return 77;
|
||||
+}
|
||||
+
|
||||
+#endif
|
||||
|
Loading…
Reference in a new issue