mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 05:18:07 -05:00
gnu: jami: Apply upstream patch that fixes a usability issue.
* gnu/packages/patches/jami-fix-esc-bug.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/jami.scm (%jami-sources): Apply it.
This commit is contained in:
parent
ccf6401d05
commit
3a656ea836
3 changed files with 27 additions and 1 deletions
|
@ -1304,6 +1304,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/irrlicht-link-against-needed-libs.patch \
|
||||
%D%/packages/patches/isl-0.11.1-aarch64-support.patch \
|
||||
%D%/packages/patches/itk-snap-alt-glibc-compat.patch \
|
||||
%D%/packages/patches/jami-fix-esc-bug.patch \
|
||||
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
|
||||
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
|
||||
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
|
||||
|
|
|
@ -90,7 +90,8 @@ (define %jami-sources
|
|||
"plugins"))))
|
||||
(sha256
|
||||
(base32
|
||||
"1zx0i9aw8jsba3bjc5r4pkkybm8c0lyz420ciq89vsswd48gfdhg"))))
|
||||
"1zx0i9aw8jsba3bjc5r4pkkybm8c0lyz420ciq89vsswd48gfdhg"))
|
||||
(patches (search-patches "jami-fix-esc-bug.patch"))))
|
||||
|
||||
;; Jami maintains a set of patches for some key dependencies (currently
|
||||
;; pjproject and ffmpeg) of Jami that haven't yet been integrated upstream.
|
||||
|
|
24
gnu/packages/patches/jami-fix-esc-bug.patch
Normal file
24
gnu/packages/patches/jami-fix-esc-bug.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
This fixes the issue where pressing the ESC key would hide the Jami
|
||||
GUI on systems lacking a notification tray.
|
||||
|
||||
From 47fd4c38ddd8bd350319ce9bb750ca496826e655 Mon Sep 17 00:00:00 2001
|
||||
From: Sébastien Blin <sebastien.blin@savoirfairelinux.com>
|
||||
Date: Fri, 29 Jul 2022 21:24:01 -0400
|
||||
Subject: [PATCH] layoutmanager: fix popFullScreenItem
|
||||
|
||||
Change-Id: I79780d4ad570846e6f3c52734dd627bcd0e11327
|
||||
---
|
||||
|
||||
diff --git a/src/app/LayoutManager.qml b/src/app/LayoutManager.qml
|
||||
index 98516ce..87f13ac 100644
|
||||
--- a/client-qt/src/app/LayoutManager.qml
|
||||
+++ b/client-qt/src/app/LayoutManager.qml
|
||||
@@ -176,7 +176,7 @@
|
||||
|
||||
// Only leave fullscreen mode if our window isn't in fullscreen
|
||||
// mode already.
|
||||
- if (priv.fullScreenItems.length === 0) {
|
||||
+ if (priv.fullScreenItems.length === 0 && priv.windowedVisibility !== Window.Hidden) {
|
||||
// Simply recall the last visibility state.
|
||||
visibility = priv.windowedVisibility
|
||||
}
|
Loading…
Reference in a new issue