mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: datefudge: Update to 1.26.
* gnu/packages/time.scm (datefudge): Update to 1.26. [source]: Update source URIs. Remove patch. [arguments]: Adjust make-flags to allow cross-compiling and set the version string. Remove custom 'patch-makefile phase. * gnu/packages/patches/datefudge-gettimeofday.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I8b53f9a9c3eb900ce5bceaa864ed701fb3cd3dc4
This commit is contained in:
parent
77192e834b
commit
3be993d963
3 changed files with 12 additions and 36 deletions
|
@ -1118,7 +1118,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/dante-non-darwin.patch \
|
||||
%D%/packages/patches/date-ignore-zonenow.patch \
|
||||
%D%/packages/patches/date-output-pkg-config-files.patch \
|
||||
%D%/packages/patches/datefudge-gettimeofday.patch \
|
||||
%D%/packages/patches/dbacl-include-locale.h.patch \
|
||||
%D%/packages/patches/dbacl-icheck-multiple-definitions.patch \
|
||||
%D%/packages/patches/dblatex-inkscape-1.0.patch \
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Add the 'restrict' qualifier to match the 'gettimeofday' declaration found
|
||||
in glibc 2.31.
|
||||
|
||||
--- datefudge-1.23/datefudge.c 2020-02-17 22:35:21.343341725 +0100
|
||||
+++ datefudge-1.23/datefudge.c 2020-02-17 22:35:49.619117874 +0100
|
||||
@@ -78,6 +78,6 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
-int gettimeofday(struct timeval *x, struct timezone *y) {
|
||||
+int gettimeofday(struct timeval *restrict x, void *restrict y) {
|
||||
return __gettimeofday(x,y);
|
||||
}
|
|
@ -2,7 +2,7 @@
|
|||
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2013, 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2015-2019, 2021, 2024 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
|
||||
;;; Copyright © 2015, 2017 Cyril Roelandt <tipecaml@gmail.com>
|
||||
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
|
||||
|
@ -64,6 +64,7 @@ (define-module (gnu packages time)
|
|||
#:use-module (guix build-system python)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix gexp)
|
||||
#:use-module (guix utils)
|
||||
#:use-module (guix git-download)
|
||||
#:use-module (guix licenses)
|
||||
#:use-module (guix packages))
|
||||
|
@ -580,9 +581,7 @@ (define-public rdate
|
|||
(define-public datefudge
|
||||
(package
|
||||
(name "datefudge")
|
||||
;; XXX When updating this package, make sure to do something about the
|
||||
;; archive.org backup URI.
|
||||
(version "1.23")
|
||||
(version "1.26")
|
||||
(source (origin
|
||||
;; Source code is available from
|
||||
;; <https://salsa.debian.org/debian/datefudge.git>. However,
|
||||
|
@ -590,34 +589,25 @@ (define-public datefudge
|
|||
;; (since Git -> GnuTLS -> datefudge).
|
||||
(method url-fetch)
|
||||
(uri (list
|
||||
;; For some reason this tarball was removed from Debian's
|
||||
;; servers. Remove this archive.org URL when updating
|
||||
;; datefudge, or add the new tarball to archive.org and
|
||||
;; update the URL.
|
||||
(string-append
|
||||
"https://archive.org/download/datefudge_" version
|
||||
".tar_202112/" "datefudge_" version ".tar.xz")
|
||||
(string-append
|
||||
"mirror://debian/pool/main/d/datefudge/datefudge_"
|
||||
version ".tar.xz")))
|
||||
version ".tar.xz")
|
||||
;; Update the Debian snapshot URL when updating the package.
|
||||
(string-append
|
||||
"https://snapshot.debian.org/archive/debian/"
|
||||
"20240115T092401Z/pool/main/d/datefudge/"
|
||||
"datefudge_1.26.tar.xz")))
|
||||
(sha256
|
||||
(base32
|
||||
"0ifnlb0mc8qc2kb5042pbz0ns6rwcb7201di8wyrsphl0yhnhxiv"))
|
||||
(patches (search-patches "datefudge-gettimeofday.patch"))))
|
||||
"09cjds76gzkwk6ssmsk3cgkcfhglfi9kmbahi1h17v4311v432iz"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:test-target "test"
|
||||
#:make-flags (list "CC=gcc"
|
||||
#:make-flags (list (string-append "CC=" ,(cc-for-target))
|
||||
(string-append "VERSION=" ,version)
|
||||
(string-append "prefix=" (assoc-ref %outputs "out")))
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'patch-makefile
|
||||
(lambda _
|
||||
(substitute* "Makefile"
|
||||
((" -o root -g root") "")
|
||||
(("VERSION := \\$\\(shell dpkg-parsechangelog .*")
|
||||
(string-append "VERSION = " ,version)))
|
||||
#t))
|
||||
(delete 'configure))))
|
||||
(native-inputs
|
||||
(list perl))
|
||||
|
|
Loading…
Reference in a new issue