mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: openssl: Set appropriate RUNPATH on shared libraries.
Fixes <http://bugs.gnu.org/20041>. Reported by taylanbayirli@gmail.com (Taylan Ulrich Bayırlı/Kammer). * gnu/packages/patches/openssl-runpath.patch: New file. * gnu/packages/openssl.scm (openssl)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
353fda815e
commit
3e462da5c1
3 changed files with 18 additions and 1 deletions
|
@ -489,6 +489,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/nvi-dbpagesize-binpower.patch \
|
||||
gnu/packages/patches/nvi-db4.patch \
|
||||
gnu/packages/patches/openexr-missing-samples.patch \
|
||||
gnu/packages/patches/openssl-runpath.patch \
|
||||
gnu/packages/patches/orpheus-cast-errors-and-includes.patch \
|
||||
gnu/packages/patches/ots-no-include-missing-file.patch \
|
||||
gnu/packages/patches/patchelf-page-size.patch \
|
||||
|
|
|
@ -36,7 +36,8 @@ (define-public openssl
|
|||
".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0jijgzf72659pikms2bc5w31h78xrd1h5zp2r01an2h340y3kdhm"))))
|
||||
"0jijgzf72659pikms2bc5w31h78xrd1h5zp2r01an2h340y3kdhm"))
|
||||
(patches (list (search-patch "openssl-runpath.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs `(("perl" ,perl)))
|
||||
(arguments
|
||||
|
|
15
gnu/packages/patches/openssl-runpath.patch
Normal file
15
gnu/packages/patches/openssl-runpath.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
This patch makes the build system pass -Wl,-rpath=$out/lib even for
|
||||
libraries (it already does so for executables, thanks to 'DO_GNU_APP'
|
||||
in 'Makefile.shared'.)
|
||||
|
||||
--- openssl-1.0.2a/Makefile.shared 2015-04-05 01:07:35.357602454 +0200
|
||||
+++ openssl-1.0.2a/Makefile.shared 2015-04-05 01:09:50.474513303 +0200
|
||||
@@ -106,7 +106,7 @@ LINK_SO= \
|
||||
LIBPATH=`for x in $$LIBDEPS; do echo $$x; done | sed -e 's/^ *-L//;t' -e d | uniq`; \
|
||||
LIBPATH=`echo $$LIBPATH | sed -e 's/ /:/g'`; \
|
||||
LD_LIBRARY_PATH=$$LIBPATH:$$LD_LIBRARY_PATH \
|
||||
- $${SHAREDCMD} $${SHAREDFLAGS} \
|
||||
+ $${SHAREDCMD} $${SHAREDFLAGS} -Wl,-rpath,$(LIBRPATH) \
|
||||
-o $$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX \
|
||||
$$ALLSYMSFLAGS $$SHOBJECTS $$NOALLSYMSFLAGS $$LIBDEPS \
|
||||
) && $(SYMLINK_SO)
|
Loading…
Reference in a new issue