From 3ed3746a932b1033630c42510a550d0cfb618a57 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:51:51 +0200
Subject: [PATCH] gnu: Add texlive-gradient-text.

* gnu/packages/tex.scm (texlive-gradient-text): New variable.
---
 gnu/packages/tex.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5c79f1ee5a..34ed2c1c89 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -84132,6 +84132,26 @@ (define-public texlive-grabbox
 into a box and executes the code afterwards.")
     (license license:lppl1.3c)))
 
+(define-public texlive-gradient-text
+  (package
+    (name "texlive-gradient-text")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/gradient-text/"
+                   "tex/latex/gradient-text/")
+             (base32
+              "00gnv7gbs583mwviajlfpr0m748s1ysc9h7aig8bwhn8v1rrjxqw")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/gradient-text")
+    (synopsis "Decorate text with linear gradient colors")
+    (description
+     "This package enables writers to conveniently decorate text with linear
+gradient colors.  The RGB values of the first and the last character are
+specified as parameters while the rest of the text is colored automatically.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar