mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: libmateweather: Update to 1.28.0.
* gnu/packages/mate.scm (libmateweather): Update to 1.28.0 * gnu/packages/patches/libmateweather-use-TZDIR.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Unregister it. Change-Id: I7432dd65bcf00e9f44d610fad337b629714fb3d2 Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
This commit is contained in:
parent
9ef7b99a90
commit
3f6c6328c0
3 changed files with 2 additions and 47 deletions
|
@ -1647,7 +1647,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libmad-length-check.patch \
|
||||
%D%/packages/patches/libmad-md_size.patch \
|
||||
%D%/packages/patches/libmad-mips-newgcc.patch \
|
||||
%D%/packages/patches/libmateweather-use-TZDIR.patch \
|
||||
%D%/packages/patches/libmp4v2-c++11.patch \
|
||||
%D%/packages/patches/libmpeg2-arm-private-symbols.patch \
|
||||
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
|
||||
|
|
|
@ -253,16 +253,14 @@ (define-public mate-desktop
|
|||
(define-public libmateweather
|
||||
(package
|
||||
(name "libmateweather")
|
||||
(version "1.26.1")
|
||||
(version "1.28.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://mate/" (version-major+minor version) "/"
|
||||
"libmateweather-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0fpgc2l46024j2sqqsvclg9c6x33hyjk2zbg5h74v7cf9c7rj062"))
|
||||
(patches
|
||||
(list (search-patch "libmateweather-use-TZDIR.patch")))))
|
||||
(base32 "1dfj68q3x9camd7h94pcwv8a5969cv5d4p979gcbk4xknpg76hsm"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
From 109fef8208188ddf4be76d6899f7d8fde5b8b3be Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@member.fsf.org>
|
||||
Date: Sat, 22 Jul 2023 14:40:31 +0800
|
||||
Subject: [PATCH] Use TZDIR for ZONEINFO_DIR if the variable is set.
|
||||
|
||||
---
|
||||
libmateweather/mateweather-timezone.c | 8 +++++---
|
||||
1 file changed, 5 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/libmateweather/mateweather-timezone.c b/libmateweather/mateweather-timezone.c
|
||||
index 2754728..6c858c4 100644
|
||||
--- a/libmateweather/mateweather-timezone.c
|
||||
+++ b/libmateweather/mateweather-timezone.c
|
||||
@@ -61,7 +61,7 @@ static gboolean
|
||||
parse_tzdata (const char *tzname, time_t start, time_t end,
|
||||
int *offset, gboolean *has_dst, int *dst_offset)
|
||||
{
|
||||
- char *filename, *contents;
|
||||
+ char *tzdir, *filename, *contents;
|
||||
gsize length;
|
||||
int timecnt, transitions_size, ttinfo_map_size;
|
||||
int initial_transition = -1, second_transition = -1;
|
||||
@@ -71,7 +71,10 @@ parse_tzdata (const char *tzname, time_t start, time_t end,
|
||||
char initial_isdst, second_isdst;
|
||||
int i;
|
||||
|
||||
- filename = g_build_filename (ZONEINFO_DIR, tzname, NULL);
|
||||
+ tzdir = g_getenv("TZDIR");
|
||||
+ if (tzdir == NULL)
|
||||
+ tzdir = ZONEINFO_DIR;
|
||||
+ filename = g_build_filename (tzdir, tzname, NULL);
|
||||
if (!g_file_get_contents (filename, &contents, &length, NULL)) {
|
||||
g_free (filename);
|
||||
return FALSE;
|
||||
@@ -403,4 +406,3 @@ mateweather_timezone_get_dst_offset (MateWeatherTimezone *zone)
|
||||
g_return_val_if_fail (zone->has_dst, 0);
|
||||
return zone->dst_offset;
|
||||
}
|
||||
-
|
||||
--
|
||||
2.41.0
|
||||
|
Loading…
Reference in a new issue