gnu: jbig2dec: Update to 0.18.

* gnu/packages/patches/jbig2dec-ignore-testtest.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/image.scm (jbig2dec): Update to 0.18.
[source](uri): Adjust for Ghostscript 9.51.
[source](patches): Remove.
[arguments]: Add #:phases.
[native-inputs]: Add AUTOCONF, AUTOMAKE, LIBTOOL and PYTHON-WRAPPER.
This commit is contained in:
Marius Bakke 2020-03-14 01:20:14 +01:00
parent 704f1b53c7
commit 3fd74c4506
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 20 additions and 22 deletions

View file

@ -1053,7 +1053,6 @@ dist_patch_DATA = \
%D%/packages/patches/java-xerces-bootclasspath.patch \
%D%/packages/patches/java-xerces-build_dont_unzip.patch \
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
%D%/packages/patches/jfsutils-add-sysmacros.patch \
%D%/packages/patches/jfsutils-include-systypes.patch \
%D%/packages/patches/jsoncpp-fix-inverted-case.patch \

View file

@ -635,18 +635,33 @@ (define-public leptonica
(define-public jbig2dec
(package
(name "jbig2dec")
(version "0.17")
(version "0.18")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ArtifexSoftware"
"/ghostpdl-downloads/releases/download"
"/gs950/" name "-" version ".tar.gz"))
"/gs951/" name "-" version ".tar.gz"))
(sha256
(base32
"0wpvslmwazia3z8gyk343kbq6yj47pxr4x5yjvx332v309qssazp"))
(patches (search-patches "jbig2dec-ignore-testtest.patch"))))
"0pigfw2v0ppvr0lbysm69gx0zsa5q2q92yrb8af2j3im6x97f6cy"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--disable-static")))
(arguments '(#:configure-flags '("--disable-static")
#:phases (modify-phases %standard-phases
(add-before 'bootstrap 'force-bootstrap
(lambda _
;; XXX: jbig2dec 0.18 was released with
;; a broken configure script, so we
;; recreate the build system here.
;; Remove the autoconf inputs below
;; when deleting this code.
(delete-file "configure")
(delete-file "autogen.sh")
#t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
("python" ,python-wrapper))) ;for tests
(synopsis "Decoder of the JBIG2 image compression format")
(description
"JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit

View file

@ -1,16 +0,0 @@
Do not run the test 'test_jbig2dec.py'. It doesn't seem to do anything
and reports failure. TODO: Actually fix the test instead of ignoring it.
diff --git a/Makefile.in b/Makefile.in
index 63982d4..8af1d61 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -93,7 +93,7 @@ host_triplet = @host@
bin_PROGRAMS = jbig2dec$(EXEEXT)
noinst_PROGRAMS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
test_arith$(EXEEXT)
-TESTS = test_sha1$(EXEEXT) test_jbig2dec.py test_huffman$(EXEEXT) \
+TESTS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
test_arith$(EXEEXT)
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4