mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: wxwidgets: Fix for Filezilla client.
* gnu/packages/patches/wxwidgets-fix-windowGTK.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
9f86202ba1
commit
40c611a41d
3 changed files with 24 additions and 2 deletions
|
@ -5,7 +5,7 @@
|
||||||
# Copyright © 2013, 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
|
# Copyright © 2013, 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
|
||||||
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
|
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
|
||||||
# Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
|
# Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
|
||||||
# Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
|
# Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
|
||||||
# Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
|
# Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
|
||||||
# Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
|
# Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
|
||||||
# Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
|
# Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
|
||||||
|
@ -976,6 +976,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/wordnet-CVE-2008-2149.patch \
|
%D%/packages/patches/wordnet-CVE-2008-2149.patch \
|
||||||
%D%/packages/patches/wordnet-CVE-2008-3908-pt1.patch \
|
%D%/packages/patches/wordnet-CVE-2008-3908-pt1.patch \
|
||||||
%D%/packages/patches/wordnet-CVE-2008-3908-pt2.patch \
|
%D%/packages/patches/wordnet-CVE-2008-3908-pt2.patch \
|
||||||
|
%D%/packages/patches/wxwidgets-fix-windowGTK.patch \
|
||||||
%D%/packages/patches/xdotool-fix-makefile.patch \
|
%D%/packages/patches/xdotool-fix-makefile.patch \
|
||||||
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||||
%D%/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
%D%/packages/patches/xf86-video-ast-remove-mibstore.patch \
|
||||||
|
|
18
gnu/packages/patches/wxwidgets-fix-windowGTK.patch
Normal file
18
gnu/packages/patches/wxwidgets-fix-windowGTK.patch
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
This patch allow Filezilla client to resize window.
|
||||||
|
The patch was adapted from upstream source repository:
|
||||||
|
'<http://trac.wxwidgets.org/changeset/4793e5b0a4e189e492287305859b278fed780080/git-wxWidgets>'
|
||||||
|
|
||||||
|
--- a/src/gtk/toplevel.cpp 2014-10-06 16:33:44.000000000 -0500
|
||||||
|
+++ b/src/gtk/toplevel.cpp 2017-02-16 21:33:27.779907810 -0600
|
||||||
|
@@ -1216,8 +1216,9 @@
|
||||||
|
int hints_mask = GDK_HINT_MIN_SIZE | GDK_HINT_MAX_SIZE;
|
||||||
|
hints.min_width = 1;
|
||||||
|
hints.min_height = 1;
|
||||||
|
- hints.max_width = INT_MAX;
|
||||||
|
- hints.max_height = INT_MAX;
|
||||||
|
+ // using INT_MAX for size will lead to integer overflow with HiDPI scaling
|
||||||
|
+ hints.max_width = INT_MAX / 16;
|
||||||
|
+ hints.max_height = INT_MAX / 16;
|
||||||
|
const int decorSize_x = m_decorSize.left + m_decorSize.right;
|
||||||
|
const int decorSize_y = m_decorSize.top + m_decorSize.bottom;
|
||||||
|
if (minSize.x > decorSize_x)
|
|
@ -3,6 +3,7 @@
|
||||||
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
|
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
|
||||||
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
|
;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
|
||||||
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
|
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
|
||||||
|
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -50,7 +51,9 @@ (define-public wxwidgets
|
||||||
"releases/download/v" version
|
"releases/download/v" version
|
||||||
"/wxWidgets-" version ".tar.bz2"))
|
"/wxWidgets-" version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0paq27brw4lv8kspxh9iklpa415mxi8zc117vbbbhfjgapf7js1l"))))
|
(base32 "0paq27brw4lv8kspxh9iklpa415mxi8zc117vbbbhfjgapf7js1l"))
|
||||||
|
(patches (search-patches
|
||||||
|
"wxwidgets-fix-windowGTK.patch"))))
|
||||||
(build-system glib-or-gtk-build-system)
|
(build-system glib-or-gtk-build-system)
|
||||||
(inputs
|
(inputs
|
||||||
`(("glu" ,glu)
|
`(("glu" ,glu)
|
||||||
|
|
Loading…
Reference in a new issue