mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: stex: Fix read-only gifs and math directories.
Excplicitly set the user write bit when initializing the gifs or math directories from the skeletons installed in the store. See also upstream discussion at <https://github.com/dybvig/stex/pull/6>. This problem would be exposed by the upcoming changes to Racket's build system. * gnu/packages/patches/stex-copy-from-immutable-store.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/chez.scm (stex-bootstrap)[patches]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
92e8cff749
commit
4176d47ef7
3 changed files with 45 additions and 0 deletions
|
@ -1828,6 +1828,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/slim-reset.patch \
|
%D%/packages/patches/slim-reset.patch \
|
||||||
%D%/packages/patches/slim-login.patch \
|
%D%/packages/patches/slim-login.patch \
|
||||||
%D%/packages/patches/slim-display.patch \
|
%D%/packages/patches/slim-display.patch \
|
||||||
|
%D%/packages/patches/stex-copy-from-immutable-store.patch \
|
||||||
%D%/packages/patches/syslinux-gcc10.patch \
|
%D%/packages/patches/syslinux-gcc10.patch \
|
||||||
%D%/packages/patches/syslinux-strip-gnu-property.patch \
|
%D%/packages/patches/syslinux-strip-gnu-property.patch \
|
||||||
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
|
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
|
||||||
|
|
|
@ -613,6 +613,9 @@ (define-public stex-bootstrap
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0n6dryv5j7cw2qmsj55wqb0ph901h83a2hl4j891ppxp0xx18nkp"))
|
(base32 "0n6dryv5j7cw2qmsj55wqb0ph901h83a2hl4j891ppxp0xx18nkp"))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
|
(patches
|
||||||
|
;; submitted upstream in https://github.com/dybvig/stex/pull/6
|
||||||
|
(search-patches "stex-copy-from-immutable-store.patch"))
|
||||||
(snippet
|
(snippet
|
||||||
#~(for-each delete-file
|
#~(for-each delete-file
|
||||||
'("sbin/install" "doc/stex.pdf" "doc/stex.html")))))
|
'("sbin/install" "doc/stex.pdf" "doc/stex.html")))))
|
||||||
|
|
41
gnu/packages/patches/stex-copy-from-immutable-store.patch
Normal file
41
gnu/packages/patches/stex-copy-from-immutable-store.patch
Normal file
|
@ -0,0 +1,41 @@
|
||||||
|
From 9434b4a36646c036db8de326158056aa3293fb82 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Philip McGrath <philip@philipmcgrath.com>
|
||||||
|
Date: Thu, 28 Apr 2022 22:56:20 -0400
|
||||||
|
Subject: [PATCH] fix read-only gifs and math directories
|
||||||
|
|
||||||
|
An installed copy of stex might have all write permission bits removed,
|
||||||
|
even for the owner of the installed files: this is the case with Guix
|
||||||
|
package of stex, for example. If such an installation is used to
|
||||||
|
initialize the gifs or math directories (e.g. for an out-of-source
|
||||||
|
build), tar likewise creates them without write permissions, preventing
|
||||||
|
subdirectories from being created later. Set the user write bit
|
||||||
|
explicitly to avoid this problem.
|
||||||
|
Mf-stex
|
||||||
|
|
||||||
|
Related to https://github.com/racket/racket/pull/4203
|
||||||
|
---
|
||||||
|
|
||||||
|
Submitted upstream in https://github.com/dybvig/stex/pull/6
|
||||||
|
|
||||||
|
Mf-stex | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/Mf-stex b/Mf-stex
|
||||||
|
index 09ec6f3..11fb214 100644
|
||||||
|
--- a/Mf-stex
|
||||||
|
+++ b/Mf-stex
|
||||||
|
@@ -112,9 +112,11 @@ $(x).mathrun: gifs $(mathfiles)
|
||||||
|
|
||||||
|
gifs:
|
||||||
|
(cd $(STEXLIB); tar -cf - gifs) | tar -xpf -
|
||||||
|
+ chmod u+w gifs
|
||||||
|
|
||||||
|
math:
|
||||||
|
(cd $(STEXLIB); tar -cf - math) | tar -xpf -
|
||||||
|
+ chmod u+w math
|
||||||
|
|
||||||
|
$(mathfiles): $(x).hthirdrun $(figps)
|
||||||
|
echo -n gifs= > $(mathfiles)
|
||||||
|
--
|
||||||
|
2.32.0
|
||||||
|
|
Loading…
Reference in a new issue