mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: arb: Build with flint 2.6.
Backport an upstream patch to fix a compatibility issue with flint 2.6. * gnu/packages/algebra.scm (arb): Add patch. * gnu/packages/patches/arb-flint-2.6.patch: New file. * gnu/local.mk (dist_patch_DATA): Register new file.
This commit is contained in:
parent
d7c8bcc47c
commit
417eaa88dc
3 changed files with 51 additions and 1 deletions
|
@ -772,6 +772,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
|
||||
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
|
||||
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
||||
%D%/packages/patches/arb-flint-2.6.patch \
|
||||
%D%/packages/patches/aspell-default-dict-dir.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
||||
|
|
|
@ -504,7 +504,8 @@ (define-public arb
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"05lpy3hkl5f8ik19aw40cqydrb932xaf2n8hbq9ib5dnk7f010p1"))))
|
||||
"05lpy3hkl5f8ik19aw40cqydrb932xaf2n8hbq9ib5dnk7f010p1"))
|
||||
(patches (search-patches "arb-flint-2.6.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(propagated-inputs
|
||||
`(("flint" ,flint))) ; flint.h is included by arf.h
|
||||
|
|
48
gnu/packages/patches/arb-flint-2.6.patch
Normal file
48
gnu/packages/patches/arb-flint-2.6.patch
Normal file
|
@ -0,0 +1,48 @@
|
|||
From d3d9983231e0f034e86a1e75761627eb8213b704 Mon Sep 17 00:00:00 2001
|
||||
From: fredrik <fredrik.johansson@gmail.com>
|
||||
Date: Wed, 29 Apr 2020 13:41:36 +0200
|
||||
Subject: [PATCH] handle flint incompatibilities
|
||||
|
||||
---
|
||||
fmpr.h | 4 ++++
|
||||
fmpz_extras.h | 4 ++++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/fmpr.h b/fmpr.h
|
||||
index 2204d72e..c6a8c342 100644
|
||||
--- a/fmpr.h
|
||||
+++ b/fmpr.h
|
||||
@@ -22,7 +22,11 @@
|
||||
#include "flint/flint.h"
|
||||
#include "flint/fmpz.h"
|
||||
#include "flint/fmpq.h"
|
||||
+#if __FLINT_RELEASE < 20600
|
||||
#include "flint/config.h"
|
||||
+#else
|
||||
+#include "flint/flint-config.h"
|
||||
+#endif
|
||||
#include "fmpz_extras.h"
|
||||
|
||||
#ifndef flint_abort
|
||||
diff --git a/fmpz_extras.h b/fmpz_extras.h
|
||||
index 4fd0538f..486e28c8 100644
|
||||
--- a/fmpz_extras.h
|
||||
+++ b/fmpz_extras.h
|
||||
@@ -43,6 +43,8 @@ fmpz_add_inline(fmpz_t z, const fmpz_t x, const fmpz_t y)
|
||||
fmpz_add(z, x, y);
|
||||
}
|
||||
|
||||
+#if __FLINT_RELEASE < 20600
|
||||
+
|
||||
static __inline__ void
|
||||
fmpz_add_si(fmpz_t z, const fmpz_t x, slong y)
|
||||
{
|
||||
@@ -61,6 +63,8 @@ fmpz_sub_si(fmpz_t z, const fmpz_t x, slong y)
|
||||
fmpz_add_ui(z, x, -y);
|
||||
}
|
||||
|
||||
+#endif
|
||||
+
|
||||
static __inline__ void
|
||||
fmpz_add_si_inline(fmpz_t z, const fmpz_t x, slong y)
|
||||
{
|
Loading…
Reference in a new issue