gnu: make-bootstrap: Adjust gawk patch to 4.2.1.

* gnu/packages/patches/gawk-shell.patch: Update for 4.2.1.
This commit is contained in:
Marius Bakke 2018-04-05 17:07:43 +02:00
parent bce2206021
commit 44e3e431cd
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA

View file

@ -4,31 +4,39 @@ absolute file name of `sh'.
--- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200
+++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200
@@ -1945,7 +1945,7 @@ two_way_open(const char *str, struct red
@@ -2025,7 +2025,7 @@
signal(SIGPIPE, SIG_DFL);
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", str, NULL);
+ execlp("sh", "sh", "-c", str, NULL);
_exit(errno == ENOENT ? 127 : 126);
- execl("/bin/sh", "sh", "-c", command, NULL);
+ execlp("sh", "sh", "-c", command, NULL);
_exit(errno == ENOENT ? 127 : 126);
case -1:
@@ -2129,7 +2129,7 @@ use_pipes:
case -1:
@@ -2077,7 +2077,7 @@
signal(SIGPIPE, SIG_DFL);
- execl("/bin/sh", "sh", "-c", command, NULL);
+ execlp("sh", "sh", "-c", command, NULL);
_exit(errno == ENOENT ? 127 : 126);
case -1:
@@ -2422,7 +2422,7 @@
fatal(_("close of pipe failed (%s)"), strerror(errno));
/* stderr does NOT get dup'ed onto child's stdout */
signal(SIGPIPE, SIG_DFL);
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", str, NULL);
+ execlp("sh", "sh", "-c", str, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
#endif /* NOT __EMX__, NOT __MINGW32__ */
@@ -2323,7 +2323,7 @@ gawk_popen(const char *cmd, struct redir
@@ -2659,7 +2659,7 @@
if (close(p[0]) == -1 || close(p[1]) == -1)
fatal(_("close of pipe failed (%s)"), strerror(errno));
signal(SIGPIPE, SIG_DFL);
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", cmd, NULL);
+ execlp("sh", "sh", "-c", cmd, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
#endif /* NOT __EMX__, NOT __MINGW32__ */