mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 14:16:55 -05:00
gnu: clang@9: Do not refer to /lib on foreign distros.
Partly fixes <https://issues.guix.gnu.org/51088>. * gnu/packages/patches/clang-9.0-libc-search-path.patch: Update.
This commit is contained in:
parent
66caab54b9
commit
46141bd372
1 changed files with 50 additions and 40 deletions
|
@ -4,17 +4,47 @@ but unfortunately, that doesn't work for us.
|
|||
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
||||
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
||||
the distro-specific stuff and removes the hard-coded FHS directory names
|
||||
to make sure Clang also works on non-GuixSD systems.
|
||||
to make sure Clang also works on foreign distros.
|
||||
|
||||
diff --git a/lib/Driver/Distro.cpp b/lib/Driver/Distro.cpp
|
||||
index f2a3074d..536db89c 100644
|
||||
--- a/lib/Driver/Distro.cpp
|
||||
+++ b/lib/Driver/Distro.cpp
|
||||
@@ -18,6 +18,10 @@ using namespace clang::driver;
|
||||
using namespace clang;
|
||||
|
||||
static Distro::DistroType DetectDistro(llvm::vfs::FileSystem &VFS) {
|
||||
+ // The compiler should always behave the same, even when used via Guix on a
|
||||
+ // foreign distro.
|
||||
+ return Distro::UnknownDistro;
|
||||
+
|
||||
llvm::ErrorOr<std::unique_ptr<llvm::MemoryBuffer>> File =
|
||||
VFS.getBufferForFile("/etc/lsb-release");
|
||||
if (File) {
|
||||
diff --git a/lib/Driver/ToolChains/Cuda.cpp b/lib/Driver/ToolChains/Cuda.cpp
|
||||
index 96f8c513..64fd7a26 100644
|
||||
--- a/lib/Driver/ToolChains/Cuda.cpp
|
||||
+++ b/lib/Driver/ToolChains/Cuda.cpp
|
||||
@@ -69,6 +69,9 @@ CudaInstallationDetector::CudaInstallationDetector(
|
||||
const Driver &D, const llvm::Triple &HostTriple,
|
||||
const llvm::opt::ArgList &Args)
|
||||
: D(D) {
|
||||
+ // Don't look for CUDA in /usr.
|
||||
+ return;
|
||||
+
|
||||
struct Candidate {
|
||||
std::string Path;
|
||||
bool StrictChecking;
|
||||
diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
||||
index 7f59bc77..67d8ce22 100644
|
||||
--- a/lib/Driver/ToolChains/Linux.cpp
|
||||
+++ b/lib/Driver/ToolChains/Linux.cpp
|
||||
@@ -240,6 +240,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
.str());
|
||||
}
|
||||
|
||||
+// Comment out the distro-specific tweaks so that they don't bite when
|
||||
+// using Guix on a foreign distro.
|
||||
+ // Comment out the distro-specific tweaks so that they don't bite when
|
||||
+ // using Guix on a foreign distro.
|
||||
+#if 0
|
||||
Distro Distro(D.getVFS());
|
||||
|
||||
|
@ -27,57 +57,37 @@ diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
|||
|
||||
// The selection of paths to try here is designed to match the patterns which
|
||||
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
||||
@@ -363,7 +367,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
// the cross. Note that GCC does include some of these directories in some
|
||||
// configurations but this seems somewhere between questionable and simply
|
||||
// a bug.
|
||||
- if (StringRef(LibPath).startswith(SysRoot)) {
|
||||
+ if (0) {
|
||||
addPathIfExists(D, LibPath + "/" + MultiarchTriple, Paths);
|
||||
addPathIfExists(D, LibPath + "/../" + OSLibDir, Paths);
|
||||
@@ -369,6 +373,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
}
|
||||
@@ -382,6 +386,8 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
addPathIfExists(D, SysRoot + "/lib/" + MultiarchTriple, Paths);
|
||||
addPathIfExists(D, SysRoot + "/lib/../" + OSLibDir, Paths);
|
||||
|
||||
+// This requires the commented distro tweaks above.
|
||||
+#if 0
|
||||
if (IsAndroid) {
|
||||
// Android sysroots contain a library directory for each supported OS
|
||||
// version as well as some unversioned libraries in the usual multiarch
|
||||
@@ -410,10 +416,15 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
addPathIfExists(D, SysRoot + "/" + OSLibDir + "/" + ABIName, Paths);
|
||||
addPathIfExists(D, SysRoot + "/usr/" + OSLibDir + "/" + ABIName, Paths);
|
||||
}
|
||||
+#endif
|
||||
|
||||
+#if 0
|
||||
// Similar to the logic for GCC above, if we currently running Clang inside
|
||||
// of the requested system root, add its parent library paths to
|
||||
// those searched.
|
||||
@@ -414,6 +419,8 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
// Try walking via the GCC triple path in case of biarch or multiarch GCC
|
||||
// installations with strange symlinks.
|
||||
if (GCCInstallation.isValid()) {
|
||||
+
|
||||
+// The following code would end up adding things like
|
||||
+// "/usr/lib/x86_64-unknown-linux-gnu/../../lib64" to the search path.
|
||||
+#if 0
|
||||
+ // The following code would end up adding things like
|
||||
+ // "/usr/lib/x86_64-unknown-linux-gnu/../../lib64" to the search path.
|
||||
addPathIfExists(D,
|
||||
SysRoot + "/usr/lib/" + GCCInstallation.getTriple().str() +
|
||||
"/../../" + OSLibDir,
|
||||
@@ -426,6 +437,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
BiarchSibling.gccSuffix(),
|
||||
Paths);
|
||||
}
|
||||
+#endif
|
||||
|
||||
// See comments above on the multilib variant for details of why this is
|
||||
// included even from outside the sysroot.
|
||||
@@ -450,8 +462,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
@@ -449,9 +456,14 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
// directory ('Dir' below) or the ResourceDir.
|
||||
if (StringRef(D.Dir).startswith(SysRoot))
|
||||
addPathIfExists(D, D.Dir + "/../lib", Paths);
|
||||
|
||||
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
||||
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
||||
+#endif
|
||||
+
|
||||
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
||||
+ // and friends can be found.
|
||||
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
||||
|
||||
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
||||
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
||||
+ // Add GCC's lib/ directory so libstdc++.so can be found.
|
||||
+ addPathIfExists(D, GCCInstallation.getParentLibPath(), Paths);
|
||||
}
|
||||
|
||||
ToolChain::CXXStdlibType Linux::GetDefaultCXXStdlibType() const {
|
||||
|
|
Loading…
Reference in a new issue