mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: efibootmgr: Update to 17.
* gnu/packages/linux.scm (efibootmgr): Update to 17. [source]: Use GIT-FETCH and GIT-FILE-NAME. Add a patch to build against efivar@37. * gnu/packages/patches/efibootmgr-remove-extra-decl.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
6139c879a5
commit
46cac065be
3 changed files with 39 additions and 9 deletions
|
@ -955,6 +955,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/ecl-16-format-directive-limit.patch \
|
%D%/packages/patches/ecl-16-format-directive-limit.patch \
|
||||||
%D%/packages/patches/ecl-16-ignore-stderr-write-error.patch \
|
%D%/packages/patches/ecl-16-ignore-stderr-write-error.patch \
|
||||||
%D%/packages/patches/ecl-16-libffi.patch \
|
%D%/packages/patches/ecl-16-libffi.patch \
|
||||||
|
%D%/packages/patches/efibootmgr-remove-extra-decl.patch \
|
||||||
%D%/packages/patches/eigen-remove-openmp-error-counting.patch \
|
%D%/packages/patches/eigen-remove-openmp-error-counting.patch \
|
||||||
%D%/packages/patches/eigen-stabilise-sparseqr-test.patch \
|
%D%/packages/patches/eigen-stabilise-sparseqr-test.patch \
|
||||||
%D%/packages/patches/einstein-build.patch \
|
%D%/packages/patches/einstein-build.patch \
|
||||||
|
|
|
@ -6163,15 +6163,17 @@ (define-public efivar
|
||||||
(define-public efibootmgr
|
(define-public efibootmgr
|
||||||
(package
|
(package
|
||||||
(name "efibootmgr")
|
(name "efibootmgr")
|
||||||
(version "16")
|
(version "17")
|
||||||
(source (origin
|
(source
|
||||||
(method url-fetch)
|
(origin
|
||||||
(uri (string-append "https://github.com/rhinstaller/efibootmgr"
|
(method git-fetch)
|
||||||
"/releases/download/" version "/efibootmgr"
|
(uri (git-reference
|
||||||
"-" version ".tar.bz2"))
|
(url "https://github.com/rhinstaller/efibootmgr")
|
||||||
(sha256
|
(commit version)))
|
||||||
(base32
|
(file-name (git-file-name name version))
|
||||||
"0pzn67vxxaf7jna4cd0i4kqm60h04kb21hckksv9z82q9gxra1wm"))))
|
(sha256
|
||||||
|
(base32 "1niicijxg59rsmiw3rsjwy4bvi1n42dynvm01lnp9haixdzdpq03"))
|
||||||
|
(patches (search-patches "efibootmgr-remove-extra-decl.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:tests? #f ;no tests
|
`(#:tests? #f ;no tests
|
||||||
|
|
27
gnu/packages/patches/efibootmgr-remove-extra-decl.patch
Normal file
27
gnu/packages/patches/efibootmgr-remove-extra-decl.patch
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
From 99b578501643377e0b1994b2a068b790d189d5ad Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Jones <pjones@redhat.com>
|
||||||
|
Date: Wed, 13 Jun 2018 09:41:01 -0400
|
||||||
|
Subject: [PATCH] remove extra decl
|
||||||
|
|
||||||
|
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||||
|
---
|
||||||
|
src/efibootmgr.c | 3 ---
|
||||||
|
1 file changed, 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/efibootmgr.c b/src/efibootmgr.c
|
||||||
|
index de38f01..4e1a680 100644
|
||||||
|
--- a/src/efibootmgr.c
|
||||||
|
+++ b/src/efibootmgr.c
|
||||||
|
@@ -1536,9 +1536,6 @@ parse_opts(int argc, char **argv)
|
||||||
|
"invalid numeric value %s\n",
|
||||||
|
optarg);
|
||||||
|
}
|
||||||
|
- /* XXX efivar-36 accidentally doesn't have a public
|
||||||
|
- * header for this */
|
||||||
|
- extern int efi_set_verbose(int verbosity, FILE *errlog);
|
||||||
|
efi_set_verbose(opts.verbose - 2, stderr);
|
||||||
|
break;
|
||||||
|
case 'V':
|
||||||
|
--
|
||||||
|
2.24.0
|
||||||
|
|
Loading…
Reference in a new issue