mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: rust: Accept more detailed gdb lines for simple enums.
* gnu/packages/patches/rust-1.25-accept-more-detailed-gdb-lines.patch: Modify. * gnu/packages/rust.scm (rust-1.25)[arguments]<#:phases>[disable-nil-enum-test]: Delete phase.
This commit is contained in:
parent
a6f2afeee1
commit
46cb1c97cb
2 changed files with 16 additions and 7 deletions
|
@ -92,3 +92,19 @@ diff -ur orig/rustc-1.25.0-src/src/test/debuginfo/generic-tuple-style-enum.rs ru
|
|||
|
||||
// gdb-command:print univariant
|
||||
// gdbg-check:$4 = {{__0 = -1}}
|
||||
--- orig/rustc-1.25.0-src/src/test/debuginfo/nil-enum.rs 2018-09-13 10:24:33.783565071 +0200
|
||||
+++ rustc-1.25.0-src/src/test/debuginfo/nil-enum.rs 2018-10-26 18:19:20.404564587 +0200
|
||||
@@ -17,11 +17,11 @@
|
||||
|
||||
// gdb-command:print first
|
||||
// gdbg-check:$1 = {<No data fields>}
|
||||
-// gdbr-check:$1 = <error reading variable>
|
||||
+// gdbr-check:$1 = nil_enum::ANilEnum
|
||||
|
||||
// gdb-command:print second
|
||||
// gdbg-check:$2 = {<No data fields>}
|
||||
-// gdbr-check:$2 = <error reading variable>
|
||||
+// gdbr-check:$2 = nil_enum::AnotherNilEnum
|
||||
|
||||
#![allow(unused_variables)]
|
||||
#![feature(omit_gdb_pretty_printer_section)]
|
||||
|
|
|
@ -706,13 +706,6 @@ (define-public rust-1.25
|
|||
;; This test wants to update the crate index.
|
||||
(("fn no_index_update") "#[ignore]\nfn no_index_update"))
|
||||
#t))
|
||||
;; FIXME: Re-enable this test if it's indeed supposed to work.
|
||||
;; See <https://github.com/rust-lang/rust/issues/54178>.
|
||||
(add-after 'configure 'disable-nil-enum-test
|
||||
(lambda _
|
||||
(substitute* "src/test/debuginfo/nil-enum.rs"
|
||||
(("ignore-lldb") "ignore-gdb"))
|
||||
#t))
|
||||
(replace 'patch-aarch64-test
|
||||
(lambda _
|
||||
(substitute* "src/librustc_metadata/dynamic_lib.rs"
|
||||
|
|
Loading…
Reference in a new issue