mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: mingw: Add mingw-w64 reproducibility patches.
These patches were originally found at the debian mingw-w64 team's mingw-w64 repo, and should improve the reproducibility of our mingw-w64 toolchain. * gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch: New file. * gnu/packages/patches/mingw-w64-reproducible-gendef.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/mingw.scm (make-mingw-w64): Apply patches.
This commit is contained in:
parent
19b10c91e8
commit
4719b71572
4 changed files with 55 additions and 1 deletions
|
@ -1201,6 +1201,8 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
%D%/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
%D%/packages/patches/mingw-w64-6.0.0-gcc.patch \
|
||||
%D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \
|
||||
%D%/packages/patches/mingw-w64-reproducible-gendef.patch \
|
||||
%D%/packages/patches/minisat-friend-declaration.patch \
|
||||
%D%/packages/patches/minisat-install.patch \
|
||||
%D%/packages/patches/mpc123-initialize-ao.patch \
|
||||
|
|
|
@ -53,7 +53,10 @@ (define* (make-mingw-w64 machine
|
|||
"mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
|
||||
(patches (search-patches "mingw-w64-6.0.0-gcc.patch"))))
|
||||
(patches
|
||||
(search-patches "mingw-w64-6.0.0-gcc.patch"
|
||||
"mingw-w64-dlltool-temp-prefix.patch"
|
||||
"mingw-w64-reproducible-gendef.patch"))))
|
||||
(native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
|
||||
("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
|
||||
,@(if with-winpthreads?
|
||||
|
|
26
gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
Normal file
26
gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
This following patch was originally found at the debian mingw-w64 team's
|
||||
mingw-w64 repo located here:
|
||||
https://salsa.debian.org/mingw-w64-team/mingw-w64.git
|
||||
|
||||
Invoke the following in the aforementioned repo to see the original patch:
|
||||
|
||||
$ git show 4974e2c:debian/patches/dlltool-temp-prefix.patch
|
||||
|
||||
Description: Specify dlltool's temp prefix
|
||||
Author: Stephen Kitt <steve@sk2.org>
|
||||
|
||||
By default dlltool uses its pid for the object files it generates.
|
||||
Enforcing its temp prefix allows the files it generates to be
|
||||
reproducible.
|
||||
|
||||
--- a/mingw-w64-crt/Makefile.am
|
||||
+++ b/mingw-w64-crt/Makefile.am
|
||||
@@ -36,7 +36,7 @@
|
||||
DTDEF32=$(GENLIB) $(DLLTOOLFLAGS32) $(AM_DLLTOOLFLAGS)
|
||||
DTDEF64=$(GENLIB) $(DLLTOOLFLAGS64) $(AM_DLLTOOLFLAGS)
|
||||
else
|
||||
- AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@
|
||||
+ AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@ --temp-prefix $$(basename $@ .a)
|
||||
DLLTOOLFLAGSARM32=-m arm
|
||||
DLLTOOLFLAGSARM64=-m arm64
|
||||
DLLTOOLFLAGS32=--as-flags=--32 -m i386
|
23
gnu/packages/patches/mingw-w64-reproducible-gendef.patch
Normal file
23
gnu/packages/patches/mingw-w64-reproducible-gendef.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
This following patch was originally found at the debian mingw-w64 team's
|
||||
mingw-w64 repo located here:
|
||||
https://salsa.debian.org/mingw-w64-team/mingw-w64.git
|
||||
|
||||
Invoke the following in the aforementioned repo to see the original patch:
|
||||
|
||||
$ git show 4974e2c:debian/patches/reproducible-gendef.patch
|
||||
|
||||
Description: Drop __DATE__ from gendef
|
||||
Author: Stephen Kitt <skitt@debian.org>
|
||||
|
||||
This allows gendef to be built reproducibly.
|
||||
|
||||
--- a/mingw-w64-tools/gendef/src/gendef.c
|
||||
+++ b/mingw-w64-tools/gendef/src/gendef.c
|
||||
@@ -196,7 +196,6 @@
|
||||
" By default, the output files are named after their DLL counterparts\n"
|
||||
" gendef MYDLL.DLL Produces MYDLL.def\n"
|
||||
" gendef - MYDLL.DLL Prints the exports to stdout\n");
|
||||
- fprintf (stderr, "\nBuilt on %s\n", __DATE__);
|
||||
fprintf (stderr, "\nReport bugs to <mingw-w64-public@lists.sourceforge.net>\n");
|
||||
exit (0);
|
||||
}
|
Loading…
Reference in a new issue