mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: python2-unittest2: Update to 1.1.0.
* gnu/packages/python.scm (python2-unittest2): Update to 1.1.0. * gnu/packages/patches/python2-unittest2-remove-argparse.patch: New file. * gnu/local.mk: Add it.
This commit is contained in:
parent
1898eaa335
commit
4792a0321a
3 changed files with 19 additions and 2 deletions
|
@ -994,6 +994,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
||||
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
||||
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
||||
%D%/packages/patches/python2-unittest2-remove-argparse.patch \
|
||||
%D%/packages/patches/qt4-ldflags.patch \
|
||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||
|
|
11
gnu/packages/patches/python2-unittest2-remove-argparse.patch
Normal file
11
gnu/packages/patches/python2-unittest2-remove-argparse.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/setup.py 2017-09-12 01:22:06.273997788 +0200
|
||||
+++ b/setup.py 2017-09-12 01:22:14.297918757 +0200
|
||||
@@ -57,7 +57,7 @@
|
||||
# Both install and setup requires - because we read VERSION from within the
|
||||
# package, and the package also exports all the APIs.
|
||||
# six for compat helpers
|
||||
-REQUIRES = ['argparse', 'six>=1.4', 'traceback2'],
|
||||
+REQUIRES = ['six>=1.4', 'traceback2'],
|
||||
|
||||
params = dict(
|
||||
name=NAME,
|
|
@ -1843,7 +1843,7 @@ (define-public python-unittest2
|
|||
(define-public python2-unittest2
|
||||
(package (inherit python-unittest2)
|
||||
(name "python2-unittest2")
|
||||
(version "0.5.1")
|
||||
(version "1.1.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -1852,7 +1852,12 @@ (define-public python2-unittest2
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0wbs4i4x3x7klr3v35ss6p9mcqz883i1xgcpkhvl7n2lyv6yhpda"))))
|
||||
"0y855kmx7a8rnf81d3lh5lyxai1908xjp0laf4glwa4c8472m212"))
|
||||
(patches
|
||||
(search-patches "python2-unittest2-remove-argparse.patch"))))
|
||||
(propagated-inputs
|
||||
`(("python2-six" ,python2-six)
|
||||
("python2-traceback2" ,python2-traceback2)))
|
||||
(arguments
|
||||
`(#:python ,python-2
|
||||
#:tests? #f)))) ; no setup.py test command
|
||||
|
|
Loading…
Reference in a new issue