mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: libtasn1: Remove obsolete patch.
This is a followup to 6a09628cb1
.
(picked from the wrong branch, sorry!)
* gnu/packages/tls.scm (libtasn1)[source]: Remove upstreamed patch.
* gnu/packages/patches/libtasn1-CVE-2017-6891.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
ccd7daae4c
commit
4953c33316
3 changed files with 0 additions and 53 deletions
|
@ -742,7 +742,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
|
||||
%D%/packages/patches/libssh2-fix-build-failure-with-gcrypt.patch \
|
||||
%D%/packages/patches/libtar-CVE-2013-4420.patch \
|
||||
%D%/packages/patches/libtasn1-CVE-2017-6891.patch \
|
||||
%D%/packages/patches/libtheora-config-guess.patch \
|
||||
%D%/packages/patches/libtiff-CVE-2016-10092.patch \
|
||||
%D%/packages/patches/libtiff-CVE-2016-10093.patch \
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
Fix CVE-2017-6891:
|
||||
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-6891
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://git.savannah.gnu.org/cgit/libtasn1.git/commit/?id=5520704d075802df25ce4ffccc010ba1641bd484
|
||||
|
||||
From 5520704d075802df25ce4ffccc010ba1641bd484 Mon Sep 17 00:00:00 2001
|
||||
From: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
||||
Date: Thu, 18 May 2017 18:03:34 +0200
|
||||
Subject: [PATCH] asn1_find_node: added safety check on asn1_find_node()
|
||||
|
||||
This prevents a stack overflow in asn1_find_node() which
|
||||
is triggered by too long variable names in the definitions
|
||||
files. That means that applications have to deliberately
|
||||
pass a too long 'name' constant to asn1_write_value()
|
||||
and friends. Reported by Jakub Jirasek.
|
||||
|
||||
Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
|
||||
---
|
||||
lib/parser_aux.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/lib/parser_aux.c b/lib/parser_aux.c
|
||||
index b4a7370..976ab38 100644
|
||||
--- a/lib/parser_aux.c
|
||||
+++ b/lib/parser_aux.c
|
||||
@@ -120,6 +120,9 @@ asn1_find_node (asn1_node pointer, const char *name)
|
||||
if (n_end)
|
||||
{
|
||||
nsize = n_end - n_start;
|
||||
+ if (nsize >= sizeof(n))
|
||||
+ return NULL;
|
||||
+
|
||||
memcpy (n, n_start, nsize);
|
||||
n[nsize] = 0;
|
||||
n_start = n_end;
|
||||
@@ -158,6 +161,9 @@ asn1_find_node (asn1_node pointer, const char *name)
|
||||
if (n_end)
|
||||
{
|
||||
nsize = n_end - n_start;
|
||||
+ if (nsize >= sizeof(n))
|
||||
+ return NULL;
|
||||
+
|
||||
memcpy (n, n_start, nsize);
|
||||
n[nsize] = 0;
|
||||
n_start = n_end;
|
||||
--
|
||||
2.13.0
|
||||
|
|
@ -58,7 +58,6 @@ (define-public libtasn1
|
|||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/libtasn1/libtasn1-"
|
||||
version ".tar.gz"))
|
||||
(patches (search-patches "libtasn1-CVE-2017-6891.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0h929bdq6w699y1mdkdajp5a6da8whgg3ba5p4j8x1wy36rlcjll"))))
|
||||
|
|
Loading…
Reference in a new issue