mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 04:29:25 -05:00
gnu: hurd: Update to hurd-headers version: 0.9-91a51672.
* gnu/packages/patches/hurd-cross.patch: New file. * gnu/packages/patches/hurd-fix-eth-multiplexer-dependency.patch: Remove unused file. * gnu/local.mk (dist_patch_DATA): Update admin. * gnu/packages/hurd.scm (hurd): Update to latest git master: version and source from hurd-headers; Add hurd-cross patch.
This commit is contained in:
parent
aaa4cb0cad
commit
496d607db3
4 changed files with 42 additions and 37 deletions
|
@ -1038,7 +1038,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/hdf-eos5-fortrantests.patch \
|
%D%/packages/patches/hdf-eos5-fortrantests.patch \
|
||||||
%D%/packages/patches/higan-remove-march-native-flag.patch \
|
%D%/packages/patches/higan-remove-march-native-flag.patch \
|
||||||
%D%/packages/patches/hubbub-sort-entities.patch \
|
%D%/packages/patches/hubbub-sort-entities.patch \
|
||||||
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \
|
%D%/packages/patches/hurd-cross.patch \
|
||||||
%D%/packages/patches/hplip-remove-imageprocessor.patch \
|
%D%/packages/patches/hplip-remove-imageprocessor.patch \
|
||||||
%D%/packages/patches/hydra-disable-darcs-test.patch \
|
%D%/packages/patches/hydra-disable-darcs-test.patch \
|
||||||
%D%/packages/patches/icecat-makeicecat.patch \
|
%D%/packages/patches/icecat-makeicecat.patch \
|
||||||
|
|
|
@ -282,14 +282,9 @@ (define-public gnumach
|
||||||
(define-public hurd
|
(define-public hurd
|
||||||
(package
|
(package
|
||||||
(name "hurd")
|
(name "hurd")
|
||||||
(version "0.9")
|
(version (package-version hurd-headers))
|
||||||
(source (origin
|
(source (origin (inherit (package-source hurd-headers))
|
||||||
(method url-fetch)
|
(patches (search-patches "hurd-cross.patch"))))
|
||||||
(uri (hurd-source-url version))
|
|
||||||
(sha256
|
|
||||||
(base32
|
|
||||||
"1nw9gly0n7pyv3cpfm4mmxy4yccrx4g0lyrvd3vk2vil26jpbggw"))
|
|
||||||
(patches (search-patches "hurd-fix-eth-multiplexer-dependency.patch"))))
|
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
|
@ -308,8 +303,11 @@ (define-public hurd
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("glibc-hurd-headers" ,glibc/hurd-headers)))
|
(inputs `(("glibc-hurd-headers" ,glibc/hurd-headers)))
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("mig" ,mig)
|
`(("autoconf" ,autoconf)
|
||||||
("perl" ,perl)))
|
("automake" ,automake)
|
||||||
|
("mig" ,mig)
|
||||||
|
("perl" ,perl)
|
||||||
|
("texinfo" ,texinfo-4)))
|
||||||
(supported-systems %hurd-systems)
|
(supported-systems %hurd-systems)
|
||||||
(home-page "https://www.gnu.org/software/hurd/hurd.html")
|
(home-page "https://www.gnu.org/software/hurd/hurd.html")
|
||||||
(synopsis "The kernel servers for the GNU operating system")
|
(synopsis "The kernel servers for the GNU operating system")
|
||||||
|
|
33
gnu/packages/patches/hurd-cross.patch
Normal file
33
gnu/packages/patches/hurd-cross.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
This fixes linking libfstest/test-fcntl (and others).
|
||||||
|
|
||||||
|
As discussed with upstream: https://lists.gnu.org/archive/html/bug-hurd/2020-03/msg00018.html
|
||||||
|
|
||||||
|
From 96a9f67a8685e713f25259c18306797d54cc27a5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Nieuwenhuizen <janneke@gnu.org>
|
||||||
|
Date: Sat, 14 Mar 2020 11:28:31 +0100
|
||||||
|
Subject: [PATCH] build: Fix cross build on Guix.
|
||||||
|
|
||||||
|
As discussed in https://lists.gnu.org/archive/html/bug-hurd/2020-03/msg00018.html.
|
||||||
|
|
||||||
|
* Makeconf (lpath): Add -Wl,-rpath-link=<dir> next to -L<dir>.
|
||||||
|
---
|
||||||
|
Makeconf | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makeconf b/Makeconf
|
||||||
|
index 67f7ab1c..f68ff6e3 100644
|
||||||
|
--- a/Makeconf
|
||||||
|
+++ b/Makeconf
|
||||||
|
@@ -325,7 +325,8 @@ _libsubst=${libsubst$(patsubst %,-override,${libsubst-override})}
|
||||||
|
|
||||||
|
# Direct the linker where to find shared objects specified in the
|
||||||
|
# dependencies of other shared objects it encounters.
|
||||||
|
-lpath := -L. $(patsubst %,-L%,$(dir $(wildcard ../lib*/lib*.so)))
|
||||||
|
+lib_dirs := $(dir $(wildcard ../lib*/lib*.so))
|
||||||
|
+lpath := -L. $(lib_dirs:%=-L%) $(lib_dirs:%=-Wl,-rpath-link=%)
|
||||||
|
|
||||||
|
# Main rule to link executables
|
||||||
|
#
|
||||||
|
--
|
||||||
|
2.24.0
|
||||||
|
|
|
@ -1,26 +0,0 @@
|
||||||
From ef0399bad41e60cb30d5073129abeb206076394a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Manolis Ragkousis <manolis837@gmail.com>
|
|
||||||
Date: Sat, 8 Apr 2017 16:44:52 +0300
|
|
||||||
Subject: [PATCH] eth-multiplexer: Fix iohelp missing dependency.
|
|
||||||
|
|
||||||
* eth-multiplexer/Makefile (HURDLIBS): Add iohelp.
|
|
||||||
---
|
|
||||||
eth-multiplexer/Makefile | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/eth-multiplexer/Makefile b/eth-multiplexer/Makefile
|
|
||||||
index 07f909e7..cefa0abd 100644
|
|
||||||
--- a/eth-multiplexer/Makefile
|
|
||||||
+++ b/eth-multiplexer/Makefile
|
|
||||||
@@ -26,7 +26,7 @@ MIGSFLAGS = -imacros $(srcdir)/mig-mutate.h
|
|
||||||
device-MIGSFLAGS="-DMACH_PAYLOAD_TO_PORT=ports_payload_get_name"
|
|
||||||
OBJS = $(SRCS:.c=.o) $(MIGSTUBS)
|
|
||||||
LCLHDRS = ethernet.h util.h vdev.h netfs_impl.h
|
|
||||||
-HURDLIBS = ports ihash fshelp shouldbeinlibc netfs bpf
|
|
||||||
+HURDLIBS = ports ihash iohelp fshelp shouldbeinlibc netfs bpf
|
|
||||||
LDLIBS = -lpthread
|
|
||||||
|
|
||||||
CFLAGS += -I$(top_srcdir)/libbpf
|
|
||||||
--
|
|
||||||
2.12.2
|
|
||||||
|
|
Loading…
Reference in a new issue