mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: libopenshot: Update to 0.2.3.
* gnu/packages/video.scm (libopenshot): Update to 0.2.3.
This commit is contained in:
parent
799298ebf3
commit
4994174fa0
4 changed files with 3 additions and 250 deletions
|
@ -996,8 +996,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libffi-3.2.1-complex-alpha.patch \
|
||||
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
||||
%D%/packages/patches/libjxr-fix-typos.patch \
|
||||
%D%/packages/patches/libopenshot-fixup-tests.patch \
|
||||
%D%/packages/patches/libopenshot-tests-with-system-libs.patch \
|
||||
%D%/packages/patches/libotr-test-auth-fix.patch \
|
||||
%D%/packages/patches/libmad-armv7-thumb-pt1.patch \
|
||||
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \
|
||||
|
|
|
@ -1,148 +0,0 @@
|
|||
From 691536f2f8a9ed7322fedb24d489db08c70705b9 Mon Sep 17 00:00:00 2001
|
||||
From: "Dr. Tobias Quathamer" <toddy@debian.org>
|
||||
Date: Sat, 18 Nov 2017 13:54:22 +0100
|
||||
Subject: [PATCH] This the combination of two patches:
|
||||
https://sources.debian.org/data/main/libo/libopenshot/0.2.2+dfsg1-1/debian/patches/0003-Fix-failing-tests-by-using-a-fault-tolerance.patch
|
||||
https://sources.debian.org/data/main/libo/libopenshot/0.2.2+dfsg1-1/debian/patches/0004-Add-some-more-fault-tolerance-for-arm64.patch
|
||||
|
||||
Together they should fix the test suite on all architectures
|
||||
---
|
||||
tests/FFmpegReader_Tests.cpp | 9 ++++-----
|
||||
tests/ImageWriter_Tests.cpp | 8 ++++----
|
||||
tests/Timeline_Tests.cpp | 28 ++++++++++++++--------------
|
||||
3 files changed, 22 insertions(+), 23 deletions(-)
|
||||
|
||||
diff --git a/tests/FFmpegReader_Tests.cpp b/tests/FFmpegReader_Tests.cpp
|
||||
index 53563ca..07fc41e 100644
|
||||
--- a/tests/FFmpegReader_Tests.cpp
|
||||
+++ b/tests/FFmpegReader_Tests.cpp
|
||||
@@ -95,8 +95,8 @@ TEST(FFmpegReader_Check_Video_File)
|
||||
int pixel_index = 112 * 4; // pixel 112 (4 bytes per pixel)
|
||||
|
||||
// Check image properties on scanline 10, pixel 112
|
||||
- CHECK_EQUAL(21, (int)pixels[pixel_index]);
|
||||
- CHECK_EQUAL(191, (int)pixels[pixel_index + 1]);
|
||||
+ CHECK_CLOSE(21, (int)pixels[pixel_index], 1);
|
||||
+ CHECK_CLOSE(191, (int)pixels[pixel_index + 1], 2);
|
||||
CHECK_EQUAL(0, (int)pixels[pixel_index + 2]);
|
||||
CHECK_EQUAL(255, (int)pixels[pixel_index + 3]);
|
||||
|
||||
@@ -109,8 +109,8 @@ TEST(FFmpegReader_Check_Video_File)
|
||||
|
||||
// Check image properties on scanline 10, pixel 112
|
||||
CHECK_EQUAL(0, (int)pixels[pixel_index]);
|
||||
- CHECK_EQUAL(96, (int)pixels[pixel_index + 1]);
|
||||
- CHECK_EQUAL(188, (int)pixels[pixel_index + 2]);
|
||||
+ CHECK_CLOSE(96, (int)pixels[pixel_index + 1], 1);
|
||||
+ CHECK_CLOSE(188, (int)pixels[pixel_index + 2], 1);
|
||||
CHECK_EQUAL(255, (int)pixels[pixel_index + 3]);
|
||||
|
||||
// Close reader
|
||||
@@ -209,4 +209,3 @@ TEST(FFmpegReader_Multiple_Open_and_Close)
|
||||
// Close reader
|
||||
r.Close();
|
||||
}
|
||||
-
|
||||
diff --git a/tests/ImageWriter_Tests.cpp b/tests/ImageWriter_Tests.cpp
|
||||
index 107ee39..d10c8bd 100644
|
||||
--- a/tests/ImageWriter_Tests.cpp
|
||||
+++ b/tests/ImageWriter_Tests.cpp
|
||||
@@ -73,9 +73,9 @@ TEST(ImageWriter_Test_Gif)
|
||||
int pixel_index = 230 * 4; // pixel 230 (4 bytes per pixel)
|
||||
|
||||
// Check image properties
|
||||
- CHECK_EQUAL(20, (int)pixels[pixel_index]);
|
||||
- CHECK_EQUAL(18, (int)pixels[pixel_index + 1]);
|
||||
- CHECK_EQUAL(11, (int)pixels[pixel_index + 2]);
|
||||
+ CHECK_CLOSE(20, (int)pixels[pixel_index], 5);
|
||||
+ CHECK_CLOSE(18, (int)pixels[pixel_index + 1], 2);
|
||||
+ CHECK_CLOSE(11, (int)pixels[pixel_index + 2], 2);
|
||||
CHECK_EQUAL(255, (int)pixels[pixel_index + 3]);
|
||||
}
|
||||
-#endif
|
||||
\ No newline at end of file
|
||||
+#endif
|
||||
diff --git a/tests/Timeline_Tests.cpp b/tests/Timeline_Tests.cpp
|
||||
index 8c81579..4d861a6 100644
|
||||
--- a/tests/Timeline_Tests.cpp
|
||||
+++ b/tests/Timeline_Tests.cpp
|
||||
@@ -119,8 +119,8 @@ TEST(Timeline_Check_Two_Track_Video)
|
||||
int pixel_index = 230 * 4; // pixel 230 (4 bytes per pixel)
|
||||
|
||||
// Check image properties
|
||||
- CHECK_EQUAL(21, (int)f->GetPixels(pixel_row)[pixel_index]);
|
||||
- CHECK_EQUAL(191, (int)f->GetPixels(pixel_row)[pixel_index + 1]);
|
||||
+ CHECK_CLOSE(21, (int)f->GetPixels(pixel_row)[pixel_index], 2);
|
||||
+ CHECK_CLOSE(191, (int)f->GetPixels(pixel_row)[pixel_index + 1], 2);
|
||||
CHECK_EQUAL(0, (int)f->GetPixels(pixel_row)[pixel_index + 2]);
|
||||
CHECK_EQUAL(255, (int)f->GetPixels(pixel_row)[pixel_index + 3]);
|
||||
|
||||
@@ -128,17 +128,17 @@ TEST(Timeline_Check_Two_Track_Video)
|
||||
f = t.GetFrame(2);
|
||||
|
||||
// Check image properties
|
||||
- CHECK_EQUAL(176, (int)f->GetPixels(pixel_row)[pixel_index]);
|
||||
+ CHECK_CLOSE(176, (int)f->GetPixels(pixel_row)[pixel_index], 1);
|
||||
CHECK_EQUAL(0, (int)f->GetPixels(pixel_row)[pixel_index + 1]);
|
||||
- CHECK_EQUAL(186, (int)f->GetPixels(pixel_row)[pixel_index + 2]);
|
||||
+ CHECK_CLOSE(186, (int)f->GetPixels(pixel_row)[pixel_index + 2], 1);
|
||||
CHECK_EQUAL(255, (int)f->GetPixels(pixel_row)[pixel_index + 3]);
|
||||
|
||||
// Get frame
|
||||
f = t.GetFrame(3);
|
||||
|
||||
// Check image properties
|
||||
- CHECK_EQUAL(23, (int)f->GetPixels(pixel_row)[pixel_index]);
|
||||
- CHECK_EQUAL(190, (int)f->GetPixels(pixel_row)[pixel_index + 1]);
|
||||
+ CHECK_CLOSE(23, (int)f->GetPixels(pixel_row)[pixel_index], 1);
|
||||
+ CHECK_CLOSE(190, (int)f->GetPixels(pixel_row)[pixel_index + 1], 2);
|
||||
CHECK_EQUAL(0, (int)f->GetPixels(pixel_row)[pixel_index + 2]);
|
||||
CHECK_EQUAL(255, (int)f->GetPixels(pixel_row)[pixel_index + 3]);
|
||||
|
||||
@@ -146,8 +146,8 @@ TEST(Timeline_Check_Two_Track_Video)
|
||||
f = t.GetFrame(24);
|
||||
|
||||
// Check image properties
|
||||
- CHECK_EQUAL(186, (int)f->GetPixels(pixel_row)[pixel_index]);
|
||||
- CHECK_EQUAL(106, (int)f->GetPixels(pixel_row)[pixel_index + 1]);
|
||||
+ CHECK_CLOSE(186, (int)f->GetPixels(pixel_row)[pixel_index], 1);
|
||||
+ CHECK_CLOSE(106, (int)f->GetPixels(pixel_row)[pixel_index + 1], 1);
|
||||
CHECK_EQUAL(0, (int)f->GetPixels(pixel_row)[pixel_index + 2]);
|
||||
CHECK_EQUAL(255, (int)f->GetPixels(pixel_row)[pixel_index + 3]);
|
||||
|
||||
@@ -155,8 +155,8 @@ TEST(Timeline_Check_Two_Track_Video)
|
||||
f = t.GetFrame(5);
|
||||
|
||||
// Check image properties
|
||||
- CHECK_EQUAL(23, (int)f->GetPixels(pixel_row)[pixel_index]);
|
||||
- CHECK_EQUAL(190, (int)f->GetPixels(pixel_row)[pixel_index + 1]);
|
||||
+ CHECK_CLOSE(23, (int)f->GetPixels(pixel_row)[pixel_index], 1);
|
||||
+ CHECK_CLOSE(190, (int)f->GetPixels(pixel_row)[pixel_index + 1], 2);
|
||||
CHECK_EQUAL(0, (int)f->GetPixels(pixel_row)[pixel_index + 2]);
|
||||
CHECK_EQUAL(255, (int)f->GetPixels(pixel_row)[pixel_index + 3]);
|
||||
|
||||
@@ -165,17 +165,17 @@ TEST(Timeline_Check_Two_Track_Video)
|
||||
|
||||
// Check image properties
|
||||
CHECK_EQUAL(0, (int)f->GetPixels(pixel_row)[pixel_index]);
|
||||
- CHECK_EQUAL(94, (int)f->GetPixels(pixel_row)[pixel_index + 1]);
|
||||
- CHECK_EQUAL(186, (int)f->GetPixels(pixel_row)[pixel_index + 2]);
|
||||
+ CHECK_CLOSE(94, (int)f->GetPixels(pixel_row)[pixel_index + 1], 1);
|
||||
+ CHECK_CLOSE(186, (int)f->GetPixels(pixel_row)[pixel_index + 2], 1);
|
||||
CHECK_EQUAL(255, (int)f->GetPixels(pixel_row)[pixel_index + 3]);
|
||||
|
||||
// Get frame
|
||||
f = t.GetFrame(4);
|
||||
|
||||
// Check image properties
|
||||
- CHECK_EQUAL(176, (int)f->GetPixels(pixel_row)[pixel_index]);
|
||||
+ CHECK_CLOSE(176, (int)f->GetPixels(pixel_row)[pixel_index], 1);
|
||||
CHECK_EQUAL(0, (int)f->GetPixels(pixel_row)[pixel_index + 1]);
|
||||
- CHECK_EQUAL(186, (int)f->GetPixels(pixel_row)[pixel_index + 2]);
|
||||
+ CHECK_CLOSE(186, (int)f->GetPixels(pixel_row)[pixel_index + 2], 1);
|
||||
CHECK_EQUAL(255, (int)f->GetPixels(pixel_row)[pixel_index + 3]);
|
||||
|
||||
// Close reader
|
||||
--
|
||||
2.21.0
|
||||
|
|
@ -1,95 +0,0 @@
|
|||
Combination of two patches that fix libopenshot tests when built with
|
||||
system-provided ffmpeg and jsoncpp. See
|
||||
|
||||
https://github.com/OpenShot/libopenshot/pull/163
|
||||
|
||||
From 0d7691ab53433e1583f6a66ea96683b0f7af8a57 Mon Sep 17 00:00:00 2001
|
||||
From: "FeRD (Frank Dana)" <ferdnyc@gmail.com>
|
||||
Date: Mon, 17 Sep 2018 14:04:40 -0400
|
||||
Subject: [PATCH] tests/CMakeFiles: Use FFMpeg like src/
|
||||
|
||||
---
|
||||
tests/CMakeLists.txt | 32 +++++++++++++++++++++++++++++++-
|
||||
1 file changed, 31 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
||||
index 2c45550..4df8464 100644
|
||||
--- a/tests/CMakeLists.txt
|
||||
+++ b/tests/CMakeLists.txt
|
||||
@@ -79,7 +79,37 @@ ENDIF (ImageMagick_FOUND)
|
||||
FIND_PACKAGE(FFmpeg REQUIRED)
|
||||
|
||||
# Include FFmpeg headers (needed for compile)
|
||||
-include_directories(${FFMPEG_INCLUDE_DIR})
|
||||
+message('AVCODEC_FOUND: ${AVCODEC_FOUND}')
|
||||
+message('AVCODEC_INCLUDE_DIRS: ${AVCODEC_INCLUDE_DIRS}')
|
||||
+message('AVCODEC_LIBRARIES: ${AVCODEC_LIBRARIES}')
|
||||
+
|
||||
+IF (AVCODEC_FOUND)
|
||||
+ include_directories(${AVCODEC_INCLUDE_DIRS})
|
||||
+ENDIF (AVCODEC_FOUND)
|
||||
+IF (AVDEVICE_FOUND)
|
||||
+ include_directories(${AVDEVICE_INCLUDE_DIRS})
|
||||
+ENDIF (AVDEVICE_FOUND)
|
||||
+IF (AVFORMAT_FOUND)
|
||||
+ include_directories(${AVFORMAT_INCLUDE_DIRS})
|
||||
+ENDIF (AVFORMAT_FOUND)
|
||||
+IF (AVFILTER_FOUND)
|
||||
+ include_directories(${AVFILTER_INCLUDE_DIRS})
|
||||
+ENDIF (AVFILTER_FOUND)
|
||||
+IF (AVUTIL_FOUND)
|
||||
+ include_directories(${AVUTIL_INCLUDE_DIRS})
|
||||
+ENDIF (AVUTIL_FOUND)
|
||||
+IF (POSTPROC_FOUND)
|
||||
+ include_directories(${POSTPROC_INCLUDE_DIRS})
|
||||
+ENDIF (POSTPROC_FOUND)
|
||||
+IF (SWSCALE_FOUND)
|
||||
+ include_directories(${SWSCALE_INCLUDE_DIRS})
|
||||
+ENDIF (SWSCALE_FOUND)
|
||||
+IF (SWRESAMPLE_FOUND)
|
||||
+ include_directories(${SWRESAMPLE_INCLUDE_DIRS})
|
||||
+ENDIF (SWRESAMPLE_FOUND)
|
||||
+IF (AVRESAMPLE_FOUND)
|
||||
+ include_directories(${AVRESAMPLE_INCLUDE_DIRS})
|
||||
+ENDIF (AVRESAMPLE_FOUND)
|
||||
|
||||
################# LIBOPENSHOT-AUDIO ###################
|
||||
# Find JUCE-based openshot Audio libraries
|
||||
|
||||
|
||||
From e9e85cdfd036587adb86341f7f81619dc69f102c Mon Sep 17 00:00:00 2001
|
||||
From: "FeRD (Frank Dana)" <ferdnyc@gmail.com>
|
||||
Date: Mon, 17 Sep 2018 19:23:25 -0400
|
||||
Subject: [PATCH] Use system jsoncpp in tests, too
|
||||
|
||||
The tests/ build needs to use the same jsoncpp as the src/ build,
|
||||
or tests in Clip_Tests.cpp can fail.
|
||||
---
|
||||
tests/CMakeLists.txt | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
||||
index 4df8464..a1a0356 100644
|
||||
--- a/tests/CMakeLists.txt
|
||||
+++ b/tests/CMakeLists.txt
|
||||
@@ -180,12 +180,18 @@ endif(OPENMP_FOUND)
|
||||
# Find ZeroMQ library (used for socket communication & logging)
|
||||
FIND_PACKAGE(ZMQ REQUIRED)
|
||||
|
||||
-# Include FFmpeg headers (needed for compile)
|
||||
+# Include ZeroMQ headers (needed for compile)
|
||||
include_directories(${ZMQ_INCLUDE_DIRS})
|
||||
|
||||
################### JSONCPP #####################
|
||||
# Include jsoncpp headers (needed for JSON parsing)
|
||||
-include_directories("../thirdparty/jsoncpp/include")
|
||||
+if (USE_SYSTEM_JSONCPP)
|
||||
+ find_package(JsonCpp REQUIRED)
|
||||
+ include_directories(${JSONCPP_INCLUDE_DIRS})
|
||||
+else()
|
||||
+ message("Using embedded JsonCpp")
|
||||
+ include_directories("../thirdparty/jsoncpp/include")
|
||||
+endif(USE_SYSTEM_JSONCPP)
|
||||
|
||||
IF (NOT DISABLE_TESTS)
|
||||
############### SET TEST SOURCE FILES #################
|
|
@ -3300,7 +3300,7 @@ (define-public vidstab
|
|||
(define-public libopenshot
|
||||
(package
|
||||
(name "libopenshot")
|
||||
(version "0.2.2")
|
||||
(version "0.2.3")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -3309,7 +3309,7 @@ (define-public libopenshot
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1x4kv05pdq1pglb6y056aa7llc6iyibyhzg93k7zwj0q08cp5ixd"))
|
||||
"0r1qmr8ar5n72603xkj9h065vbpznrqsq88kxxmn9n8djyyvk03k"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet '(begin
|
||||
;; Allow overriding of the python installation dir
|
||||
|
@ -3318,9 +3318,7 @@ (define-public libopenshot
|
|||
(string-append set " CACHE PATH "
|
||||
"\"Python bindings directory\")")))
|
||||
(delete-file-recursively "thirdparty")
|
||||
#t))
|
||||
(patches (search-patches "libopenshot-fixup-tests.patch"
|
||||
"libopenshot-tests-with-system-libs.patch"))))
|
||||
#t))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
|
|
Loading…
Reference in a new issue