mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 21:59:08 -05:00
Revert "gnu: aspell: Update to 0.60.8."
This reverts commit 4fcb6a3558
.
aspell causes about 1400 packages to be rebuilt.
This commit is contained in:
parent
9eb6d7125b
commit
4a822462ef
3 changed files with 37 additions and 4 deletions
|
@ -695,6 +695,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
|
||||
%D%/packages/patches/apr-skip-getservbyname-test.patch \
|
||||
%D%/packages/patches/aspell-default-dict-dir.patch \
|
||||
%D%/packages/patches/aspell-gcc-compat.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
|
||||
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
|
||||
|
|
|
@ -38,7 +38,7 @@ (define-module (gnu packages aspell)
|
|||
(define-public aspell
|
||||
(package
|
||||
(name "aspell")
|
||||
(version "0.60.8")
|
||||
(version "0.60.6.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -46,8 +46,9 @@ (define-public aspell
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1wi60ankalmh8ds7nplz434jd7j94gdvbahdwsr539rlad8pxdzr"))
|
||||
(patches (search-patches "aspell-default-dict-dir.patch"))))
|
||||
"1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
|
||||
(patches (search-patches "aspell-default-dict-dir.patch"
|
||||
"aspell-gcc-compat.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
@ -143,7 +144,7 @@ (define* (aspell-dictionary dict-name full-name
|
|||
(define-public aspell-dict-ar
|
||||
(aspell-dictionary "ar" "Arabic"
|
||||
#:version "1.2-0"
|
||||
#:prefix "aspell6-"
|
||||
#:prefix "aspell6-"
|
||||
#:sha256
|
||||
(base32
|
||||
"1avw40bp8yi5bnkq64ihm2rldgw34lk89yz281q9bmndh95a47h4")))
|
||||
|
|
31
gnu/packages/patches/aspell-gcc-compat.patch
Normal file
31
gnu/packages/patches/aspell-gcc-compat.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
Fix GCC7 warnings.
|
||||
|
||||
Taken from upstream:
|
||||
https://git.savannah.gnu.org/cgit/aspell.git/commit/?id=8089fa02122fed0a6394eba14bbedcb1d18e2384
|
||||
|
||||
diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
|
||||
index a979539..19ab63c 100644
|
||||
--- a/modules/filter/tex.cpp
|
||||
+++ b/modules/filter/tex.cpp
|
||||
@@ -174,7 +174,7 @@ namespace {
|
||||
|
||||
if (c == '{') {
|
||||
|
||||
- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
|
||||
+ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
|
||||
push_command(Parm);
|
||||
|
||||
top.in_what = Parm;
|
||||
diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
|
||||
index db54f3d..89ee09d 100644
|
||||
--- a/prog/check_funs.cpp
|
||||
+++ b/prog/check_funs.cpp
|
||||
@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
|
||||
}
|
||||
}
|
||||
if (i == width-1) {
|
||||
- if (word == '\0')
|
||||
+ if (*word == '\0')
|
||||
put(out,' ');
|
||||
else if (word[len] == '\0')
|
||||
put(out, word, len);
|
Loading…
Reference in a new issue