mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 04:29:25 -05:00
gnu: gwenview: Update to 23.08.5 and fix build.
* gnu/packages/kde.scm (gwenview): Update to 23.08.5. [source]: Apply gwenview-kimageannotator patch. [inputs]: Remove qtimageformats; add qtimageformats-5. * gnu/packages/patches/gwenview-kimageannotator.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: If73bc38772adef9f43d74f0f9061dfb2600aa502
This commit is contained in:
parent
1757b5bc3c
commit
4ab5d17e21
3 changed files with 34 additions and 3 deletions
|
@ -1438,6 +1438,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gtk4-respect-GUIX_GTK4_PATH.patch \
|
%D%/packages/patches/gtk4-respect-GUIX_GTK4_PATH.patch \
|
||||||
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||||
%D%/packages/patches/gtksourceview-2-add-default-directory.patch \
|
%D%/packages/patches/gtksourceview-2-add-default-directory.patch \
|
||||||
|
%D%/packages/patches/gwenview-kimageannotator.patch \
|
||||||
%D%/packages/patches/gzdoom-search-in-installed-share.patch \
|
%D%/packages/patches/gzdoom-search-in-installed-share.patch \
|
||||||
%D%/packages/patches/gzdoom-find-system-libgme.patch \
|
%D%/packages/patches/gzdoom-find-system-libgme.patch \
|
||||||
%D%/packages/patches/hdf4-reproducibility.patch \
|
%D%/packages/patches/hdf4-reproducibility.patch \
|
||||||
|
|
|
@ -233,14 +233,15 @@ (define-public akregator
|
||||||
(define-public gwenview
|
(define-public gwenview
|
||||||
(package
|
(package
|
||||||
(name "gwenview")
|
(name "gwenview")
|
||||||
(version "23.04.3")
|
(version "23.08.5")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://kde/stable/release-service/" version
|
(uri (string-append "mirror://kde/stable/release-service/" version
|
||||||
"/src/gwenview-" version ".tar.xz"))
|
"/src/gwenview-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0vijsq4174p4asdjq47bzdp2xkfn8hpg7b4dgp3yvapfxwjgp148"))))
|
(base32 "0f4h2vf8nkz1jcrxw98n52divvdmxh434659m1pd4l5pag0d3z54"))
|
||||||
|
(patches (search-patches "gwenview-kimageannotator.patch"))))
|
||||||
(build-system qt-build-system)
|
(build-system qt-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
(list #:phases
|
(list #:phases
|
||||||
|
@ -281,7 +282,7 @@ (define-public gwenview
|
||||||
libtiff
|
libtiff
|
||||||
phonon
|
phonon
|
||||||
purpose
|
purpose
|
||||||
qtimageformats
|
qtimageformats-5
|
||||||
qtsvg-5
|
qtsvg-5
|
||||||
qtwayland-5
|
qtwayland-5
|
||||||
qtx11extras
|
qtx11extras
|
||||||
|
|
29
gnu/packages/patches/gwenview-kimageannotator.patch
Normal file
29
gnu/packages/patches/gwenview-kimageannotator.patch
Normal file
|
@ -0,0 +1,29 @@
|
||||||
|
Submitted By: Douglas R. Reno <renodr at linuxfromscratch dot org>
|
||||||
|
Date: 2024-02-26
|
||||||
|
Initial Package Version: 23.08.5
|
||||||
|
Upstream Status: Rejected (Qt6 port is primary now)
|
||||||
|
Origin: Self
|
||||||
|
Description: Fixes building Gwenview with recent kImageAnnotator
|
||||||
|
and kColorPicker versions by adjusting their paths
|
||||||
|
and FOUND variables so that the correct libraries are
|
||||||
|
selected.
|
||||||
|
|
||||||
|
--- gwenview-23.08.5.orig/CMakeLists.txt 2024-02-26 15:02:29.702754535 -0600
|
||||||
|
+++ gwenview-23.08.5/CMakeLists.txt 2024-02-26 15:09:48.012866877 -0600
|
||||||
|
@@ -166,11 +166,11 @@ if(NOT WITHOUT_X11)
|
||||||
|
endif()
|
||||||
|
|
||||||
|
if (QT_MAJOR_VERSION STREQUAL "5")
|
||||||
|
- find_package(kImageAnnotator)
|
||||||
|
- set_package_properties(kImageAnnotator PROPERTIES URL "https://github.com/ksnip/kImageAnnotator" DESCRIPTION "The kImageAnnotator library provides tools to annotate" TYPE REQUIRED)
|
||||||
|
- if(kImageAnnotator_FOUND)
|
||||||
|
- set(KIMAGEANNOTATOR_FOUND 1)
|
||||||
|
- find_package(kColorPicker REQUIRED)
|
||||||
|
+ find_package(kImageAnnotator-Qt5)
|
||||||
|
+ set_package_properties(kImageAnnotator-Qt5 PROPERTIES URL "https://github.com/ksnip/kImageAnnotator" DESCRIPTION "The kImageAnnotator library provides tools to annotate" TYPE REQUIRED)
|
||||||
|
+ if(kImageAnnotator-Qt5_FOUND)
|
||||||
|
+ set(kImageAnnotator_FOUND 1)
|
||||||
|
+ find_package(kColorPicker-Qt5 REQUIRED)
|
||||||
|
if(NOT kImageAnnotator_VERSION VERSION_LESS 0.5.0)
|
||||||
|
set(KIMAGEANNOTATOR_CAN_LOAD_TRANSLATIONS 1)
|
||||||
|
endif()
|
Loading…
Reference in a new issue