mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-24 19:49:25 -05:00
gnu: libcacard: Update to 2.8.1.
* gnu/packages/spice.scm (libcacard): Update to 2.8.1. [source]: Remove patch. * gnu/packages/patches/libcacard-unknown-variable.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
15e5d22fcb
commit
4d5f7986d6
3 changed files with 3 additions and 55 deletions
|
@ -1365,7 +1365,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libbonobo-activation-test-race.patch \
|
||||
%D%/packages/patches/libcaca-CVE-2021-3410-pt1.patch \
|
||||
%D%/packages/patches/libcaca-CVE-2021-3410-pt2.patch \
|
||||
%D%/packages/patches/libcacard-unknown-variable.patch \
|
||||
%D%/packages/patches/libcanberra-sound-theme-freedesktop.patch \
|
||||
%D%/packages/patches/libcanberra-wayland-crash.patch \
|
||||
%D%/packages/patches/libcroco-CVE-2020-12825.patch \
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
Fix Meson error when test dependencies are missing.
|
||||
|
||||
Based on this upstream commit, with some adjustments to apply on 2.8.0:
|
||||
https://gitlab.freedesktop.org/spice/libcacard/-/commit/cf6121deb47e437aa566cfeb29a03da93c432394
|
||||
|
||||
diff --git a/tests/meson.build b/tests/meson.build
|
||||
index 87945a2..baefaf5 100644
|
||||
--- a/tests/meson.build
|
||||
+++ b/tests/meson.build
|
||||
@@ -9,15 +9,6 @@ modutil_dep = find_program('modutil', required: false)
|
||||
openssl_dep = find_program('openssl', required: false)
|
||||
softhsm_util_dep = find_program('softhsm2-util', required: false)
|
||||
|
||||
-if pkcs11_tool_dep.found() and p11tool_dep.found() and modutil_dep.found() and openssl_dep.found() and softhsm_util_dep.found()
|
||||
- softhsm = custom_target(
|
||||
- 'softhsm2.conf',
|
||||
- command: find_program('setup-softhsm2.sh'),
|
||||
- capture: true,
|
||||
- output: 'setup-softhsm2.log',
|
||||
- )
|
||||
-endif
|
||||
-
|
||||
libcacard_test = executable(
|
||||
'libcacard',
|
||||
['libcacard.c', 'common.c'],
|
||||
@@ -64,9 +55,18 @@ hwtests_test = executable(
|
||||
dependencies: [libcacard_dep],
|
||||
)
|
||||
|
||||
-test(
|
||||
- 'hwtests',
|
||||
- hwtests_test,
|
||||
- depends: [softhsm],
|
||||
- env: env,
|
||||
-)
|
||||
+if pkcs11_tool_dep.found() and p11tool_dep.found() and modutil_dep.found() and openssl_dep.found() and softhsm_util_dep.found()
|
||||
+ softhsm = custom_target(
|
||||
+ 'softhsm2.conf',
|
||||
+ command: find_program('setup-softhsm2.sh'),
|
||||
+ capture: true,
|
||||
+ output: 'setup-softhsm2.log',
|
||||
+ )
|
||||
+
|
||||
+ test(
|
||||
+ 'hwtests',
|
||||
+ hwtests_test,
|
||||
+ depends: [softhsm],
|
||||
+ env: env,
|
||||
+ )
|
||||
+endif
|
|
@ -329,17 +329,16 @@ (define-public spice-vdagent
|
|||
(define-public libcacard
|
||||
(package
|
||||
(name "libcacard")
|
||||
(version "2.8.0")
|
||||
(version "2.8.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://gitlab.freedesktop.org/spice/libcacard/uploads/"
|
||||
"9d8f24b131bcbbd7846727ea92952cb5"
|
||||
"13b249e695a0d9aa7cb501b1a85ebab1"
|
||||
"/libcacard-" version ".tar.xz"))
|
||||
(patches (search-patches "libcacard-unknown-variable.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0azj3rqr2smg0lai24xrn3zr628xmjfrzcggay877zrr64ybj1c0"))))
|
||||
"1rrjlclm6ad63gah1fa4yfwrz4z6vgq2yrybbvzvvdbxrgl4vgzv"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f ; TODO Tests require gnutls built with
|
||||
|
|
Loading…
Reference in a new issue