mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-24 03:29:40 -05:00
gnu: Add ibus-table.
* gnu/packages/patches/ibus-table-paths.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/ibus.scm (ibus-table): New variable. Co-authored-by: 宋文武 <iyzsong@member.fsf.org>
This commit is contained in:
parent
55593beaba
commit
4eeb35595b
3 changed files with 83 additions and 0 deletions
|
@ -899,6 +899,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/akonadi-timestamps.patch \
|
||||
%D%/packages/patches/allegro-mesa-18.2.5-and-later.patch \
|
||||
%D%/packages/patches/ibus-anthy-fix-tests.patch \
|
||||
%D%/packages/patches/ibus-table-paths.patch \
|
||||
%D%/packages/patches/anki-mpv-args.patch \
|
||||
%D%/packages/patches/antiword-CVE-2014-8123.patch \
|
||||
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
|
||||
|
|
|
@ -906,6 +906,50 @@ (define-public ibus-libhangul
|
|||
"ibus-hangul is a Korean input method engine for IBus.")
|
||||
(license gpl2+)))
|
||||
|
||||
(define-public ibus-table
|
||||
(package
|
||||
(name "ibus-table")
|
||||
(version "1.17.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/mike-fabian/ibus-table/releases/download/"
|
||||
version "/ibus-table-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "063ba4fwk04lh0naj8z9r9x15ikckp94pd3f8xn40z3lnwsjx2sj"))
|
||||
(patches (search-patches "ibus-table-paths.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
(list #:phases
|
||||
#~(modify-phases %standard-phases
|
||||
(add-after 'unpack 'patch-paths
|
||||
(lambda _
|
||||
(substitute* "engine/tabcreatedb.py"
|
||||
(("/usr/share/ibus-table")
|
||||
(string-append #$output "/share/ibus-table")))
|
||||
(substitute* "engine/ibus_table_location.py"
|
||||
(("/usr/share/ibus-table")
|
||||
(string-append #$output "/share/ibus-table"))
|
||||
(("/usr/libexec")
|
||||
(string-append #$output "/libexec")))))
|
||||
(add-before 'check 'pre-check
|
||||
(lambda _
|
||||
(setenv "HOME" (getcwd))))))) ; tests write to $HOME
|
||||
(native-inputs (list (list glib "bin") pkg-config))
|
||||
(inputs (list glib gtk+ ibus python python-pygobject))
|
||||
(native-search-paths
|
||||
(list (search-path-specification
|
||||
(variable "IBUS_TABLE_LOCATION")
|
||||
(files '("share/ibus-table"))
|
||||
(separator #f))))
|
||||
(home-page "https://mike-fabian.github.io/ibus-table")
|
||||
(synopsis "Table based input framework for IBus")
|
||||
(description
|
||||
"@code{ibus-table} is a framework for table based input methods using
|
||||
IBus.")
|
||||
(license lgpl2.1+)))
|
||||
|
||||
(define-public ibus-speech-to-text
|
||||
(package
|
||||
(name "ibus-speech-to-text")
|
||||
|
|
38
gnu/packages/patches/ibus-table-paths.patch
Normal file
38
gnu/packages/patches/ibus-table-paths.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
diff --git a/engine/ibus-engine-table.in b/engine/ibus-engine-table.in
|
||||
index e79d62a6cad4..675007204abd 100644
|
||||
--- a/engine/ibus-engine-table.in
|
||||
+++ b/engine/ibus-engine-table.in
|
||||
@@ -24,8 +24,6 @@ prefix=@prefix@
|
||||
exec_prefix=@prefix@
|
||||
datarootdir=@datarootdir@
|
||||
datadir=@datadir@
|
||||
-export IBUS_TABLE_LOCATION=@datarootdir@/ibus-table
|
||||
-export IBUS_TABLE_LIB_LOCATION=@libexecdir@
|
||||
|
||||
# Set this variable to something > 0 to get more debug output.
|
||||
# (Debug output may show up in the log file and/or in the lookup table):
|
||||
diff --git a/engine/ibus-table-createdb.in b/engine/ibus-table-createdb.in
|
||||
index 91eb28b7cbe5..187dddf2c952 100644
|
||||
--- a/engine/ibus-table-createdb.in
|
||||
+++ b/engine/ibus-table-createdb.in
|
||||
@@ -24,6 +24,4 @@ exec_prefix=@exec_prefix@
|
||||
bindir=@bindir@
|
||||
datarootdir=@datarootdir@
|
||||
datadir=@datadir@
|
||||
-export IBUS_TABLE_DATA_DIR=@datarootdir@
|
||||
-export IBUS_TABLE_BIN_PATH=@bindir@
|
||||
exec @PYTHON@ @datarootdir@/ibus-table/engine/tabcreatedb.py $@
|
||||
diff --git a/setup/ibus-setup-table.in b/setup/ibus-setup-table.in
|
||||
index 7f7405c37296..ae6f96921c56 100644
|
||||
--- a/setup/ibus-setup-table.in
|
||||
+++ b/setup/ibus-setup-table.in
|
||||
@@ -22,9 +22,6 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
datarootdir=@datarootdir@
|
||||
-export IBUS_PREFIX=@prefix@
|
||||
-export IBUS_DATAROOTDIR=@datarootdir@
|
||||
-export IBUS_LOCALEDIR=@localedir@
|
||||
cd @prefix@/share/ibus-table/setup/
|
||||
exec @PYTHON@ main.py $@
|
||||
|
Loading…
Reference in a new issue