gnu: aws-c-cal: Update to 0.5.12.

* gnu/packages/c.scm (aws-c-cal): Update to 0.5.12.
[arguments]: Fix CMAKE_PREFIX_PATH.
[source]: Remove patch.
* gnu/packages/patches/aws-c-cal-cmake-prefix.patch: Delete file.
* gnu/local.mk: Remove it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2021-10-18 17:33:03 +00:00 committed by Ludovic Courtès
parent 2a32dedfbf
commit 4ff5cd6b06
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 6 additions and 18 deletions

View file

@ -872,7 +872,6 @@ dist_patch_DATA = \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-auth-cmake-prefix.patch \
%D%/packages/patches/aws-c-auth-disable-networking-tests.patch\
%D%/packages/patches/aws-c-cal-cmake-prefix.patch \
%D%/packages/patches/aws-c-compression-cmake-prefix.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-cmake-prefix.patch \

View file

@ -669,7 +669,8 @@ (define-public aws-c-io
(define-public aws-c-cal
(package
(name "aws-c-cal")
(version "0.5.11")
; Update only when updating aws-crt-cpp.
(version "0.5.12")
(source (origin
(method git-fetch)
(uri (git-reference
@ -678,12 +679,13 @@ (define-public aws-c-cal
(file-name (git-file-name name version))
(sha256
(base32
"0rqqk4n56h8sf4q070rhgjwas04j8h0vq4wl1alq5l1rqq72qqdf"))
(patches (search-patches "aws-c-cal-cmake-prefix.patch"))))
"09zqf610x4g2mcjcaf9nh88k6dkw14pi721yr8hxb5rmsx7rlfrb"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
(list "-DBUILD_SHARED_LIBS=ON"
(string-append "-DCMAKE_PREFIX_PATH="
(assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
`(("aws-c-common" ,aws-c-common)))
(inputs

View file

@ -1,13 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,10 @@ endif()
option(BYO_CRYPTO "Set this if you want to provide your own cryptography implementation. This will cause the defaults to not be compiled." OFF)
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
+endif()
+
if (DEFINED CMAKE_PREFIX_PATH)
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
endif()