mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: bash-completion: Update to 2.8.
* gnu/packages/bash.scm (bash-completion): Update to 2.8. * gnu/packages/patches/bash-completion-directories.patch: Update context.
This commit is contained in:
parent
39c6af4774
commit
504be7db58
2 changed files with 7 additions and 6 deletions
|
@ -3,6 +3,7 @@
|
|||
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
|
||||
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -263,7 +264,7 @@ (define-public static-bash
|
|||
(define-public bash-completion
|
||||
(package
|
||||
(name "bash-completion")
|
||||
(version "2.7")
|
||||
(version "2.8")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -271,7 +272,7 @@ (define-public bash-completion
|
|||
version "/" name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"07j484vb3k90f4989xh1g1x99g01akrp69p3dml4lza27wnqkfj1"))
|
||||
"0kgmflrr1ga9wfk770vmakna3nj46ylb5ky9ipd0v2k9ymq5a7y0"))
|
||||
(patches
|
||||
(search-patches "bash-completion-directories.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
|
|
|
@ -8,9 +8,9 @@ directory, but also in the user's profile and in the system profile.
|
|||
This is what this patch does.
|
||||
|
||||
|
||||
--- a/bash_completion 2016-08-03 10:23:02.356782287 +0200
|
||||
+++ b/bash_completion 2016-08-03 10:27:50.120140403 +0200
|
||||
@@ -1960,7 +1960,13 @@
|
||||
--- a/bash_completion
|
||||
+++ b/bash_completion
|
||||
@@ -2016,7 +2016,13 @@ complete -F _minimal ''
|
||||
|
||||
__load_completion()
|
||||
{
|
||||
|
@ -22,6 +22,6 @@ This is what this patch does.
|
|||
+ "/run/current-system/profile/etc/bash_completion.d/$base"
|
||||
+ ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions )
|
||||
+
|
||||
local OIFS=$IFS IFS=: dir cmd="$1" compfile
|
||||
local OIFS=$IFS IFS=: dir cmd="${1##*/}" compfile
|
||||
for dir in ${XDG_DATA_DIRS:-/usr/local/share:/usr/share}; do
|
||||
dirs+=( $dir/bash-completion/completions )
|
||||
|
|
Loading…
Reference in a new issue