mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: iputils: Update to 20221126.
* gnu/packages/networking.scm (iputils): Update to 20221126. [source](patches): Remove. [arguments]: Remove obsolete phase. Disable one new test. [description]: Adjust for removed commands. * gnu/packages/patches/iputils-libcap-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
963abdf05d
commit
51939d19c1
3 changed files with 12 additions and 65 deletions
|
@ -1416,7 +1416,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/inkscape-poppler-compat.patch \
|
||||
%D%/packages/patches/instead-use-games-path.patch \
|
||||
%D%/packages/patches/intltool-perl-compatibility.patch \
|
||||
%D%/packages/patches/iputils-libcap-compat.patch \
|
||||
%D%/packages/patches/irrlicht-use-system-libs.patch \
|
||||
%D%/packages/patches/irrlicht-link-against-needed-libs.patch \
|
||||
%D%/packages/patches/isl-0.11.1-aarch64-support.patch \
|
||||
|
|
|
@ -1564,35 +1564,25 @@ (define-public ifstatus
|
|||
(define-public iputils
|
||||
(package
|
||||
(name "iputils")
|
||||
(version "20190709")
|
||||
(version "20221126")
|
||||
(home-page "https://github.com/iputils/iputils")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference (url home-page)
|
||||
(commit (string-append "s" version))))
|
||||
(uri (git-reference (url home-page) (commit version)))
|
||||
(file-name (git-file-name name version))
|
||||
(patches (search-patches "iputils-libcap-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"04bp4af15adp79ipxmiakfp0ij6hx5qam266flzbr94pr8z8l693"))))
|
||||
"1qfdvr60mlwh5kr4p27wjknz1cvrwfi6iadh9ny45661v22i0njx"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags '("-DBUILD_RARPD=true")
|
||||
#:phases
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'fix-docbook-url
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(let* ((docbook-xsl (assoc-ref inputs "docbook-xsl"))
|
||||
(uri (string-append docbook-xsl "/xml/xsl/docbook-xsl-"
|
||||
,(package-version docbook-xsl))))
|
||||
(for-each
|
||||
(lambda (file)
|
||||
(substitute* file
|
||||
(("http://docbook\\.sourceforge\\.net/release/xsl-ns/current")
|
||||
uri)))
|
||||
(cons "doc/meson.build"
|
||||
(find-files "doc" "\\.xsl$")))
|
||||
#t))))))
|
||||
(add-after 'unpack 'disable-ping-test
|
||||
(lambda _
|
||||
;; Disable ping test, as it requires root or raw socket capabilities.
|
||||
(substitute* "test/meson.build"
|
||||
(("if build_ping == true")
|
||||
"if false")))))))
|
||||
(native-inputs
|
||||
`(("gettext" ,gettext-minimal)
|
||||
("pkg-config" ,pkg-config)
|
||||
|
@ -1611,20 +1601,15 @@ (define-public iputils
|
|||
@item @command{arping}: Ping hosts using the @dfn{Address Resolution Protocol}.
|
||||
@item @command{clockdiff}: Compute time difference between network hosts
|
||||
using ICMP TSTAMP messages.
|
||||
@item @command{ninfod}: Daemon that responds to IPv6 Node Information Queries.
|
||||
@item @command{ping}: Use ICMP ECHO messages to measure round-trip delays
|
||||
and packet loss across network paths.
|
||||
@item @command{rarpd}: Answer RARP requests from clients.
|
||||
@item @command{rdisc}: Populate network routing tables with information from
|
||||
the ICMP router discovery protocol.
|
||||
@item @command{tftpd}: Trivial file transfer protocol server.
|
||||
@item @command{tracepath}: Trace network path to an IPv4 or IPv6 address and
|
||||
discover MTU along the way.
|
||||
@end itemize")
|
||||
;; The various utilities are covered by different licenses, see LICENSE
|
||||
;; for details.
|
||||
(license (list license:gpl2+ ;arping, rarpd, tracepath
|
||||
license:bsd-3 ;clockdiff, ninfod, ping, tftpd
|
||||
(license (list license:gpl2+ ;arping, tracepath
|
||||
license:bsd-3 ;clockdiff, ping
|
||||
(license:non-copyleft
|
||||
"https://spdx.org/licenses/Rdisc.html"
|
||||
"Sun Microsystems license, see rdisc.c for details")))))
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
Fix name clash with libcap 2.29.
|
||||
|
||||
Taken from upstream:
|
||||
https://github.com/iputils/iputils/commit/18f9a84e0e702841d6cc4d5f593de4fbd1348e83
|
||||
|
||||
diff --git a/ninfod/ninfod.c b/ninfod/ninfod.c
|
||||
--- a/ninfod/ninfod.c
|
||||
+++ b/ninfod/ninfod.c
|
||||
@@ -455,7 +455,7 @@ static void do_daemonize(void)
|
||||
/* --------- */
|
||||
#ifdef HAVE_LIBCAP
|
||||
static const cap_value_t cap_net_raw = CAP_NET_RAW;
|
||||
-static const cap_value_t cap_setuid = CAP_SETUID;
|
||||
+static const cap_value_t cap_setuserid = CAP_SETUID;
|
||||
static cap_flag_value_t cap_ok;
|
||||
#else
|
||||
static uid_t euid;
|
||||
@@ -487,7 +487,7 @@ static void limit_capabilities(void)
|
||||
|
||||
cap_get_flag(cap_cur_p, CAP_SETUID, CAP_PERMITTED, &cap_ok);
|
||||
if (cap_ok != CAP_CLEAR)
|
||||
- cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuid, CAP_SET);
|
||||
+ cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuserid, CAP_SET);
|
||||
|
||||
if (cap_set_proc(cap_p) < 0) {
|
||||
DEBUG(LOG_ERR, "cap_set_proc: %s\n", strerror(errno));
|
||||
@@ -520,8 +520,8 @@ static void drop_capabilities(void)
|
||||
|
||||
/* setuid / setuid */
|
||||
if (cap_ok != CAP_CLEAR) {
|
||||
- cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuid, CAP_SET);
|
||||
- cap_set_flag(cap_p, CAP_EFFECTIVE, 1, &cap_setuid, CAP_SET);
|
||||
+ cap_set_flag(cap_p, CAP_PERMITTED, 1, &cap_setuserid, CAP_SET);
|
||||
+ cap_set_flag(cap_p, CAP_EFFECTIVE, 1, &cap_setuserid, CAP_SET);
|
||||
|
||||
if (cap_set_proc(cap_p) < 0) {
|
||||
DEBUG(LOG_ERR, "cap_set_proc: %s\n", strerror(errno));
|
Loading…
Reference in a new issue