mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: python-uqbar: Update to 0.5.9.
* gnu/packages/graphviz.scm (python-uqbar): Update to 0.5.9. [source]: Add patch for Python 3.10 compatibility. [arguments]: Remove outdated patch phase. Change-Id: I81d83efd69bd07fe12790981c48a6e82297908f0 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
4cafd86f77
commit
51d25c771c
3 changed files with 27 additions and 9 deletions
|
@ -1782,6 +1782,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-sphinx-prompt-docutils-0.19.patch \
|
||||
%D%/packages/patches/python-telingo-fix-comparison.patch \
|
||||
%D%/packages/patches/python-typeguard-python3.10.patch \
|
||||
%D%/packages/patches/python-uqbar-python3.10.patch \
|
||||
%D%/packages/patches/python-wxwidgets-type-errors.patch \
|
||||
%D%/packages/patches/qtdeclarative-5-disable-qmlcache.patch \
|
||||
%D%/packages/patches/qtdeclarative-disable-qmlcache.patch \
|
||||
|
|
|
@ -195,7 +195,7 @@ (define-public python-pygraphviz
|
|||
(define-public python-uqbar
|
||||
(package
|
||||
(name "python-uqbar")
|
||||
(version "0.5.6")
|
||||
(version "0.5.9")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -205,18 +205,12 @@ (define-public python-uqbar
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1ml3x2mf7nlnvrh9lari5yk0sz2mmg39jwsbjxnpzhnw4kcwpdrs"))))
|
||||
"0c573nzpm51qgz2g296f8pw8ys0i3r6daynxk06zagk5l5fgw9ar"))
|
||||
(patches (search-patches "python-uqbar-python3.10.patch"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'patch
|
||||
(lambda _
|
||||
(substitute* "setup.py"
|
||||
;; Latest versions of sphink-rtd-theme require npm to build.
|
||||
(("sphinx-rtd-theme >= 0.5.0") "sphinx-rtd-theme >= 0.2.4")
|
||||
(("black") "black >= 19.10b0"))
|
||||
#t))
|
||||
(replace 'check
|
||||
(lambda* (#:key tests? #:allow-other-keys)
|
||||
(when tests?
|
||||
|
|
23
gnu/packages/patches/python-uqbar-python3.10.patch
Normal file
23
gnu/packages/patches/python-uqbar-python3.10.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
Since Python 3.10 the output of a CLI program created with argparse
|
||||
uses "options" instead of "optional arguments". This behaviour breaks
|
||||
the tests in python-uqbar.
|
||||
|
||||
--- a/tests/test_cli.py
|
||||
+++ b/tests/test_cli.py
|
||||
@@ -84,7 +84,7 @@ def test_call_help():
|
||||
|
||||
speak like a cat
|
||||
|
||||
- optional arguments:
|
||||
+ options:
|
||||
-h, --help show this help message and exit
|
||||
--version show program's version number and exit
|
||||
--loud be adamant
|
||||
@@ -101,6 +101,6 @@ def test_help():
|
||||
"""
|
||||
usage: vox-aggregator [-h] [--version] {help,list,birds,mammals} ...
|
||||
|
||||
- optional arguments:
|
||||
+ options:
|
||||
-h, --help show this help message and exit
|
||||
--version show program's version number and exit
|
Loading…
Reference in a new issue