mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: kmod: Honor $LINUX_MODULE_DIRECTORY.
* gnu/packages/patches/kmod-module-directory.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/linux.scm (kmod)[origin]: Use it.
This commit is contained in:
parent
d7d42d6b24
commit
528b6a3dce
3 changed files with 34 additions and 1 deletions
|
@ -318,6 +318,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/icu4c-test-date-format.patch \
|
||||
gnu/packages/patches/inkscape-stray-comma.patch \
|
||||
gnu/packages/patches/kmod-module-directory.patch \
|
||||
gnu/packages/patches/libevent-dns-tests.patch \
|
||||
gnu/packages/patches/libffi-mips-n32-fix.patch \
|
||||
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \
|
||||
|
|
|
@ -1204,7 +1204,8 @@ (define-public kmod
|
|||
"kmod-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1yid3a9b64a60ybj66fk2ysrq5klnl0ijl4g624cl16y8404g9rv"))))
|
||||
"1yid3a9b64a60ybj66fk2ysrq5klnl0ijl4g624cl16y8404g9rv"))
|
||||
(patches (list (search-patch "kmod-module-directory.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)))
|
||||
|
|
31
gnu/packages/patches/kmod-module-directory.patch
Normal file
31
gnu/packages/patches/kmod-module-directory.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
This patch changes libkmod so it honors the 'LINUX_MODULE_DIRECTORY'
|
||||
environment variable, rather than looking for modules exclusively in
|
||||
/lib/modules.
|
||||
|
||||
Patch by Shea Levy, from Nixpkgs; adjusted to use 'LINUX_MODULE_DIRECTORY'
|
||||
rather than 'MODULE_DIR' as the variable name.
|
||||
|
||||
|
||||
--- kmod-7/libkmod/libkmod.c 2012-03-15 08:19:16.750010226 -0400
|
||||
+++ kmod-7/libkmod/libkmod.c 2012-04-04 15:21:29.532074313 -0400
|
||||
@@ -200,7 +200,7 @@
|
||||
static char *get_kernel_release(const char *dirname)
|
||||
{
|
||||
struct utsname u;
|
||||
- char *p;
|
||||
+ char *p, *dirname_prefix;
|
||||
|
||||
if (dirname != NULL)
|
||||
return path_make_absolute_cwd(dirname);
|
||||
@@ -208,7 +208,10 @@
|
||||
if (uname(&u) < 0)
|
||||
return NULL;
|
||||
|
||||
- if (asprintf(&p, "%s/%s", dirname_default_prefix, u.release) < 0)
|
||||
+ if ((dirname_prefix = getenv("LINUX_MODULE_DIRECTORY")) == NULL)
|
||||
+ dirname_prefix = dirname_default_prefix;
|
||||
+
|
||||
+ if (asprintf(&p, "%s/%s", dirname_prefix, u.release) < 0)
|
||||
return NULL;
|
||||
|
||||
return p;
|
Loading…
Reference in a new issue