mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: fifengine: Fix build.
* gnu/packages/patches/fifengine-boost-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/games.scm (fifengine)[source](patches): Add it. [arguments]: Remove defunct Python module import.
This commit is contained in:
parent
9d9c7d2202
commit
52d945d382
3 changed files with 21 additions and 9 deletions
|
@ -1046,6 +1046,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fasthenry-spSolve.patch \
|
||||
%D%/packages/patches/fasthenry-spFactor.patch \
|
||||
%D%/packages/patches/fbreader-curl-7.62.patch \
|
||||
%D%/packages/patches/fifengine-boost-compat.patch \
|
||||
%D%/packages/patches/fifengine-swig-compat.patch \
|
||||
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
||||
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
|
||||
|
|
|
@ -3726,19 +3726,14 @@ (define-public fifengine
|
|||
(uri (string-append "https://codeload.github.com/fifengine/"
|
||||
"fifengine/tar.gz/" version))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(patches (search-patches "fifengine-swig-compat.patch"))
|
||||
(patches (search-patches "fifengine-swig-compat.patch"
|
||||
"fifengine-boost-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1y4grw25cq5iqlg05rnbyxw1njl11ypidnlsm3qy4sm3xxdvb0p8"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f ; TODO The test running fails to run some tests.
|
||||
#:imported-modules ,(cons '(guix build python-build-system)
|
||||
%cmake-build-system-modules)
|
||||
#:modules ((guix build cmake-build-system)
|
||||
((guix build python-build-system) #:select (guix-pythonpath))
|
||||
(guix build utils)
|
||||
(srfi srfi-1))
|
||||
#:configure-flags
|
||||
(list
|
||||
(string-append "-DOPENALSOFT_INCLUDE_DIR="
|
||||
|
@ -3764,9 +3759,8 @@ (define-public fifengine
|
|||
;; python modules.
|
||||
(delete 'check)
|
||||
(add-after 'install 'check
|
||||
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
|
||||
(lambda* (#:key tests? #:allow-other-keys)
|
||||
(when tests?
|
||||
(add-installed-pythonpath inputs outputs)
|
||||
;; The tests require an X server.
|
||||
(system "Xvfb :1 &")
|
||||
(setenv "DISPLAY" ":1")
|
||||
|
|
17
gnu/packages/patches/fifengine-boost-compat.patch
Normal file
17
gnu/packages/patches/fifengine-boost-compat.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Fix build with newer Boost.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://github.com/fifengine/fifengine/commit/8072f18a9bf4e75c3e1b197b6ccda11e82954460
|
||||
|
||||
diff --git a/engine/core/vfs/zip/zipnode.cpp b/engine/core/vfs/zip/zipnode.cpp
|
||||
--- a/engine/core/vfs/zip/zipnode.cpp
|
||||
+++ b/engine/core/vfs/zip/zipnode.cpp
|
||||
@@ -28,6 +28,7 @@
|
||||
#include "vfs/fife_boost_filesystem.h"
|
||||
|
||||
#include "zipnode.h"
|
||||
+#include <algorithm>
|
||||
|
||||
namespace {
|
||||
/** helper function to find a value in a ZipNodeContainer
|
Loading…
Reference in a new issue