gnu: spdlog: Update to 1.13.0.

* gnu/packages/logging.scm (spdlog): Update to 1.13.0.
[source]: Remove upstreamed patch.
* gnu/local.mk: Unregister it.
* gnu/packages/patches/spdlog-fix-tests.patch: Delete file.

Change-Id: I78b5021b9841d16f43a283eaee931b4f92746ab8
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2024-01-17 17:03:58 +00:00 committed by Ludovic Courtès
parent 28434e496c
commit 5618fd5d6f
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 2 additions and 30 deletions

View file

@ -2045,7 +2045,6 @@ dist_patch_DATA = \
%D%/packages/patches/source-highlight-gcc-compat.patch \
%D%/packages/patches/softhsm-fix-openssl3-tests.patch \
%D%/packages/patches/spectre-meltdown-checker-externalize-fwdb.patch \
%D%/packages/patches/spdlog-fix-tests.patch \
%D%/packages/patches/sphinxbase-fix-doxygen.patch \
%D%/packages/patches/sssd-system-directories.patch \
%D%/packages/patches/steghide-fixes.patch \

View file

@ -213,7 +213,7 @@ (define-public multitail
(define-public spdlog
(package
(name "spdlog")
(version "1.12.0")
(version "1.13.0")
(source
(origin
(method git-fetch)
@ -221,9 +221,8 @@ (define-public spdlog
(url "https://github.com/gabime/spdlog")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(patches (search-patches "spdlog-fix-tests.patch"))
(sha256
(base32 "0yyncv6wjs5rqm76rkqyxpfbsingk1dq5zfcqhy1a7fpw8xdl53k"))))
(base32 "0zgdmdgnp2y36jrlk85d4fiyjkjd6anly8pambyc3f3v6sg02zyy"))))
(build-system cmake-build-system)
;; TODO run benchmark. Currently not possible, as adding
;; (gnu packages benchmark) forms a dependency cycle

View file

@ -1,26 +0,0 @@
Remove after next release and package update:
https://github.com/gabime/spdlog/commit/2ee8bac78e6525a8ad9a9196e65d502ce390d83a
From 2ee8bac78e6525a8ad9a9196e65d502ce390d83a Mon Sep 17 00:00:00 2001
From: xvitaly <vitaly@easycoding.org>
Date: Sun, 23 Jul 2023 10:15:25 +0200
Subject: [PATCH] Added missing square bracket to fix the level_to_string_view
test. (#2827)
---
tests/test_misc.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/test_misc.cpp b/tests/test_misc.cpp
index 9f3cb1744..6199641ff 100644
--- a/tests/test_misc.cpp
+++ b/tests/test_misc.cpp
@@ -43,7 +43,7 @@ TEST_CASE("log_levels", "[log_levels]")
REQUIRE(log_info("Hello", spdlog::level::trace) == "Hello");
}
-TEST_CASE("level_to_string_view", "[convert_to_string_view")
+TEST_CASE("level_to_string_view", "[convert_to_string_view]")
{
REQUIRE(spdlog::level::to_string_view(spdlog::level::trace) == "trace");
REQUIRE(spdlog::level::to_string_view(spdlog::level::debug) == "debug");