mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 20:49:29 -05:00
gnu: diffutils: Update to 3.10.
* gnu/packages/base.scm (diffutils): Update to 3.10. * gnu/packages/patches/diffutils-fix-signal-processing.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I795fa93938f8723090887d33574baa1a392ef42e
This commit is contained in:
parent
5f238e3e36
commit
563538a4e2
3 changed files with 2 additions and 62 deletions
|
@ -1122,7 +1122,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/debops-debops-defaults-fall-back-to-less.patch \
|
||||
%D%/packages/patches/dee-vapi.patch \
|
||||
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
|
||||
%D%/packages/patches/diffutils-fix-signal-processing.patch \
|
||||
%D%/packages/patches/directfb-davinci-glibc-228-compat.patch \
|
||||
%D%/packages/patches/dkimproxy-add-ipv6-support.patch \
|
||||
%D%/packages/patches/docbook-utils-documentation-edits.patch \
|
||||
|
|
|
@ -347,15 +347,14 @@ (define-public patch
|
|||
(define-public diffutils
|
||||
(package
|
||||
(name "diffutils")
|
||||
(version "3.8")
|
||||
(version "3.10")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/diffutils/diffutils-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1v4g8gi0lgakqa7iix8s4fq7lq6l92vw3rjd9wfd2rhjng8xggd6"))
|
||||
(patches (search-patches "diffutils-fix-signal-processing.patch"))))
|
||||
"17nhkdn5a2z6pwcmjs4jas2plg066hbdz06y5vhypr14qwyfkrch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
(list
|
||||
|
|
|
@ -1,58 +0,0 @@
|
|||
Author: Frédéric Bonnard <frediz@debian.org>
|
||||
|
||||
Obtained from:
|
||||
|
||||
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922552#19
|
||||
|
||||
Fixes bug reported upstream at:
|
||||
|
||||
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34519
|
||||
|
||||
diff --git a/src/diff.c b/src/diff.c
|
||||
index e2eb32437353..b574e8282dc9 100644
|
||||
--- a/src/diff.c
|
||||
+++ b/src/diff.c
|
||||
@@ -1451,6 +1451,8 @@ compare_files (struct comparison const *parent,
|
||||
}
|
||||
}
|
||||
|
||||
+ final_process_signals ();
|
||||
+
|
||||
/* Now the comparison has been done, if no error prevented it,
|
||||
and STATUS is the value this function will return. */
|
||||
|
||||
diff --git a/src/diff.h b/src/diff.h
|
||||
index 03daaa4a0530..e177fe600a25 100644
|
||||
--- a/src/diff.h
|
||||
+++ b/src/diff.h
|
||||
@@ -390,6 +390,7 @@ extern enum changes analyze_hunk (struct change *, lin *, lin *, lin *, lin *);
|
||||
extern void begin_output (void);
|
||||
extern void debug_script (struct change *);
|
||||
extern void fatal (char const *) __attribute__((noreturn));
|
||||
+extern void final_process_signals (void);
|
||||
extern void finish_output (void);
|
||||
extern void message (char const *, char const *, char const *);
|
||||
extern void message5 (char const *, char const *, char const *,
|
||||
diff --git a/src/util.c b/src/util.c
|
||||
index 4f4d9bb285eb..56d292de2927 100644
|
||||
--- a/src/util.c
|
||||
+++ b/src/util.c
|
||||
@@ -237,6 +237,18 @@ process_signals (void)
|
||||
}
|
||||
}
|
||||
|
||||
+/* Process remaining signals once before exit */
|
||||
+void
|
||||
+final_process_signals (void)
|
||||
+{
|
||||
+ static int last = 1;
|
||||
+
|
||||
+ if (last) {
|
||||
+ process_signals ();
|
||||
+ last = 0;
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
static void
|
||||
install_signal_handlers (void)
|
||||
{
|
Loading…
Reference in a new issue