gnu: KDE Frameworks: Update all packages to 5.92.0

*  gnu/packages/kde-frameworks.scm

(extra-cmake-modules, attica, bluez-qt, breeze-icons, kapidox, karchive,
kcalendarcore, kcodecs, kconfig, kcoreaddons, kdbusaddons, kdnssd,
kguiaddons, kholidays, ki18n, kidletime, kirigami, kitemmodels,
kitemviews, kplotting, ksyntaxhighlighting, kwayland, kwidgetsaddons,
kwindowsystem, modemmanager-qt, networkmanager-qt, oxygen-icons, prison,
qqc2-desktop-style, solid, sonnet, threadweaver, kactivities, kauth,
kcompletion, kcontacts, kcrash, kdoctools, kfilemetadata, kimageformats,
kjobwidgets, knotifications, kpackage, kpty, kunitconversion, syndication,
baloo, kactivities-stats, kbookmarks, kcmutils, kconfigwidgets,
kdeclarative, kded, kdesignerplugin, kdesu, kdewebkit, kemoticons,
kglobalaccel, kiconthemes, kinit, kio, knewstuff, knotifyconfig, kparts,
kpeople, krunner, kservice, ktexteditor, ktextwidgets, kwallet, kxmlgui,
kxmlrpcclient, plasma-framework, purpose, kde-frameworkintegration,
kdelibs4support, khtml, kjs, kjsembed, kmediaplayer, kross, kdav):
Update to 5.92.0.

(extra-cmake-modules)[arguments]:
Disable failing test.
Don't run check phase after install.

(bluez): [arguments]: Enable tests.

(breeze-icons): [native-inputs]: Remove uneeded dependency libxml2, Add python-lxml, python.

(kapidox): Use python-build-system.  [native-inputs]: Remove extraneous
input.

kcalendarcore: [arguments]: Enable as many tests as possible.

(kconfig): [native-inputs]: Remove no longer needed inputs.
[arguments]: Disable failing test.

(kcoreaddons): [arguments]: Remove old hack, disable broken tests.

(ki18n): [arguments]: Disable failing tests.

(kguiaddons): [inputs]: Add new dependencies qtwayland, wayland.

(kwidgetsaddons): [arguments]: Disable another failing test.

(kwayland): [inputs]: Add plasma-wayland-protocols.
[arguments]: Enable working tests.

(knotifications): [native-inputs]: add libcanberra, libdbusmenu-qt,
qtdeclarative-5.
[arguments]: Respect tests?

(sonnet): [inputs]: Add qtdeclarative-5.

(kxmlgui): [inputs]: Add kguiaddons.

(kxmlrpcclient): [source]: Update url.

(plasma-framework): [arguments]: Enable all tests that work.
[native-inputs]: Add kdoctools.

(kpackage): [arguments]: Use substitution instead of patch.

(kio): [inputs]: Add new dependencies.
[native-inputs]: Add kdoctools.
[arguments]: Enable all tests that work.

(kdeclarative): [inputs]: Remove extraenous inputs.
[propagated-inputs]: Propagate qtdeclarative, since it always seems to
be needed.
[native-inputs]: Add dbus to skip failing test.
[arguments]: Replace check due to failing test.

(solid): [arguments]: Respect tests?.

(kdbusaddons): [arguments]: Respect tests?.
Fix patch by replacing it with a substitution instead.

(kholidays): [arguments]: Enable working test.

(ksyntaxhighlighting): [arguments]: Don't patch file that doesn't exist any more.

(kwindowsystem): [arguments]: Respect tests?.

(modemmanager-qt): [arguments]: Respect tests?.

(kauth): [arguments]: Respect tests?.

(kfilemetadata): [arguments]: A different test fails now.

(kunitconversion): [arguments]: Disable tests.

(baloo): [arguments]: Enable tests. Respect tests?.

(kconfigwidgets): Move qttools to native-inputs.

(kded): [inputs]: Remove unneeded kinit input.
[native-inputs]: Add kdoctools.

(kdesignerplugin): [inputs]: Remove extraneous inputs.
[native-inputs]: Add kdoctools.

(kglobalaccel): [inputs]: Remove extraneous inputs.

(kinit): [native-inputs]: Add kdoctools.

(knewstuff): [inputs]: Add kpackage.

(krunner): [arguments]: Disable failing tests.

(kservice): [arguments]: Enable all tests that work.
[native-inputs]: Add kdoctools.

(ktexteditor): [arguments]: Enable all tests that work.

(kwallet): [native-inputs]: Add kdoctools.

(purpose): [arguments]: Remove unneeded hack.

(kdelibs4support): Move qttools to native-inputs.
[native-inputs]: Add kdoctools.

(kcontacts): [inputs]: Add iso-codes since the tests look for some .json
files from it.
[arguments]: Disable failing tests.

(networkmanager-qt): [arguments]: Respect tests?.

* gnu/local.mk: Delete references to deleted patches:
kdbusaddons-kinit-file-name.patch
kinit-kdeinit-libpath.patch
kpackage-allow-external-paths.patch
kpackage-fix-KF5PackageMacros.cmake.patch
plasma-framework-fix-KF5PlasmaMacros.cmake.patch

* gnu/packages/patches/kdbusaddons-kinit-file-name.patch: Delete file.
* gnu/packages/patches/kinit-kdeinit-libpath.patch: Delete file.
* gnu/packages/patches/kpackage-allow-external-paths.patch: Delete file.
* gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch: Delete
file.
* gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch:
Delete file.

* gnu/packages/patches/kinit-kdeinit-extra_libs.patch: Fix patch.

Signed-off-by: Marius Bakke <marius@gnu.org>
This commit is contained in:
Brendan Tildesley 2022-02-01 18:34:57 +11:00 committed by Marius Bakke
parent c4ce54055a
commit 575a03ab39
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
9 changed files with 455 additions and 607 deletions

View file

@ -1354,7 +1354,6 @@ dist_patch_DATA = \
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
%D%/packages/patches/julia-tracker-16-compat.patch \
%D%/packages/patches/julia-allow-parallel-build.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
%D%/packages/patches/libffi-3.3-powerpc-fixes.patch \
%D%/packages/patches/libffi-float128-powerpc64le.patch \
%D%/packages/patches/libobjc2-unbundle-robin-map.patch \
@ -1371,14 +1370,11 @@ dist_patch_DATA = \
%D%/packages/patches/kiki-missing-includes.patch \
%D%/packages/patches/kiki-portability-64bit.patch \
%D%/packages/patches/kinit-kdeinit-extra_libs.patch \
%D%/packages/patches/kinit-kdeinit-libpath.patch \
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
%D%/packages/patches/kismet-unbundle-boost.patch \
%D%/packages/patches/kmail-Fix-missing-link-libraries.patch \
%D%/packages/patches/kmod-module-directory.patch \
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
%D%/packages/patches/kpackage-allow-external-paths.patch \
%D%/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch \
%D%/packages/patches/kmplayer-aarch64.patch \
%D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch \
%D%/packages/patches/kobodeluxe-paths.patch \
@ -1609,7 +1605,6 @@ dist_patch_DATA = \
%D%/packages/patches/pciutils-hurd-configure.patch \
%D%/packages/patches/pciutils-hurd-fix.patch \
%D%/packages/patches/pjproject-install-libpjsua2.patch \
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
%D%/packages/patches/pokerth-boost.patch \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
%D%/packages/patches/pthreadpool-system-libraries.patch \

File diff suppressed because it is too large Load diff

View file

@ -1,15 +0,0 @@
Add placeholder for kinit's store file name.
diff --git a/src/kdeinitinterface.cpp b/src/kdeinitinterface.cpp
index 22fa5e5..3d40937 100644
--- a/src/kdeinitinterface.cpp
+++ b/src/kdeinitinterface.cpp
@@ -52,7 +52,7 @@ void KDEInitInterface::ensureKdeinitRunning()
// If not found in system paths, search other paths
if (srv.isEmpty()) {
const QStringList searchPaths = QStringList()
- << QCoreApplication::applicationDirPath() // then look where our application binary is located
+ << QString::fromUtf8("@SUBSTITUTEME@/bin") // using QStringLiteral would be more efficient, but breaks guix store reference detection.
<< QLibraryInfo::location(QLibraryInfo::BinariesPath); // look where exec path is (can be set in qt.conf)
srv = QStandardPaths::findExecutable(QStringLiteral("kdeinit5"), searchPaths);
if (srv.isEmpty()) {

View file

@ -21,27 +21,6 @@ pkgs/development/libraries/kde-frameworks/kinit/kdeinit-extra_libs.patch
#endif
};
#endif
@@ -1533,20 +1531,6 @@ static int initXconnection()
}
#endif
-#ifndef Q_OS_OSX
-// Find a shared lib in the lib dir, e.g. libkio.so.
-// Completely unrelated to plugins.
-static QString findSharedLib(const QString &lib)
-{
- QString path = QFile::decodeName(CMAKE_INSTALL_PREFIX "/" LIB_INSTALL_DIR "/") + lib;
- if (QFile::exists(path)) {
- return path;
- }
- // We could also look in LD_LIBRARY_PATH, but really, who installs the main libs in different prefixes?
- return QString();
-}
-#endif
-
extern "C" {
static void secondary_child_handler(int)
@@ -1673,7 +1673,7 @@
#if defined(Q_OS_UNIX) && !defined(Q_OS_OSX)
if (!d.suicide && qEnvironmentVariableIsEmpty("KDE_IS_PRELINKED")) {

View file

@ -1,37 +0,0 @@
Search libraries in GUIX_KF5INIT_LIB_PATH.
Based on an idea by NixOs
pkgs/development/libraries/kde-frameworks/kinit/kinit-libpath.patch
===================================================================
--- kinit-5.32.0/src/kdeinit/kinit.cpp.orig 2017-10-22 21:02:20.908765455 +0200
+++ kinit-5.32.0/src/kdeinit/kinit.cpp 2017-10-22 21:03:25.312818248 +0200
@@ -623,20 +623,18 @@
if (libpath_relative) {
// NB: Because Qt makes the actual dlopen() call, the
// RUNPATH of kdeinit is *not* respected - see
// https://sourceware.org/bugzilla/show_bug.cgi?id=13945
// - so we try hacking it in ourselves
- QString install_lib_dir = QFile::decodeName(
- CMAKE_INSTALL_PREFIX "/" LIB_INSTALL_DIR "/");
- QString orig_libpath = libpath;
- libpath = install_lib_dir + libpath;
- l.setFileName(libpath);
- if (!l.load()) {
- libpath = orig_libpath;
- l.setFileName(libpath);
- l.load();
- }
+ // Try to load the library relative to the active profiles.
+ QByteArrayList profiles = qgetenv("KDEINIT5_LIBRARY_PATH").split(':');
+ for (const QByteArray &profile: profiles) {
+ if (!profile.isEmpty()) {
+ l.setFileName(QFile::decodeName(profile) + QStringLiteral("/") + libpath);
+ if (l.load()) break;
+ }
+ }
} else {
l.load();
}
if (!l.isLoaded()) {
QString ltdlError(l.errorString());

View file

@ -1,30 +1,24 @@
Adopted from NixOS
pkgs/development/libraries/kde-frameworks/kio/samba-search-path.patch
From af54a2a37655df26a33bc6783cb472c38f65322f Mon Sep 17 00:00:00 2001
From: Thomas Tuegel <ttuegel@mailbox.org>
Date: Sun, 28 Mar 2021 10:31:12 -0500
Subject: [PATCH 1/2] Remove impure smbd search path
===================================================================
--- kio-5.17.0.orig/src/core/ksambashare.cpp
+++ kio-5.17.0/src/core/ksambashare.cpp
@@ -67,13 +67,18 @@ KSambaSharePrivate::~KSambaSharePrivate(
---
src/core/ksambashare.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/core/ksambashare.cpp b/src/core/ksambashare.cpp
index e810ce4..7cfb4e6 100644
--- a/src/core/ksambashare.cpp
+++ b/src/core/ksambashare.cpp
@@ -61,7 +61,7 @@ KSambaSharePrivate::~KSambaSharePrivate()
bool KSambaSharePrivate::isSambaInstalled()
{
- if (QFile::exists(QStringLiteral("/usr/sbin/smbd"))
- || QFile::exists(QStringLiteral("/usr/local/sbin/smbd"))) {
- return true;
+ const QByteArray pathEnv = qgetenv("PATH");
+ if (!pathEnv.isEmpty()) {
+ QLatin1Char pathSep(':');
+ QStringList paths = QFile::decodeName(pathEnv).split(pathSep, QString::SkipEmptyParts);
+ for (QStringList::iterator it = paths.begin(); it != paths.end(); ++it) {
+ it->append(QStringLiteral("/smbd"));
+ if (QFile::exists(*it)) {
+ return true;
+ }
+ }
const bool daemonExists =
- !QStandardPaths::findExecutable(QStringLiteral("smbd"), {QStringLiteral("/usr/sbin/"), QStringLiteral("/usr/local/sbin/")}).isEmpty();
+ !QStandardPaths::findExecutable(QStringLiteral("smbd")).isEmpty();
if (!daemonExists) {
qCDebug(KIO_CORE_SAMBASHARE) << "KSambaShare: Could not find smbd";
}
- //qDebug() << "Samba is not installed!";
-
return false;
}
--
2.30.1

View file

@ -1,13 +0,0 @@
diff --git a/src/kpackage/package.cpp b/src/kpackage/package.cpp
index 5aec9fd..b15c933 100644
--- a/src/kpackage/package.cpp
+++ b/src/kpackage/package.cpp
@@ -820,7 +820,7 @@ PackagePrivate::PackagePrivate()
: QSharedData(),
fallbackPackage(nullptr),
metadata(nullptr),
- externalPaths(false),
+ externalPaths(true),
valid(false),
checkedValid(false)
{

View file

@ -1,25 +0,0 @@
From 668010ebc9fd84d9dc60f90b9a4ebf3c7054977f Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Sun, 25 Oct 2020 20:11:13 +0000
Subject: [PATCH] Fix build errors if PREFIX is different from ECM's PREFIX.
See <https://bugs.kde.org/424483> for details.
---
KF5PackageMacros.cmake | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/KF5PackageMacros.cmake b/KF5PackageMacros.cmake
index f4c1d1d..acd3798 100644
--- a/KF5PackageMacros.cmake
+++ b/KF5PackageMacros.cmake
@@ -1,6 +1,5 @@
-find_package(ECM 1.6.0 CONFIG REQUIRED)
-include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
+include(KDEInstallDirs)
set(KPACKAGE_RELATIVE_DATA_INSTALL_DIR "kpackage")
--
GitLab

View file

@ -1,25 +0,0 @@
From ff5ed26f21d304e867ab57781878069567deb23d Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Mon, 3 Aug 2020 19:49:58 +0000
Subject: [PATCH] Fix build errors if PREFIX is different from ECM's PREFIX.
See <https://bugs.kde.org/424483> for details
---
KF5PlasmaMacros.cmake | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/KF5PlasmaMacros.cmake b/KF5PlasmaMacros.cmake
index 494b42d56..80b3fd8dd 100644
--- a/KF5PlasmaMacros.cmake
+++ b/KF5PlasmaMacros.cmake
@@ -1,6 +1,5 @@
-find_package(ECM 1.6.0 CONFIG REQUIRED)
-include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
+include(KDEInstallDirs)
set(PLASMA_RELATIVE_DATA_INSTALL_DIR "plasma")
set(PLASMA_DATA_INSTALL_DIR "${KDE_INSTALL_DATADIR}/${PLASMA_RELATIVE_DATA_INSTALL_DIR}")
--
GitLab