mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 13:58:15 -05:00
gnu: Update hash-extender.
* gnu/packages/crypto.scm (hash-extender): Update to newer commit. * gnu/packages/patches/hash-extender-test-suite.patch: The patch was merged upstream, no need to apply it anymore. * gnu/local.mk (dist_patch_DATA): Unregister the patch file.
This commit is contained in:
parent
1a4baf5119
commit
57c3b71cbe
3 changed files with 4 additions and 20 deletions
|
@ -1006,7 +1006,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gtksourceview-2-add-default-directory.patch \
|
||||
%D%/packages/patches/gzdoom-search-in-installed-share.patch \
|
||||
%D%/packages/patches/gzdoom-find-system-libgme.patch \
|
||||
%D%/packages/patches/hash-extender-test-suite.patch \
|
||||
%D%/packages/patches/haskell-mode-unused-variables.patch \
|
||||
%D%/packages/patches/haskell-mode-make-check.patch \
|
||||
%D%/packages/patches/hdf4-architectures.patch \
|
||||
|
|
|
@ -1075,8 +1075,8 @@ (define-public libolm
|
|||
(license license:asl2.0)))
|
||||
|
||||
(define-public hash-extender
|
||||
(let ((commit "9ecef26809a1ceea2a455f6f591b004298df551b")
|
||||
(revision "1"))
|
||||
(let ((commit "cb8aaee49f93e9c0d2f03eb3cafb429c9eed723d")
|
||||
(revision "2"))
|
||||
(package
|
||||
(name "hash-extender")
|
||||
(version (git-version "0.0" revision commit))
|
||||
|
@ -1087,10 +1087,8 @@ (define-public hash-extender
|
|||
(commit commit)))
|
||||
(sha256
|
||||
(base32
|
||||
"0fqy3d559zgf71w39py0931d8na0ylils45r8zs6r79wgr6qn78c"))
|
||||
(file-name (git-file-name name version))
|
||||
(patches
|
||||
(search-patches "hash-extender-test-suite.patch"))))
|
||||
"1fj118566hr1wv03az2w0iqknazsqqkak0mvlcvwpgr6midjqi9b"))
|
||||
(file-name (git-file-name name version))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Make the test suite exit with a non-zero exit code if some tests failed.
|
||||
Pull request pending upstream: https://github.com/iagox86/hash_extender/pull/13
|
||||
--- a/test.c
|
||||
+++ b/test.c
|
||||
@@ -79,5 +79,9 @@ void test_report(void)
|
||||
printf("TESTS PASSED: %d / %d [%2.4f%%]\n", tests_passed, tests_run, 100 * (float)tests_passed / tests_run);
|
||||
printf("--------------------------------------------------------------------------------\n");
|
||||
}
|
||||
+
|
||||
+ if (tests_passed != tests_run) {
|
||||
+ exit(1);
|
||||
+ }
|
||||
}
|
Loading…
Reference in a new issue