mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-24 11:39:46 -05:00
gnu: python-louvain: Fix test.
* gnu/packages/graph.scm (python-louvain)[source]: Add patch. * gnu/packages/patches/python-louvain-fix-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
d1c3de6583
commit
582b1f626f
3 changed files with 17 additions and 0 deletions
|
@ -1619,6 +1619,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
|
||||
%D%/packages/patches/pthreadpool-system-libraries.patch \
|
||||
%D%/packages/patches/python-chai-drop-python2.patch \
|
||||
%D%/packages/patches/python-louvain-fix-test.patch \
|
||||
%D%/packages/patches/python-random2-getrandbits-test.patch \
|
||||
%D%/packages/patches/python-poppler-qt5-fix-build.patch \
|
||||
%D%/packages/patches/python-w3lib-fix-test-failure.patch \
|
||||
|
|
|
@ -290,6 +290,7 @@ (define-public python-louvain
|
|||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "python-louvain" version))
|
||||
(patches (search-patches "python-louvain-fix-test.patch"))
|
||||
(sha256
|
||||
(base32 "0sx53l555rwq0z7if8agirjgw4ddp8r9b949wwz8vlig03sjvfmp"))))
|
||||
(build-system python-build-system)
|
||||
|
|
15
gnu/packages/patches/python-louvain-fix-test.patch
Normal file
15
gnu/packages/patches/python-louvain-fix-test.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
https://github.com/taynaud/python-louvain/commit/638804ae636dc65306900ef6518ca0a1c9202566.diff
|
||||
|
||||
diff --git a/test_community.py b/test_community.py
|
||||
index 1ee1976..566a4b1 100644
|
||||
--- a/test_community.py
|
||||
+++ b/test_community.py
|
||||
@@ -203,7 +203,7 @@ def test_karate(self):
|
||||
self.assertAlmostEqual(co.modularity(part, graph),
|
||||
co.modularity(part_weight,
|
||||
graph,
|
||||
- "test_weight"), places=2)
|
||||
+ "test_weight"), places=1)
|
||||
|
||||
part_res_low = co.best_partition(graph, resolution=0.1)
|
||||
self.assertTrue(
|
Loading…
Reference in a new issue