gnu: python-louvain: Fix test.

* gnu/packages/graph.scm (python-louvain)[source]: Add patch.
* gnu/packages/patches/python-louvain-fix-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register patch.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2022-09-22 19:44:10 +00:00 committed by Ludovic Courtès
parent d1c3de6583
commit 582b1f626f
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 17 additions and 0 deletions

View file

@ -1619,6 +1619,7 @@ dist_patch_DATA = \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
%D%/packages/patches/pthreadpool-system-libraries.patch \
%D%/packages/patches/python-chai-drop-python2.patch \
%D%/packages/patches/python-louvain-fix-test.patch \
%D%/packages/patches/python-random2-getrandbits-test.patch \
%D%/packages/patches/python-poppler-qt5-fix-build.patch \
%D%/packages/patches/python-w3lib-fix-test-failure.patch \

View file

@ -290,6 +290,7 @@ (define-public python-louvain
(origin
(method url-fetch)
(uri (pypi-uri "python-louvain" version))
(patches (search-patches "python-louvain-fix-test.patch"))
(sha256
(base32 "0sx53l555rwq0z7if8agirjgw4ddp8r9b949wwz8vlig03sjvfmp"))))
(build-system python-build-system)

View file

@ -0,0 +1,15 @@
https://github.com/taynaud/python-louvain/commit/638804ae636dc65306900ef6518ca0a1c9202566.diff
diff --git a/test_community.py b/test_community.py
index 1ee1976..566a4b1 100644
--- a/test_community.py
+++ b/test_community.py
@@ -203,7 +203,7 @@ def test_karate(self):
self.assertAlmostEqual(co.modularity(part, graph),
co.modularity(part_weight,
graph,
- "test_weight"), places=2)
+ "test_weight"), places=1)
part_res_low = co.best_partition(graph, resolution=0.1)
self.assertTrue(