mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 22:38:07 -05:00
gnu: libgit2: Update to 0.26.0.
* gnu/packages/version-control.scm (libgit2): Update to 0.26.0. Remove "libgit2-use-after-free.patch". * gnu/packages/patches/libgit2-use-after-free.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
6ce8fe4cd0
commit
58dce7bfb5
3 changed files with 3 additions and 29 deletions
|
@ -756,7 +756,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libgit2-0.25.1-mtime-0.patch \
|
||||
%D%/packages/patches/libgdata-fix-tests.patch \
|
||||
%D%/packages/patches/libgdata-glib-duplicate-tests.patch \
|
||||
%D%/packages/patches/libgit2-use-after-free.patch \
|
||||
%D%/packages/patches/libjxr-fix-function-signature.patch \
|
||||
%D%/packages/patches/libjxr-fix-typos.patch \
|
||||
%D%/packages/patches/liboop-mips64-deplibs-fix.patch \
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
This patch is taken from <https://github.com/libgit2/libgit2/pull/4122>;
|
||||
we need it to fix the use-after-free error in 'git_commit_extract_signature'
|
||||
reported at <https://github.com/libgit2/libgit2/issues/4118>.
|
||||
|
||||
From ade0d9c658fdfc68d8046935f6908f033fe7a529 Mon Sep 17 00:00:00 2001
|
||||
From: Patrick Steinhardt <ps@pks.im>
|
||||
Date: Mon, 13 Feb 2017 13:46:17 +0100
|
||||
Subject: [PATCH 3/3] commit: avoid possible use-after-free
|
||||
|
||||
diff --git a/src/commit.c b/src/commit.c
|
||||
index 89a4db1..05b70a9 100644
|
||||
--- a/src/commit.c
|
||||
+++ b/src/commit.c
|
||||
@@ -766,8 +766,9 @@ int git_commit_extract_signature(git_buf *signature, git_buf *signed_data, git_r
|
||||
if (git_buf_oom(signature))
|
||||
goto oom;
|
||||
|
||||
+ error = git_buf_puts(signed_data, eol+1);
|
||||
git_odb_object_free(obj);
|
||||
- return git_buf_puts(signed_data, eol+1);
|
||||
+ return error;
|
||||
}
|
||||
|
||||
giterr_set(GITERR_OBJECT, "this commit is not signed");
|
|
@ -334,7 +334,7 @@ (define-public git@2.10
|
|||
(define-public libgit2
|
||||
(package
|
||||
(name "libgit2")
|
||||
(version "0.25.1")
|
||||
(version "0.26.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/libgit2/libgit2/"
|
||||
|
@ -342,9 +342,8 @@ (define-public libgit2
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1cdwcw38frc1wf28x5ppddazv9hywc718j92f3xa3ybzzycyds3s"))
|
||||
(patches (search-patches "libgit2-use-after-free.patch"
|
||||
"libgit2-0.25.1-mtime-0.patch"))))
|
||||
"1fdk9yhwvl1w1z71ykzcvgh4nsf8scxcbclz5anh98zpplmhmisa"))
|
||||
(patches (search-patches "libgit2-0.25.1-mtime-0.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
Loading…
Reference in a new issue