mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: util-linux: Remove dependency on Perl.
* gnu/packages/linux.scm (util-linux)[source](patches): New field. * gnu/packages/patches/util-linux-perl.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
ac52e80b4e
commit
5a6a3ba43a
3 changed files with 25 additions and 9 deletions
|
@ -361,6 +361,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/superlu-dist-scotchmetis.patch \
|
gnu/packages/patches/superlu-dist-scotchmetis.patch \
|
||||||
gnu/packages/patches/tcsh-fix-autotest.patch \
|
gnu/packages/patches/tcsh-fix-autotest.patch \
|
||||||
gnu/packages/patches/teckit-cstdio.patch \
|
gnu/packages/patches/teckit-cstdio.patch \
|
||||||
|
gnu/packages/patches/util-linux-perl.patch \
|
||||||
gnu/packages/patches/valgrind-glibc.patch \
|
gnu/packages/patches/valgrind-glibc.patch \
|
||||||
gnu/packages/patches/vpnc-script.patch \
|
gnu/packages/patches/vpnc-script.patch \
|
||||||
gnu/packages/patches/w3m-fix-compile.patch \
|
gnu/packages/patches/w3m-fix-compile.patch \
|
||||||
|
|
|
@ -317,15 +317,15 @@ (define-public util-linux
|
||||||
(package
|
(package
|
||||||
(name "util-linux")
|
(name "util-linux")
|
||||||
(version "2.21")
|
(version "2.21")
|
||||||
(source
|
(source (origin
|
||||||
(origin
|
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://kernel.org/linux/utils/"
|
(uri (string-append "mirror://kernel.org/linux/utils/"
|
||||||
name "/v" version "/"
|
name "/v" version "/"
|
||||||
name "-" version ".2" ".tar.xz"))
|
name "-" version ".2" ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1rpgghf7n0zx0cdy8hibr41wvkm2qp1yvd8ab1rxr193l1jmgcir"))))
|
"1rpgghf7n0zx0cdy8hibr41wvkm2qp1yvd8ab1rxr193l1jmgcir"))
|
||||||
|
(patches (list (search-patch "util-linux-perl.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags '("--disable-use-tty-group"
|
`(#:configure-flags '("--disable-use-tty-group"
|
||||||
|
|
15
gnu/packages/patches/util-linux-perl.patch
Normal file
15
gnu/packages/patches/util-linux-perl.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
Use this common trick that exploits similarities between sh and Perl syntax
|
||||||
|
to avoid a hard dependency on Perl. Instead, this script will work only
|
||||||
|
when 'perl' is available in $PATH.
|
||||||
|
|
||||||
|
--- util-linux-2.21.2/misc-utils/chkdupexe.pl 2012-05-15 13:51:45.000000000 +0200
|
||||||
|
+++ util-linux-2.21.2/misc-utils/chkdupexe.pl 2014-06-01 22:46:06.000000000 +0200
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
-#!@PERL@ -w
|
||||||
|
-#
|
||||||
|
+eval '(exit $?0)' && eval 'exec perl -wS "$0" ${1+"$@"}'
|
||||||
|
+ & eval 'exec perl -wS "$0" $argv:q'
|
||||||
|
+ if 0;
|
||||||
|
# chkdupexe version 2.1.1
|
||||||
|
#
|
||||||
|
# Simple script to look for and list duplicate executables and dangling
|
Loading…
Reference in a new issue