mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-13 18:36:14 -05:00
gnu: gst-libav: Update to 1.19.2.
* gnu/packages/gstreamer.scm (gst-libav): Update to 1.19.2. [source]: Re-indent origin. Delete patches field. [meson]: Use meson-0.55. * gnu/packages/patches/gst-libav-64channels-stack-corruption.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
This commit is contained in:
parent
b59ad1e176
commit
5be7ae7bf3
3 changed files with 10 additions and 43 deletions
|
@ -1216,7 +1216,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/grub-efi-fat-serial-number.patch \
|
||||
%D%/packages/patches/grub-setup-root.patch \
|
||||
%D%/packages/patches/gspell-dash-test.patch \
|
||||
%D%/packages/patches/gst-libav-64channels-stack-corruption.patch \
|
||||
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
|
||||
%D%/packages/patches/guile-2.2-skip-so-test.patch \
|
||||
|
|
|
@ -949,18 +949,17 @@ (define-public gst-plugins-ugly
|
|||
(define-public gst-libav
|
||||
(package
|
||||
(name "gst-libav")
|
||||
(version "1.18.4")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri
|
||||
(string-append
|
||||
"https://gstreamer.freedesktop.org/src/" name "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(patches (search-patches "gst-libav-64channels-stack-corruption.patch"))
|
||||
(sha256
|
||||
(base32 "15n3x3vhshqa3icw93g4vqmqd46122anzqvfxwn6q8famlxlcjil"))))
|
||||
(version "1.19.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri(string-append
|
||||
"https://gstreamer.freedesktop.org/src/" name "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0rv4vxrqvlc8lm1afcg934k961gysx94xshmb5jv4xpwjkl8akzw"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
`(#:meson ,meson-0.55))
|
||||
(native-inputs
|
||||
`(("perl" ,perl)
|
||||
("pkg-config" ,pkg-config)
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
Fix a stack corruption when handling files with more than 64 audio
|
||||
channels:
|
||||
|
||||
https://gstreamer.freedesktop.org/security/sa-2021-0005.html
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://gitlab.freedesktop.org/gstreamer/gst-libav/-/commit/dcea8baa14a5fc3b796d876baaf2f238546ba2b1
|
||||
|
||||
diff --git a/ext/libav/gstavcodecmap.c b/ext/libav/gstavcodecmap.c
|
||||
index b5be4bb7a5f2712f78383da9319754a8849e3307..be22f22cf5c7c7b22b13e44b10999adaacbcca2b 100644
|
||||
--- a/ext/libav/gstavcodecmap.c
|
||||
+++ b/ext/libav/gstavcodecmap.c
|
||||
@@ -102,7 +102,7 @@ gst_ffmpeg_channel_layout_to_gst (guint64 channel_layout, gint channels,
|
||||
guint nchannels = 0;
|
||||
gboolean none_layout = FALSE;
|
||||
|
||||
- if (channel_layout == 0) {
|
||||
+ if (channel_layout == 0 || channels > 64) {
|
||||
nchannels = channels;
|
||||
none_layout = TRUE;
|
||||
} else {
|
||||
@@ -163,7 +163,7 @@ gst_ffmpeg_channel_layout_to_gst (guint64 channel_layout, gint channels,
|
||||
} else {
|
||||
guint i;
|
||||
|
||||
- for (i = 0; i < nchannels; i++)
|
||||
+ for (i = 0; i < nchannels && i < 64; i++)
|
||||
pos[i] = GST_AUDIO_CHANNEL_POSITION_NONE;
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue