gnu: mia: Fix build with VTK 9.2.

* gnu/packages/patches/mia-vtk92.patch,
gnu/packages/patches/mia-vtk-version.patch: New files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/image-processing.scm (mia)[source](patches): Add them.
This commit is contained in:
Marius Bakke 2022-11-19 19:07:32 +01:00
parent fceeed3946
commit 5c9164d5fb
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
4 changed files with 34 additions and 1 deletions

View file

@ -1538,6 +1538,8 @@ dist_patch_DATA = \
%D%/packages/patches/mhash-keygen-test-segfault.patch \ %D%/packages/patches/mhash-keygen-test-segfault.patch \
%D%/packages/patches/mia-fix-boost-headers.patch \ %D%/packages/patches/mia-fix-boost-headers.patch \
%D%/packages/patches/mia-vtk9.patch \ %D%/packages/patches/mia-vtk9.patch \
%D%/packages/patches/mia-vtk92.patch \
%D%/packages/patches/mia-vtk-version.patch \
%D%/packages/patches/mingw-w64-6.0.0-gcc.patch \ %D%/packages/patches/mingw-w64-6.0.0-gcc.patch \
%D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \ %D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \
%D%/packages/patches/mingw-w64-reproducible-gendef.patch \ %D%/packages/patches/mingw-w64-reproducible-gendef.patch \

View file

@ -201,7 +201,9 @@ (define-public mia
(base32 (base32
"0qpcd3n26q52dpyibm11f5l6cgscdr54p2jish39gc3p1f5h3ws1")) "0qpcd3n26q52dpyibm11f5l6cgscdr54p2jish39gc3p1f5h3ws1"))
(patches (search-patches "mia-fix-boost-headers.patch" (patches (search-patches "mia-fix-boost-headers.patch"
"mia-vtk9.patch")))) "mia-vtk9.patch"
"mia-vtk92.patch"
"mia-vtk-version.patch"))))
(build-system cmake-build-system) (build-system cmake-build-system)
(arguments (arguments
`(#:configure-flags `(#:configure-flags

View file

@ -0,0 +1,15 @@
The VTK_MAJOR_VERSION macro is not available by default in newer versions.
This is a hack to expose it without changing all imports.
diff --git a/addons/vtk/CMakeLists.txt b/addons/vtk/CMakeLists.txt
--- a/addons/vtk/CMakeLists.txt
+++ b/addons/vtk/CMakeLists.txt
@@ -36,6 +36,8 @@ IF(WITH_VTKIO)
ELSE()
SET(SELECTED_VTK_LIBS ${VTK_MODULES_REQUESTED})
ENDIF()
+
+ add_compile_definitions(VTK_MAJOR_VERSION=${VTK_VERSION_MAJOR})
SET(VTK_LINK_LIBS_MESH ${SELECTED_VTK_LIBS} miamesh)
SET(VTK_LINK_LIBS_3D ${SELECTED_VTK_LIBS} mia3d)

View file

@ -0,0 +1,14 @@
Boolean pixel values are no longer supported in VTK 9.2.
diff --git a/addons/vtk/test_vtkimage.cc b/addons/vtk/test_vtkimage.cc
--- a/addons/vtk/test_vtkimage.cc
+++ b/addons/vtk/test_vtkimage.cc
@@ -206,7 +206,7 @@ BOOST_AUTO_TEST_CASE_TEMPLATE( test_mhd_write_read, T, type_mhd )
unlink(zrawfilename.str().c_str());
}
-#if VTK_MAJOR_VERSION >= 7
+#if VTK_MAJOR_VERSION >= 7 && VTK_MAJOR_VERSION < 9
BOOST_AUTO_TEST_CASE( test_simple_write_read_bool )
{
C3DBounds size(2, 3, 4);